Problems with crossover cable

Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

I am having trouble with a crossover cable under windows
xp. The system doesn't recognize that the cable is
connected to the nic, but on a win98se computer, it works
perfectly fine. I have tried switching the NICs so that
is not the problem and I am suspecting that Windows XP
has issues with crossover cables. Is there a patch or fix
for this?
11 answers Last reply
More about problems crossover cable
  1. Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

    How are you using the crossover cable? What is it doing under Win98SE that
    you're happy with? I'm pretty sure you can't "mess up" the cable's
    functionality with an operating system, but if you're using it to connect
    two computers directly for peer services (e.g. sharing folders) then you
    need to have static IP addresses on each machine. This may be your setting
    in '98 that's not set in XP. Just an educated guess from what you said
    above!
  2. Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

    Windows XP doesn't have any problem with crossover cables.


    <anthonyvidal@prodigy.net> wrote in message
    news:29b301c49f84$e2f4a5c0$a501280a@phx.gbl...
    >I am having trouble with a crossover cable under windows
    > xp. The system doesn't recognize that the cable is
    > connected to the nic, but on a win98se computer, it works
    > perfectly fine. I have tried switching the NICs so that
    > is not the problem and I am suspecting that Windows XP
    > has issues with crossover cables. Is there a patch or fix
    > for this?
  3. Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

    >-----Original Message-----
    >I am having trouble with a crossover cable under windows
    >xp. The system doesn't recognize that the cable is
    >connected to the nic, but on a win98se computer, it
    works
    >perfectly fine. I have tried switching the NICs so that
    >is not the problem and I am suspecting that Windows XP
    >has issues with crossover cables. Is there a patch or
    fix
    >for this?
    >.
    >
    Well, under Xp, there isn't any ip address for the NIC so
    the first replyer was right. I have it set to
    automatically get the ip but when I go into ipconfig from
    the comand prompt, there is no ip address for any nic
    that I put into any Xp system(home, pro, sp1, and sp2,
    OEM, or Microsoft product I have tried)
  4. Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

    >-----Original Message-----
    >How are you using the crossover cable? What is it doing
    under Win98SE that
    >you're happy with? I'm pretty sure you can't "mess up"
    the cable's
    >functionality with an operating system, but if you're
    using it to connect
    >two computers directly for peer services (e.g. sharing
    folders) then you
    >need to have static IP addresses on each machine. This
    may be your setting
    >in '98 that's not set in XP. Just an educated guess
    from what you said
    >above!

    I just have one end connected to the NIC is either
    computer. Under ipconfig, it says that the media is
    disconnected from my NIC
  5. Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

    I set up the ip numbers, but under ipconfig, the only
    thinds undr my NIC in my XP computer is it's physical
    adddress and it says media disconnected, and yes, it is a
    crossover cable.
  6. Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

    That won't work. Where will it get the IP address from?

    "Automatically get IP address" requires a DHCP server, which only runs on
    routers and a server OS like Windows Server 2003. You have to manually
    assign IP addresses when using a crossover cable. Make sure they're in the
    same subnet - for instance, assign one computer 192.168.1.10 and the other
    192.168.1.11.

    And you're sure that this is a crossover cable? Look at the plugs on teh
    cable - is the middle pair switched? If not, it's not a crossover cable.


    <anthonyvidal@prodigy.net> wrote in message
    news:342b01c4a01c$e9352840$a501280a@phx.gbl...

    >>
    > Well, under Xp, there isn't any ip address for the NIC so
    > the first replyer was right. I have it set to
    > automatically get the ip but when I go into ipconfig from
    > the comand prompt, there is no ip address for any nic
    > that I put into any Xp system(home, pro, sp1, and sp2,
    > OEM, or Microsoft product I have tried)
  7. Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

    > I set up the ip numbers, but under ipconfig, the only
    > thinds undr my NIC in my XP computer is it's physical
    > adddress and it says media disconnected, and yes, it is a
    > crossover cable.

    Hmmm. Usually "media disconnected" is a hardware issue (that is, cord
    unplugged), but if it worked for '98 then it can't be that. If you set each
    computer to use a specific IP address, those should come up in ipconfig/all.
    Can you post the result of ipconfig/all (of course blotting out any specific
    information you feel you need to keep secure, but leaving the line title.
    Nothing in that report should be sensitive, but I want you to feel secure),
    because since Windows NT 3.5 ipconfig usually helps for this kind of thing.

    > And you're sure that this is a crossover cable? Look at the plugs on
    > teh [sic] cable - is the middle pair switched? If not, it's not a
    > crossover cable.

    As far as the correct wiring, it should be right if it worked under '98, but
    the correct order is:
    plug 1: orange, orange/white, green, blue/white, blue, green/white, brown,
    brown/white and
    plug 2: green, green/white, orange, blue/white, blue, orange/white, brown,
    brown/white,
    OR
    plug 2: green, green/white, orange, brown/white, brown, orange/white, blue,
    blue/white.
    That's from memory, so if it's wrong someone correct me. Otherwise, if
    that's not the order of the wires when you look through the clear part of
    the plug, I don't know what kind of crazy moon network was working on your
    '98 setup :)

    Assuming your cable and NIC card are good (that is, work under Win98) then
    we're to the Network Settings dialog, which should be diagnosed by the
    ipconfig/all results.
  8. Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

    C:\Documents and Settings\Anthony>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : ANTHONY-
    U5839H9
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

    Media State . . . . . . . . . . . : Media
    disconnected
    Description . . . . . . . . . . . : Realtek
    RTL8139 Family PCI Fast Ethe
    rnet NIC
    Physical Address. . . . . . . . . : 00-90-47-04-
    06-DE

    PPP adapter SBC Yahoo! (Troy):

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : WAN
    (PPP/SLIP) Interface
    Physical Address. . . . . . . . . : 00-53-45-00-
    00-00
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 4.157.74.207
    Subnet Mask . . . . . . . . . . . :
    255.255.255.255
    Default Gateway . . . . . . . . . : 4.157.74.207
    DNS Servers . . . . . . . . . . . : 151.164.1.8
    206.13.28.12

    I am sure it is a crossover cable, the wiring in it goes:
    plug 1: green, green, white, blue, blue, orange, brown,
    brown
    Plug 2: orange, orange, green, blue, blue, green, brown ,
    brown
  9. Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

    > Ethernet adapter Local Area Connection:
    > Media State . . . . . . . . . . . : Media disconnected
    > Description . . . . . . . . . . . : Realtek ...
    > Physical Address. . . . . . . . . : 00-90-47-04-06-DE

    You're right about the cable, it's a crossover.

    Assuming you do not have any spyware dialers, nor any broadband utilities
    installed, read on. If you do have broadband utilities (e.g. PPPoE virtual
    adapters), they hijack these settings and I can't help you. If you are
    clean, then...

    Right-Click on "Network Neighborhood" and choose properties. In the network
    connections window, choose your Realtek adapter ("Local Area Connection"
    will be the name), right-click and choose properties. In the "General" tab
    there should be a scrolling box with several items, one of which is
    "Internet Protocol(TCP/IP)." Click on that, and then the bright
    "Properties" button directly beneath the scrolling box. In the general tab
    choose the "Use the following IP address" bullet, and fill in:

    IP Address: 168.192.2.5
    Subnet Mask: 255.255.255.0
    Default Gateway: 168.192.2.1 (will be ignored, but I don't think they like
    it blank).
    Then choose the "Use the following DNS Server addresses"
    Preferred DNS Server: 131.183.1.4
    Alternate DNS Server: 131.183.1.1 (These will also be ignored, but shouldn't
    be blank).

    Click "OK" about 25 times, then restart. On the other computer, do the same
    EXCEPT make the IP Address 168.192.2.6 instead (same first three numbers,
    different last one). Reboot there too.

    The specific numbers aren't that important (so you can use variants you know
    work), but I can see that they're not there in IPConfig. After you do this,
    then your IPConfig results should have more info for this adapter.

    If this doesn't clear up the media disconnected, then there's a 99% chance
    you've got a hardware problem (again, assuming there's not something
    chomping up your Ethernet protocol like a PPPoE driver or spyware dialer).
  10. Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

    This is till what I get in ipconfig after entering that
    info and rechecking it three times:

    C:\Documents and Settings\Anthony>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : ANTHONY-
    U5839H9
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

    Media State . . . . . . . . . . . : Media
    disconnecte
    Description . . . . . . . . . . . : Realtek
    RTL8139 F
    rnet NIC
    Physical Address. . . . . . . . . : 00-90-47-04-
    06-DE

    go here to see some images:
    http://www.angelfire.com/alt2/anthonyvidal/br666networkcon
    n.html
  11. Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

    > This is till what I get in ipconfig after entering that
    > info and rechecking it three times:
    > ...
    > go here to see some images:
    > http://www.angelfire.com/alt2/anthonyvidal/br666networkconn.html

    You couldn't have done better! The following article suggested that you
    disable your firewire (1394) network connection,
    http://www.annoyances.org/exec/forum/winxp/1076593857 , but I don't know
    that this is actually necessary. If I were over someone's house and this
    was on their screen like it is on yours, I'd conclude that you had a
    hardware problem (either a bad conductor in the crossover, or one of the
    Ethernet cards bad). I'm sorry I can't give you anything better!
Ask a new question

Read More

Routers Cable Windows XP Networking