Sign in with
Sign up | Sign in
Your question

Error 13: invalid data --trying to install new hrd

Tags:
Last response: in Windows 2000/NT
Share
November 1, 2002 4:33:37 PM

This isn't my problem but it sure is an interesting one i want to see a solution for also.

here is the original post:

I keep getting the infamous "Error 13: The data is invalid" error :-(

No luck with REGEDT32 -- any, ANY more hints very much appreciated!

It started the very first day with the on-board soundcard. I gave up (which
also does not install the game port or MIDI stuff). But today I found it
also won't install the Mass Storage Device drivers for my digital camera on
any USB port (which themselves work fine and are also used for my Wacom
Graphire USB tablet).

I've tried the security settings in REGEDT32 -- in fact I even granted Full
Control to other keys as well (like the whole parent CurrentControlSet,
SYSTEM and HARDWARE) but all to no avail. The first days I worked only with
the Administrator account. I've moved my only PCI card (ethernet) to other
slots, and even fully removed and uninstalled it. Nothing helps. The most
annoying thing is that I cannot even find anything on
http://support.microsoft.com while Google proves that many encounter the
very same problem -- and many are helped with REGEDT32. This makes me wonder
if I should be using different keywords on the MS support site...?

For who understands it: C:\WINNT\setupapi.log shows below...

I have no slave on my primary IDE. Could that cause problems?

Thanks a lot,
Arjan.

----------------------------------------------------------------------

Asus P4S533-E
AwardBIOS (Interrupt Mode: APIC; Plug & Play O/S: No)
On-board sound C-Media CMI8738 6CH
Samsung 256 MB DDR PC-266
IDE Primary Western Digital WD200EB/AB 20 GB
IDE Secundary Master Seagate ST36531A 6 GB
IDE Secundary Salve CD-952E/TKU CD-Rom
Intel Celeron 1700 MHz
NVidia Riva TNT2 64MB AGP
PCI Fast Ethernet Realtek RTL8139 (Edimax)
No modem
Wacom Graphire USB
Logitech Mouseman PS/2
Microsoft Natural keyboard PS/2
Nikon Coolpix 4500 USB Mass Storage Device

Windows 2000 Professional 5.00.2195 + SP3
Windows SQL Server Developer + SP2
McAfee v4.5.1
Borland Delphi 6
Control Panel, System, Device Manager, Driver Signing, Verification: Warn

----------------------------------------------------------------------

C:\WINNT\setupapi.log

Munged cmdline: "C:\WINNT\system32\rundll32.exe" shell32.dll,Control_RunDLL
"C:\WINNT\System32\hdwwiz.cpl",Add/Remove Hardware

EXE name: C:\WINNT\system32\rundll32.exe
Set selected driver.
Device install function: DIF_SELECTBESTCOMPATDRV.
Selecting best compatible driver caused error: Error 0xe0000228: There are
no compatible drivers for this device.

Completed default installer, error: Error 0xe0000228: There are no
compatible drivers for this device.

Set selected driver.

Searching for hardware ID(s):
pci\ven_13f6&dev_0111&subsys_80e21043&rev_10,pci\ven_13f6&dev_0111&subsys_80
e21043,pci\ven_13f6&dev_0111&cc_040100,pci\ven_13f6&dev_0111&cc_0401

Searching for compatible ID(s):
pci\ven_13f6&dev_0111&rev_10,pci\ven_13f6&dev_0111,pci\ven_13f6&cc_040100,pc
i\ven_13f6&cc_0401,pci\ven_13f6,pci\cc_040100,pci\cc_0401

Enumerating files e:\drivers\audio\c-media\8738\win_xp\drv\*.inf

The file (e:\drivers\audio\c-media\8738\win_xp\drv\CMAUDIO.INF) is not
digitally signed, ignoring driver date.

Found PCI\VEN_13F6&DEV_0111 in
e:\drivers\audio\c-media\8738\win_xp\drv\CMAUDIO.INF; Device: CMI8738/C3DX
PCI Audio Device; Driver: CMI8738/C3DX PCI Audio Device; Provider: C-Media;
Mfg: C-Media; Section: PCI1
Decorated section name: PCI1.NTx86

Found PCI\VEN_13F6&DEV_0111&REV_10 in
e:\drivers\audio\c-media\8738\win_xp\drv\CMAUDIO.INF; Device: CMI8738/C3DX
PCI Audio Device; Driver: CMI8738/C3DX PCI Audio Device; Provider: C-Media;
Mfg: C-Media; Section: PCI1
Decorated section name: PCI1.NTx86

Found PCI\VEN_13F6&DEV_0111&SUBSYS_80E21043 in
e:\drivers\audio\c-media\8738\win_xp\drv\CMAUDIO.INF; Device: CMI8738/C3DX
PCI Audio Device; Driver: CMI8738/C3DX PCI Audio Device; Provider: C-Media;
Mfg: C-Media; Section: PCI13
Decorated section name: PCI13.NTx86

Searching for hardware ID(s):
pci\ven_13f6&dev_0111&subsys_80e21043&rev_10,pci\ven_13f6&dev_0111&subsys_80
e21043,pci\ven_13f6&dev_0111&cc_040100,pci\ven_13f6&dev_0111&cc_0401

Searching for compatible ID(s):
pci\ven_13f6&dev_0111&rev_10,pci\ven_13f6&dev_0111,pci\ven_13f6&cc_040100,pc
i\ven_13f6&cc_0401,pci\ven_13f6,pci\cc_040100,pci\cc_0401
:
:
:
Selected best compatible driver.
Device install function: DIF_INSTALLDEVICEFILES.

Doing copy-only install of
PCI\VEN_13F6&DEV_0111&SUBSYS_80E21043&REV_10\3&61AAA01&0&28.

Installing section PCI13.NTx86 from
e:\drivers\audio\c-media\8738\win_2k\drv\cmaudio.inf.

Install failed, attempting to restore original files.

Device install finished with error Error 13: The data is invalid.
Completed default installer, error: Error 13: The data is invalid.
Set selected driver.

Installing NULL driver for
PCI\VEN_13F6&DEV_0111&SUBSYS_80E21043&REV_10\3&61AAA01&0&28.

Device install finished successfully
(PCI\VEN_13F6&DEV_0111&SUBSYS_80E21043&REV_10\3&61AAA01&0&28).

----------------------------------------------------------------------

Munged cmdline: C:\WINNT\system32\services.exe
EXE name: C:\WINNT\system32\services.exe

Searching for hardware ID(s):
usb\vid_04b0&pid_010a&rev_0100,usb\vid_04b0&pid_010a

Searching for compatible ID(s):
usb\class_08&subclass_06&prot_50,usb\class_08&subclass_06,usb\class_08

Enumerating files C:\WINNT\inf\*.inf

Found USB\Class_08&SubClass_06&Prot_50 in C:\WINNT\inf\usbstor.inf; Device:
USB Mass Storage Device; Driver: USB Mass Storage Device; Provider:
Microsoft; Mfg: Microsoft; Section: USBSTOR_BULK
Decorated section name: USBSTOR_BULK.NT
Device install function: DIF_SELECTBESTCOMPATDRV.

Selected driver installs from section USBSTOR_BULK in
c:\winnt\inf\usbstor.inf.

Changed class GUID of device to {36FC9E60-C465-11CF-8056-444553540000}.
Set selected driver.
Selected best compatible driver.
Device install function: DIF_INSTALLDEVICEFILES.
Doing copy-only install of USB\VID_04B0&PID_010A\000004505943.
Installing section USBSTOR_BULK.NT from c:\winnt\inf\usbstor.inf.

Install failed, attempting to restore original files.
Device install finished with error Error 13: The data is invalid.
Completed default installer, error: Error 13: The data is invalid.

----------------------------------------------------------------------

Wow, you've read all the way to the end -- thanks! :-)

**********
So far no one knows...how about you tech savvy people here @tomshardware???

TIA :) )

The error code is generated by the windows installer --that's all i've found out so far.

but what is causing the problem / why/ and how fix is what we would like to know. :) 
November 2, 2002 2:50:12 PM

Last time I had an error like that (was also with USB devices) I was not able to reslove it until switching to a different motherboard with a different USB bridge chipset. The problem one was a Shuttle Athlon AK series board. Then I switched it for a Gigabyte. Didn't reinstall windows, just updated the drivers, and suddenly all my USB devices worked again. So my personal feeling is that it was a driver issue, and not related to anything with the registry. Or possibly a BIOS setting? But I was unable to find it.
!