Sign in with
Sign up | Sign in
Your question

Dual boot XP/Mand on 500 Cel 10g

Last response: in Linux/Free BSD
Share
November 2, 2002 7:23:15 AM

I just want to confirm a few things. I'm currently running a 500 MHz Celeron with 192MB Ram, a 10GB hard drive, and 4MB onboard vid. When I installed xp I left about 2.5 GB of space available at the end of the drive so I could install Mandrake v9. I was about to install mandrake when I thought I’d check out toms first, as you guys know your stuff, (and I might be able to save myself some painful mistakes).

I was originally going to 'try', to boot Linux from a floppy because I kept reading about the 1024th cylinder limit, and I didn't want to get too techo with moving files around and stuff. Will I have this problem with mandrake 9? I read over some posts that said mandrake uses the grub boot loader which doesn't have this limit. I also have little idea of how I should partiton my file system, I started off with a basic idea but after reading over some posts I’m starting to get a little unsure of what's going on. I know I need a swap file (256MB?). The system is eventually going to be turned into a headless server, running only Linux, but at the moment I just want to be able to practice with Linux. Being able to dual boot would be nice but I don’t want to fux my system, as I’ve already had to reformat the drive twice, and I read about how dual booting changes the master boot record. I haven’t figured out how to back up e-mail through outlook, which is why if I lose my mum’s stuff again she may not take it to well, lol.

How hard is this installation going to be? I heard mandrake is the best for beginners so if any one has some helpful info on 9, I’d appreciate It, I was hoping I would just be able to put the CD in and configure the stuff with a few clicks but after reading some of the posts around, I thought their may be some stuff I need to know first.

Thanks heaps in advance.
November 3, 2002 11:12:06 AM

It should be sweet. Silverpig seems to be The Man regarding Mandrake 9, so maybe he can suggest how it'll go with the installer.

The old 1024 limit is pretty much history, and grub doesn't care about it so try it and see. The MBR thing is accurate, but you can make a boot floppy, and tell it not to install the bootloader on the HD.

When going through the install, just make sure you read the Screens before clicking "Next" :-)

Good luck.

<i>Do I look like I care?</i>
November 3, 2002 9:17:11 PM

Thanks for the reply

I ended up installing on a different computer, as I didn't want to destroy my gateway and not have anyway to get on the net. Everything went fairly smoothly until I tried to ping my network, I keep getting host unreachable, on both machines, I know both cards are good as they'll ping themselves.

When I ran the command dmesg |more, I got a few things which I thought didn't seem right.

The first was a warning for device 03:01
"NTFS-fs warning (device 03:01): parse-options(): option iocharset is deprecated. Please use option n ls=<charsetname> in the future"

I also got a "8139too fast Ethernet driver 0.9.25

And the most notable one
"NETDEV WATCHDOG: eth0: transmit timed out
eth0:tx queue start entry 4 dirty entry 0".
Their's several other lines about eth0 under this, which it repeated about ten times.

I don't really know how to continue, I'll keep searching though, if anyone can clear this up I’d appreciate it a lot.
Related resources
Can't find your answer ? Ask !
November 4, 2002 2:35:52 PM

During the install did you enable DHCP?

Some day I'll be rich and famous for inventing a device that allows you to stab people in the face over the internet.
November 5, 2002 12:48:21 AM

No, I’ve been following a magazine article, and it never said I needed it. I was just following instructions, I got up to the part where it suggests I ping the network, when I keep getting the host unreachable error. (The article is for mandrake 8.2 however)

I spoke to one of my teachers and she thought it might be a driver problem with the network card, I checked out the compatibility at the mandrake website and my card is "known" to work with Linux, but not officially certified. I've also visited the manufacturers website, and they have support for Redhat and Suse, but not specifically mandrake, theirs also a Linux driver, which I assumed meant it was compatible with the rest, so I’m about to check that out now.

It’s confusing though as I’ve been told that it should work straight from install, I’m thinking I’m probably about to download a driver I’ve already got.

Thanks for the help silverpig
November 5, 2002 4:02:32 AM

How's your network set up?

One thing you could try right away is run netconf and enable dhcp. It's easy to try, and may be what's messing you up, depeding on how your network is set up. That way you don't have to wait for me to think about your setup, what could be wrong, post...

Some day I'll be rich and famous for inventing a device that allows you to stab people in the face over the internet.
November 6, 2002 12:11:54 AM

It’s a fairly standard network; I've got two computers connected via crossover, my gateway computer acts as the DHCP server. The only other notable things I can thinks of are;
• I've installed ipx/spx
• I’ve disabled the xp firewall
• I'm running AVG free anti-virus
• and I've installed user accounts (some of which contain protected files, which I always though stuffed around with things)

I reinstalled mandrake following a different article, and I enabled dhcp, but it made eth0 fail, (the second time that’s happened). If you've got any ideas as to what I can do I’d be very grateful. All my options aren't really very helpful. It's been suggested I buy new network cards or compile my own software.

This is really getting irritating, as I’m keen to see what I can do with Linux.
November 6, 2002 2:29:02 AM

I've never had a problem with linux and ethernet cards. I just enable DHCP during the install, make sure it's connected to a DHCP server, and it works every time. It must be a hardware issue. If you can borrow an ethernet card, or get one for cheap, I'd suggest that.

Some day I'll be rich and famous for inventing a device that allows you to stab people in the face over the internet.
November 7, 2002 9:05:10 AM

Thanks for the help. It must be the Realtek cards as I have two, when I tried to install Redhat 7.3 a little while ago on a different pc; I had the same problem, ‘eth0 fails’. I'll see if a friends got a network card I can borrow, other than that I guess I'll keep searching. Thanks again for the time.
!