Is this memory not compatible with AMD64's or mobo

Ok I have an AMD Sempron 3100+ Socket 754 and a MSI K8M Neo-V. Link to motherboard is at bottom of my post. I am running on a 256MB stick of DDR333 MHz ram. yes I know it's not much but it's all I need and can't really afford much more. Now from what I have been reading up on is that I need at least 400MHz memory for the new CPU's such as the Sempron's for socket754 and also the Athlon64's.

Right now the problem I am experiencing is the system will seem to boot but I am getting no video. Unfortunatly I can't update the bios because obviously I can't see the screen. It has the original BIOS in it and it is supposed to supoprt the CPU and everything I have in there, the motherboard also says it supports DDR 266/333/400MHz which I am using 333MHz ram. I have also tried the onboard video/ seperate AGP/ and a PCI video card all that will not display the darn video. I can't get a beep code because the system will also not beep. I've also tried resetting the BIOS several times to no avail.

If anyone can help me with this problem I would appreciate it as I need to go out tomorrow and fix this problem before I leave for the weekend since other people will be using this computer. Thank you for any help you guys can provide on here.

Link to motherboard:

http://www.msicomputer.com/product/p_spec.asp?model=K8M_Neo-V&class=mb
5 answers Last reply
More about memory compatible amd64 mobo
  1. If it were the ram, you would get a beep. Does the hsf spin? Do the drives start? Check to make sure that all the cables are connected properly. Try to see if you can get a post without any drives.
  2. Unplug everyting except mem, vga and cpu (=fan&heatsink obviously). If you don't get anything that way you might be in trouble.
  3. Tried this guys, and that's not it. Yes everything spins up and everything but I get no video. Are you sure the new Socket 754's will accept DDR333 or do you think I will need to buy DDR400?
  4. Have you posted in the memory forum?

    To save us both time, assume I know EVERYTHING :tongue:
  5. Try it with no memory and see if you get some beeps. If no beeps then the motherboard isnt even getting to the memory detection of the post.
Ask a new question

Read More

CPUs