Sign in with
Sign up | Sign in
Your question
Solved

Stop CPU Downclock on Battery

Last response: in Laptops & Notebooks
Share
a b à CPUs
September 4, 2010 10:23:08 PM

Ok so I just bought a MSI GX640. Its a great laptop for people who like to game but still have some protability. I like to play games in class so its great for me lol. The GX640 has a i5 450 which when plugged in hits 2.6ghz but whenever I go off of battery it limits the cpu to 1.3gz. I figured out how to stop the same effect on the gpu by turning off ATI powerplay so my gpu stays at max clocks when I game on battery but my cpu is limited to 1.3ghz. This obviously has a negative effect on gaming. Causes my fps to drop. Does anyone know how to stop this from happening? I have messed with the power settings in the control panel. Made the cpu minimum power state 100% on battery and it still limits the cpu to 1.3ghz. It is really starting to bug me that I cannot figure this out because I want to game in class but I dont have a place to plug my laptop in in a 400 person lecture hall. Like I said i messed with the power options but its possible I missed something. Thanks for your replys.
a b à CPUs
September 5, 2010 1:54:40 AM

whats your OC? if u have win7, in POWER OPTIONS u can change the power plan: -> change plan settings -> advanced -> procesor power menagement, an set it to 100%. also check in bios, there might be some power options. desable intel cpu multiplayer control in bios.
m
0
l
a b à CPUs
September 5, 2010 2:21:05 AM

i dont have the cpu oced just the GPU with a custom bios. I have tried the processor power management to 100 but that doesnt hel[ at all for some reason. As far as changing settings in the bios i want the cpu to downclock when its not in use but I just dont want the multiplier to be locked lower when its on battery. that make sense? I still want the power savings stuff when its not in use but I want full power when on battery when it is in use.
m
0
l
Related resources

Best solution

a b à CPUs
September 5, 2010 3:00:58 AM

the power options in control panel have to work. make sure u are doing it right. both my laptops (asus and ibm) go to 100% if I set them like that, i usually do 50% on battery.
see if msi have some custom software for power management. my asus laptop have its own power management program, and i use that one.
Share
a b à CPUs
September 6, 2010 12:41:25 AM

yea msi has this software called system control manager and it has power options settings binded to a button on the laptop. Like turbo battery and gaming mode and such. I take the power cable off and set the power options to gaming and the system stays at 1.3ghz. I have set the minimum cpu power to 100% and it doesnt work. I will try it again to make sure that I am doing it right. Thanks for the help
m
0
l
a b à CPUs
September 6, 2010 12:52:18 AM

update: Ok so I checked to make sure and I have the laptop in high performance mode on battery with the msi power settings off. I have both the minimum and maximum processor state to 100% and the processor still does not go above 1.3ghz. this leads me to believe that there must be something in the bios that is causing this because the msi system controller is the only msi product on the laptop.
m
0
l
a b à CPUs
September 6, 2010 3:23:00 AM

Ok so I checked in the bios.....I turned off Intel Speed step. This stop the turbo boost from working both on ac adapter and battery. so my max clock was 2.4 instead of 2.6 for both battery and ac power. this stoped the cpu from being limited while on battery but unfortunatly stops turbo boost.
m
0
l
a b à CPUs
September 12, 2010 7:59:11 AM

Best answer selected by drums101.
m
0
l
!