[Solved] USB hard disk don't show up after Rebooting PC

Hi Everyone,

I would like to connect my 2.5" external USB hard drive permanently to store my files. However, it seems like my USB hard disk doesn't show up every time I reboot my windows 7. I will need to unplug the usb and then replug it back it for it to be detected, which is a bit of a hassle.

Anyone has any ideas how i can go around this inconvenience??

Best Regards,
Kenneth
5 answers Last reply
More about solved hard disk show rebooting
  1. Well you could always install it in the computer. You'd need a 2.5 to 3.5 inch bay adapter (if the computer doesn't have a 2.5 inch bay) and a SATA cable.
    SATA cable- http://www.newegg.com/Product/Product.aspx?Item=N82E16812119382
    Bay adapter- http://www.newegg.com/Product/Product.aspx?Item=N82E16817994085
  2. andrewcarr said:
    Well you could always install it in the computer. You'd need a 2.5 to 3.5 inch bay adapter (if the computer doesn't have a 2.5 inch bay) and a SATA cable.
    SATA cable- http://www.newegg.com/Product/Product.aspx?Item=N82E16812119382
    Bay adapter- http://www.newegg.com/Product/Product.aspx?Item=N82E16817994085


    I'm out of sata slots/casing space hence using external HD.

    Anyone has any idea? can this be done through some software settings, or is just normal that if a usb hard disk is plugged in before the computer starts, it will not be detect when window boots up?
  3. I have two external HDDs running on my PC currently and haven't had an issue with them not being detected.

    Go in and check to make sure that the USB ports its connected to aren't set to Allow this computer to turn this device off to save power.

    You can get there by following these steps:

    Control Panel -> Device Manager -> Universal Serial Bus controllers -> USB Root Hub

    Right click on each of the USB Root Hub options and then click on the Power Management and make sure that the checkbox above is unchecked.

    Do this and see if the issue continues.
  4. hedwar2011 said:
    I have two external HDDs running on my PC currently and haven't had an issue with them not being detected.

    Go in and check to make sure that the USB ports its connected to aren't set to Allow this computer to turn this device off to save power.

    You can get there by following these steps:

    Control Panel -> Device Manager -> Universal Serial Bus controllers -> USB Root Hub

    Right click on each of the USB Root Hub options and then click on the Power Management and make sure that the checkbox above is unchecked.

    Do this and see if the issue continues.


    Hello and thank you for your reply. I tried your suggestion and the problem persisted.

    However, I was to determine the driver status of my hard disk upon reboot through the usb root hub properties and realized that drivers weren't loaded properly.

    I had plugged the hard disk into the front usb ports of my PC casing which is using an external usb hub connected to the mainboard. By simply plugging my hard disk to one of the ports at the back of the casing, the hard disk loaded just fine everything i start up my PC or reboot with the hard disk plugged in. thanks and cheers all :)
  5. its caused by it being routed thru your EHCI instead of XHCI. changeable via the bios
Ask a new question

Read More

USB Hard Drives External USB Windows 7 Product