How to turn on wireless connection without the f2 button for inspiron 1545

how to turn on wireless connection without the f2 button for inspiron 1545.
:sweat:
my computer randomly disconnected from the wireless connectivity, but as much as i know about how the Fn and F2 button scenarios work for my laptop, well, they're not working. my mom was on it earlier and told me she thought my F2 button wasn't working because it wouldn't do something in the setup when my comp loaded.

now I've tried the on screen keyboard and connecting another adaptable keyboard and neither has let the Fn or F2 button work for me.

i'm at a loss at what to do. :cry:
8 answers Last reply
More about turn wireless connection button inspiron 1545
  1. Head into the device manager and try to enable it from there.
  2. This bugged me for months and didn't want to buy and fit a new keyboard. Finally figured out how to alter the BIOS settings to switch on the wifi card. Note you will need a usb keyboard plugged into the laptop to do this!

    Reboot the laptop and press F2 on the external keyboard to enter the setup screen

    find the wireless settings in the menu

    there are two options here...

    set it so that the wireless adapter is enabled but NOT that it can be toggled on/off via the switch (F2)

    Apply then exit

    When computer reboots right-click on network icon in system tray

    open network and sharing centre

    click on change adapter settings

    right-click on WiFi adapter

    choose connect/disconnect

    Now treat yourself to a doughnut... you've just fixed it!


    mymusicalserenity said:
    how to turn on wireless connection without the f2 button for inspiron 1545.
    :sweat:
    my computer randomly disconnected from the wireless connectivity, but as much as i know about how the Fn and F2 button scenarios work for my laptop, well, they're not working. my mom was on it earlier and told me she thought my F2 button wasn't working because it wouldn't do something in the setup when my comp loaded.

    now I've tried the on screen keyboard and connecting another adaptable keyboard and neither has let the Fn or F2 button work for me.

    i'm at a loss at what to do. :cry:
  3. open network and sharing centre

    click on change adapter settings

    right-click on WiFi adapter

    click diagnose

    then it will troubleshoot and ask you if you want to turn it on and click on it.

    thats it
  4. Hello Unplugged Jack.
    Thanks very much for your advice. It worked!! Thanks Thanks:bounce:
    :bounce:
  5. unpluggedjack said:
    This bugged me for months and didn't want to buy and fit a new keyboard. Finally figured out how to alter the BIOS settings to switch on the wifi card. Note you will need a usb keyboard plugged into the laptop to do this!

    Reboot the laptop and press F2 on the external keyboard to enter the setup screen

    find the wireless settings in the menu

    there are two options here...

    set it so that the wireless adapter is enabled but NOT that it can be toggled on/off via the switch (F2)

    Apply then exit

    When computer reboots right-click on network icon in system tray

    open network and sharing centre

    click on change adapter settings

    right-click on WiFi adapter

    choose connect/disconnect

    Now treat yourself to a doughnut... you've just fixed it!


    mymusicalserenity said:
    how to turn on wireless connection without the f2 button for inspiron 1545.
    :sweat:
    my computer randomly disconnected from the wireless connectivity, but as much as i know about how the Fn and F2 button scenarios work for my laptop, well, they're not working. my mom was on it earlier and told me she thought my F2 button wasn't working because it wouldn't do something in the setup when my comp loaded.

    now I've tried the on screen keyboard and connecting another adaptable keyboard and neither has let the Fn or F2 button work for me.

    i'm at a loss at what to do. :cry:





    From here "click on change adapter settings", its showing only "local connection, network cable unplugged". There is no "wifi adapter. so then i dont know what to do, i have same prob with the history above. please help..
  6. unpluggedjack said:
    This bugged me for months and didn't want to buy and fit a new keyboard. Finally figured out how to alter the BIOS settings to switch on the wifi card. Note you will need a usb keyboard plugged into the laptop to do this!

    Reboot the laptop and press F2 on the external keyboard to enter the setup screen

    find the wireless settings in the menu

    there are two options here...

    set it so that the wireless adapter is enabled but NOT that it can be toggled on/off via the switch (F2)

    Apply then exit

    When computer reboots right-click on network icon in system tray

    open network and sharing centre

    click on change adapter settings

    right-click on WiFi adapter

    choose connect/disconnect

    Now treat yourself to a doughnut... you've just fixed it!


    mymusicalserenity said:
    how to turn on wireless connection without the f2 button for inspiron 1545.
    :sweat:
    my computer randomly disconnected from the wireless connectivity, but as much as i know about how the Fn and F2 button scenarios work for my laptop, well, they're not working. my mom was on it earlier and told me she thought my F2 button wasn't working because it wouldn't do something in the setup when my comp loaded.

    now I've tried the on screen keyboard and connecting another adaptable keyboard and neither has let the Fn or F2 button work for me.

    i'm at a loss at what to do. :cry:




    It worked for me using Windows 10. Thanks!
  7. unpluggedjack said:
    This bugged me for months and didn't want to buy and fit a new keyboard. Finally figured out how to alter the BIOS settings to switch on the wifi card. Note you will need a usb keyboard plugged into the laptop to do this!

    Reboot the laptop and press F2 on the external keyboard to enter the setup screen

    find the wireless settings in the menu

    there are two options here...

    set it so that the wireless adapter is enabled but NOT that it can be toggled on/off via the switch (F2)

    Apply then exit

    When computer reboots right-click on network icon in system tray

    open network and sharing centre

    click on change adapter settings

    right-click on WiFi adapter

    choose connect/disconnect

    Now treat yourself to a doughnut... you've just fixed it!


    mymusicalserenity said:
    how to turn on wireless connection without the f2 button for inspiron 1545.
    :sweat:
    my computer randomly disconnected from the wireless connectivity, but as much as i know about how the Fn and F2 button scenarios work for my laptop, well, they're not working. my mom was on it earlier and told me she thought my F2 button wasn't working because it wouldn't do something in the setup when my comp loaded.

    now I've tried the on screen keyboard and connecting another adaptable keyboard and neither has let the Fn or F2 button work for me.

    i'm at a loss at what to do. :cry:




    Realist said:
    Thank you unpluggedjack! You just solved a very annoying problem for me.
  8. hey unpluggedjack,,
    i had the same problem also but with a acer aspire 5750z laptop.
    i tried to go with your solution but i dont see any option to change key at the bios....
    plz help me
Ask a new question

Read More

Wireless Connection Inspiron Laptops