Sign in with
Sign up | Sign in
Your question

PC gameboard direcional thumbstick issues logitech g13

Last response: in Computer Peripherals
Share
January 22, 2012 11:18:19 AM

I have had this same issue with both Logitech G13 gameboard and Saitek Cyborg command unit gameboards for my PC.

It first started with playing WOW with my Saitek unit. I first noticed it when my spells would get interrupted with my toon moving without me moving him. I thought it was my gamepad getting stuck b/c it is so old.

I later noticed it in SWTOR. I have my directional thumbstick set to AWSD for movement. When i would run in a certain direction while casting something my toon would keep running in that direction even after removing my thumb from the thumbstick. The only way it would stop would be for me to move the thumbstick in the direction of movement and then let off again.

I figured it must be my gamepad. So my friend gave me his Logitech G13. Anyway, the same thing is happening with the G13. Tried going to system properties in control panel to re-calibrate but didn't work. Tried plugging into different USB port and didn't work.

Extremely frustrated. Please help.
March 18, 2012 5:16:59 PM

bmanuel77 said:
I have had this same issue with both Logitech G13 gameboard and Saitek Cyborg command unit gameboards for my PC.

It first started with playing WOW with my Saitek unit. I first noticed it when my spells would get interrupted with my toon moving without me moving him. I thought it was my gamepad getting stuck b/c it is so old.

I later noticed it in SWTOR. I have my directional thumbstick set to AWSD for movement. When i would run in a certain direction while casting something my toon would keep running in that direction even after removing my thumb from the thumbstick. The only way it would stop would be for me to move the thumbstick in the direction of movement and then let off again.

I figured it must be my gamepad. So my friend gave me his Logitech G13. Anyway, the same thing is happening with the G13. Tried going to system properties in control panel to re-calibrate but didn't work. Tried plugging into different USB port and didn't work.

Extremely frustrated. Please help.

I'm sorry to say, this has happened with the past two G13's I have had this past year. From what I have found looking for a solution, it actually the thumbstick itself failing from wear. If it's still under warranty, try and have them take care of it, otherwise, not much you can do except replace the unit. If in your search, you happen to find a solution that does help, post it so I can take care of my old ones.
m
0
l
March 28, 2012 4:58:11 PM

I actually fixed the issue by changing the way the keys are labeled. So instead of using page up and page down for the up and down direction, I use home and end. Weird.
m
0
l
!