Sign in with
Sign up | Sign in
Your question
Solved

Windows 7 Refuses to Sleep

Last response: in Windows 7
Share
December 26, 2012 12:58:23 AM

Hello,

I have a problem that makes me want to destroy my laptop. I use sleep mode a LOT. Until today, it used to actually enter sleep mode. Now, it turns of the screen, and HDD activity seems to stop (At least the light turns off). But it never actually sleeps. In fact, it seems to use MORE power somehow. I usually get ~5 hours on battery. My new awesome sleep mode is so good it consumes the battery in just 3 hours.

So..... WTF?

ASUS U46E
i7 2620M
8GB RAM
512GB SSD (Crucial M4)
Win7 Ultimate x64, up to date according to WU
Kaspersky Internet Security (Latest, up to date) - still happens when it is completely disabled

powercfg -energy https://dl.dropbox.com/u/12886421/energy-report.html

C:\Users\Chris>powercfg -requests
DISPLAY:
None.

SYSTEM:
None.

AWAYMODE:
None.


It worked perfectly fine yesterday. Not today. All I have done is install a HP printer - historically the worst installs ever.

Diagnostic boot makes new difference.

Hardware drivers are the most current, as far as I can tell. In device manager, there is an unknown device SM Bus Controller, but it has been unidentified since my last wipe, 8-9 months ago. (Nothing I do can get it to be recognized, but that's... probably... another problem for another day - it hasn't caused issues yet.)

None of the potential solutions made any difference. Actually, most of them did not apply - software I don't have, mostly. Enabling/disabling hibernate makes no difference. Rebooting makes no difference. BIOS is up to date, and hasn't changed in the past day anyway. WOL is disabled. It happens when the WLAN is disabled or enabled.

I have run CCleaner and a full Kaspersky scan. Nothing.

I have checked everything I can think of, and... nothing. I really need help here.

EDIT: Hibernate works fine.

Also... "Don't use sleep" is NOT a valid suggestion. So stop right here, don't bother proceeding. I saw that 'intelligent' solution a little too much while researching this problem.

Thanks!

EDIT: When I it 'wakes up' it still dumps me back at the login screen. So... at least Windows seems to think it slept...?

More about : windows refuses sleep

December 26, 2012 1:28:56 AM

Go to the power settings in: Control panel > System and Security > Power Options.

Then click on: change plan settings (on the currently selected power plan of course)

Then you choose the time that the computer needs to idle in order to turn off the display or go to sleep.

m
0
l
December 26, 2012 1:36:51 AM

gamingboy said:
Go to the power settings in: Control panel > System and Security > Power Options.

Then click on: change plan settings (on the currently selected power plan of course)

Then you choose the time that the computer needs to idle in order to turn off the display or go to sleep.


I am trying to manually put the computer to sleep. Either by pressing the FN+F1 (Sleep) or Start->Shut Down->Sleep. I do not have auto-sleep enabled, nor do I want it enabled. The screen turns off, the HDD light stops blinking, but the fan still runs, pushing out hot air from the CPU (even after it has been 'sleeping' a while - same temp as when it is running under load), and the power light does not blink, and the wifi light (when it is enabled) does not turn off. The lights should change and the CPU heat should dissipate when it is properly sleeping.
m
0
l
Related resources
December 26, 2012 1:49:58 AM

gamingboy said:
Read this http://support.microsoft.com/kb/976877
Some device could block your computer from going to sleep. You could try unplugging everything, and then trying to sleep.


I have disabled all devices from waking the computer. powercfg -devicequery wake_armed returns no devices now.

Wake timers are disabled.

Media sharing set to "Allow computer to sleep"

No change.... :( 
m
0
l
December 26, 2012 1:58:31 AM

Try pulling out everything that is connected to the PC. Every USB device, ethernet cable, everything. Disable Wi-Fi if you have it. Then try to sleep.
m
0
l
December 26, 2012 2:15:09 AM

gamingboy said:
Try pulling out everything that is connected to the PC. Every USB device, ethernet cable, everything. Disable Wi-Fi if you have it. Then try to sleep.


I truly, truly wish that I could report that it worked. Unfortunately..... well... you can probably guess the outcome.

No ethernet. Only had a Logitech Universal receiver attached - removed it. Disabled wifi in Networking and Sharing center, and then with the hardware switch to be thorough. All I have left is the trackpad, keyboard, monitor and CPU. And all of these things are pretty critical lol.
m
0
l

Best solution

a b $ Windows 7
December 26, 2012 2:21:40 AM

I noticed that you have an HP printer. Does it have a memory card reader on it?

The reason I ask is there is a fluke with all printers, not just HP, that when they have a memory card reader on them the computer will not sleep or hibernate in most cases unless special instruction has been created by another program.
It doesn't matter how many times you tell the USB ports on your computer, etc. to not keep the computer from sleeping, it will do so anyway because of the printer itself.

You may also want to check and see what you have starting up when Windows does as this could be a culprit as well.

I would recommend using Autoruns.

Not sure what all those things are? Go to HERE for help with identifying those pesky startup items.
Share
December 26, 2012 2:24:59 AM

Go to the power settings just like I told in my first post. Go to the current plan settings, and click on "change advanced power settings.

Then expand "sleep", and then expand "allow wake timers". Change both plugged in and on battery to disabled.
m
0
l
December 26, 2012 2:35:26 AM

:bounce:  You, sir, are my new personal hero. Uninstalling the new printer worked.

hedwar2011 said:
I noticed that you have an HP printer. Does it have a memory card reader on it?


Yes, in fact it does. I personally hate this printer, and now I have another reason! And I specifically avoided installing the HP crapware, because in my experience it causes more problems than it solves. I can't begin to count the number of problems I have seen caused by it. I only installed the drivers from Windows

hedwar2011 said:
The reason I ask is there is a fluke with all printers, not just HP, that when they have a memory card reader on them the computer will not sleep or hibernate in most cases unless special instruction has been created by another program.


Do you have a source I can find on that? I'm interested in the underlying cause.

hedwar2011 said:
It doesn't matter how many times you tell the USB ports on your computer, etc. to not keep the computer from sleeping, it will do so anyway because of the printer itself.


It's actually a networked (WiFi) printer, so unplugging USB made no difference. Or is it actually the drivers that do it? Again, I'd love some literature. I'm a computer engineer (I know, right?) and, as such, like attempting to solve the root problem. Or at least understanding it.

hedwar2011 said:
You may also want to check and see what you have starting up when Windows does as this could be a culprit as well.

I would recommend using Autoruns.

Not sure what all those things are? Go to HERE for help with identifying those pesky startup items.


I keep a tight leash on my startup programs and services. Thanks though! :) 

Thanks hedwar!

Thanks to gamingboy as well!
m
0
l
December 26, 2012 2:36:43 AM

Best answer selected by addchild314.
m
0
l
December 26, 2012 2:39:28 AM

gamingboy said:
Go to the power settings just like I told in my first post. Go to the current plan settings, and click on "change advanced power settings.

Then expand "sleep", and then expand "allow wake timers". Change both plugged in and on battery to disabled.


I typically disable all power saving options. When my laptop is on, I want it at full power and top performance. When it's behaving, it doesn't do anything I don't explicitly tell it to.

That being said, you still reminded me to make sure Windows isn't asserting it's individuality. Thanks :) 
m
0
l
December 26, 2012 2:43:05 AM

addchild314 said:
:bounce:  You, sir, are my new personal hero. Uninstalling the new printer worked.



Yes, in fact it does. I personally hate this printer, and now I have another reason! And I specifically avoided installing the HP crapware, because in my experience it causes more problems than it solves. I can't begin to count the number of problems I have seen caused by it. I only installed the drivers from Windows



Do you have a source I can find on that? I'm interested in the underlying cause.



It's actually a networked (WiFi) printer, so unplugging USB made no difference. Or is it actually the drivers that do it? Again, I'd love some literature. I'm a computer engineer (I know, right?) and, as such, like attempting to solve the root problem. Or at least understanding it.



I keep a tight leash on my startup programs and services. Thanks though! :) 

Thanks hedwar!

Thanks to gamingboy as well!


Hm.. that's a very weird bug with the printers. Good thing you got it fixed though.
How did you "uninstall" the printer? Did you turn it off, or did you uninstall a piece of software or a driver?
m
0
l
a b $ Windows 7
December 26, 2012 2:52:51 AM

addchild314 said:
:bounce:  You, sir, are my new personal hero. Uninstalling the new printer worked.



Yes, in fact it does. I personally hate this printer, and now I have another reason! And I specifically avoided installing the HP crapware, because in my experience it causes more problems than it solves. I can't begin to count the number of problems I have seen caused by it. I only installed the drivers from Windows



Do you have a source I can find on that? I'm interested in the underlying cause.



It's actually a networked (WiFi) printer, so unplugging USB made no difference. Or is it actually the drivers that do it? Again, I'd love some literature. I'm a computer engineer (I know, right?) and, as such, like attempting to solve the root problem. Or at least understanding it.



I keep a tight leash on my startup programs and services. Thanks though! :) 

Thanks hedwar!

Thanks to gamingboy as well!


It actually is something that I learned in all my years of working with computers (20+) but I also think there is something written up on it. I'll look around and see if I can dig something up for you.

EDIT: I know this sounds a bit mundane but I've seen instances in the past where a wireless printer, such as this, will prevent a computer from going to sleep correctly because it is sending packets to the router which in turn is sending packets to the computer thus keeping it awake. Strange, I know, but then again we wouldn't be here if things like this didn't happen.
m
0
l
December 26, 2012 3:05:57 AM

gamingboy said:
Hm.. that's a very weird bug with the printers. Good thing you got it fixed though.
How did you "uninstall" the printer? Did you turn it off, or did you uninstall a piece of software or a driver?


I simply used "Delete Printer" from Devices & Printers, and verified the driver removal in Device Manger. I didn't install any of the HP software.

hedwar2011 said:
It actually is something that I learned in all my years of working with computers (20+) but I also think there is something written up on it. I'll look around and see if I can dig something up for you.
.


I appreciate it! An initial search didn't reveal anything, but I'll keep looking.

hedwar2011 said:
EDIT: I know this sounds a bit mundane but I've seen instances in the past where a wireless printer, such as this, will prevent a computer from going to sleep correctly because it is sending packets to the router which in turn is sending packets to the computer thus keeping it awake. Strange, I know, but then again we wouldn't be here if things like this didn't happen


It's no stranger than a MC reader preventing sleep. And I thought I had seen all the HP errors...

But indeed, these strangest of errors keep us employed and innovating.
m
0
l
!