Sign in with
Sign up | Sign in
Your question

Problem with MadCatz MMO 7

Last response: in Computer Peripherals
Share
February 8, 2012 5:28:30 PM

So I just bought the MadCatz MMO 7 and when I plug it in it works fine. In order to get the mouses extra buttons working I need to install the drivers. This is when my problems start when I try and install the drivers the install freezes. It also makes my keyboard and mouse unusable so I have to reboot. After I reboot windows won't start so I have to reboot again. When I do it prompts me to enter a repair mode which I do and it restores the computer. I then reboot again get back on but the buttons don't work since the drivers never installed. This has happened three times and I have no idea what to do.

More about : problem madcatz mmo

May 30, 2012 4:40:23 AM

I have a similar, though less drastic of a problem and am hoping to get a solution as well.

My comp freezes on the driver install and then I just have to restart but it never finishes the software install either. Hopefully there is a fix or update available and I'm not currently finding it, or maybe someone knows how to get around it without the Cyborg software?

Update: After messing with it for a while, one of the times my computer restarted I started it in safe mode and installed the drivers/software. Restarted my computer and now it is working great. Not sure why I had to install it in safe mode but I'd suggest trying that and restarting.

Good luck. Love this mouse, but I miss a couple minor things compared to the RAT 7/9...the DPI switching is just one button, not an up/down button, and the material feels a little bit different, I like the better matte feel of the other ones. Maybe they're not though. Either way, great mouse!
m
0
l
April 3, 2013 8:32:17 AM

I to got the error where the install freezes and the keyboard and mouse freezes up to while the computer keeps on trucking... forcing me to reboot the computer on the hardware. This happend 3 times, then i went into hardware management and tried to remove the mmo7 there (was hoping to try and re-install it), this uninstall/removal ofc. also froze my win7. After a hardware reboot windows would not start up again and when it prompted for normal start or repair tool the repair tool would start up and starting normal mode would just reboot and ending me up in the same place again....

In short, trying to install this Mad Catz m.m.o. 7 mouse ended up costing me a win install, and i now have to start with a fresh win7 install... first time for everything.

Been working with computers daily for 20+ years and never had a mouse install ending up breaking the OS. Donno what it says more about, the mousedrivers or the OS...

On the plus side tho, its a awsome mouse ;>
m
0
l
Related resources
Can't find your answer ? Ask !
April 28, 2013 4:38:09 AM

Hello,
I have the same problem as Sull, and I tried all of the above (I installed the drivers as administrator, I installed it in SafeMode, I installed it as Administrator in SafeMode, And I even re installed Windows) but still no results.
On my laptop it works fine, but I bought it for my desktop, and I have no ideas what to do next. Can someone help me?
m
0
l
October 5, 2013 7:08:16 PM

Make sure you are not rebooting Windows 7 with the MMO7 Mouse plugged into a USB 3.0 device slot. Use a 2.0 slot on your board.

Correct me if I'm wrong but I don't believe the USB 3.0 slots load until windows does it's thing, and the installer requires the mouse to be detected prior to boot from what I can tell. Hate to 'necro' this thread but if it can help anybody else, then I figured I'd try posting.
m
0
l
December 21, 2013 7:40:48 AM

Ok I had all of the above problems. So what I did I just unpluged the mouse from my usb 3.0 slot and pluged it in a 2.0 slot and then I rebooted and when windows was starting I could use my mouse yay so no need for safe mode install and all that just make sure you're mouse is in 2.0 usb slot not usb 3.0
m
0
l
!