Sign in with
Sign up | Sign in
Your question

Gateway Mx6421 wireless not working

Last response: in Laptops & Notebooks
Share
October 26, 2010 9:44:03 PM

Hi, I am also looking for help with my wireless. I reinstalled Windows xp on my gateway,and lost my audio,and my wireless. I have downloaded gateway sound drivers..D00377-001.. which did not work. What can I do to get both back. I tried reinstalling windows again hoping to install the drivers again,but it tells me there is no sound driver or wireless driver. I really enjoy my Gateway when I play my games during the winter months. Thanks for any help.

coachjp1
January 2, 2011 4:17:21 AM

Ok I've seen that the MX6421 (and probably a bunch of other Gateways) are notorious for having this problem. Well, NONE of the solutions I've read have worked, but I finally found a manual workaround for this issue, and here it is:

  • In the control panel, "Add Hardware".
  • Find the uninstalled wireless network card (probably just says "Network Adapter" in the list).
  • In the Hardware Update Wizard, select "No, not this time" for Windows Update; press Next.
  • "Install from a list or specific location"; press Next.
  • Select the bottom option: "Don't search..."; press Next.
  • Select the Network Adapter option again; press Next.
  • On this screen, press "Broadcom" under the list of manufacturers and then select the following driver: "Broadcom 802.11b/g WLAN" dated 3/23/2006. Press Next and then "Yes" to the prompt. It should then install the driver for you and begin functioning like it should.

    Note: I did all this AFTER attempting the install of several other drivers, including the one provided by Gateway on their website: It's the BCM40100.exe driver. So, me being able to select this driver in the end was as a direct result of me attempting the install of these drivers. But if you're like me and exhausted all other options, you probably already tried to install the driver.

    I sincerely hope this works for you and you don't have to go through all the same trouble as I did. Best of luck to you.
    m
    0
    l
    !