Sign in with
Sign up | Sign in
Your question
Solved

HP Pavilion dv6871 lock ups

Last response: in Laptops & Notebooks
Share
October 31, 2010 6:31:59 AM

Hi,

Well, we all make mistakes eventually, and I ended up spilling some water on my laptop. It was a small amount and I cut it off, but damage was done. I can't do anything about that now. What I can do, though, is try to fix it.

If only I could find out what the problem is.

The model is a HP Pavilion dv6871. The symptom is it locks up in normal running mode within about 2-3 minutes.

Additional facts:

- The keyboard IS broken. I can easily fix this, but according to HP customer service this wouldn't cause a lock up (I was recalling how failed keyboards could lock up computers back before USB days and wasn't sure about this point based on my lack of knowledge about laptop keyboard connections). Current plan is to not replace the keyboard until I figure out the other problem.

- Assumption: Keyboard damage may be in the same localized area as the other hardware damage. The B, N and = keys are trashed.

- It only locks up in normal windows mode. When it locks up it will continue to "run" in that I can move my cursor and if my webcam is running it will continue to run for maybe 15-20 minutes. Attempting to close windows or do anything else will make the cam lock up too, though.

- It does NOT lock up in safe mode (with or without network support).

- Stock comes with 2 memory chips. I removed one at a time to see if this would fix the problem. It locked up using each chip. I used them in different slots, too, in case the slot could've been a problem. Didn't rotate, just chip #1 in slot #1 by itself, chip #2 in slot #2 by itself.

- Bios memory test passed. Can't find my memtest CD but from above information I'm not sure that would be productive.

- While in safemode chkdsk ran and found 0 bad sectors and gave no errors.

- Sound and video appear to function properly (tested over standard speakers, no headphones).

- I have no external peripherals plugged in.

- Some data has been extracted from it using a USB drive while in normal mode (so if USB is damaged it's not completely shot).

---

I can't think of what this could be. I'm assuming an unnecessary peripheral or something and that's why it isn't locking in safe but is locking in normal. I mean if it's unnecessary...I'd probably rather disable the hardware and have somewhat of a handicapped laptop than replace the motherboard.

Thanks,
Jon
October 31, 2010 6:45:34 AM

One major difference between safe and normal mode is your video drivers aren't loaded in safe mode. A standard vga driver is used. You could try reloading your graphics drivers.
m
0
l
October 31, 2010 8:58:38 AM

Alright, I disabled the video card in device manager in safe mode. Rebooted into normal and still locked up. I'm assuming this is a proper test?

Video card is a nvidia geforce 8400m GS, just for reference.

What else can I disable that might be causing this?

Edit: Dumped event log using wevtutil qe Microsoft-Windows-Diagnostics-Performance/Operational /f:text > %userprofile%/Desktop/Event.txt ... got nothing. Most recent log was in July before it was damaged. I'm kind of surprised by that because I got a BSOD once since it's been damaged (while I was trying to restart it, usually it locks before that happens and I have to cut the power manually). I've been unable to duplicate it, sadly.
m
0
l
Related resources
October 31, 2010 5:54:18 PM

Didn't want to leave you hanging, but I really don't know what to tell you except to look for other non-essential devices to disable. Even though the USB hub(s) worked for one function, you might try disabling that as well.
m
0
l
October 31, 2010 6:01:41 PM

Yeah, I'm running another hard drive test at the moment and will try disabling more stuff when it's done, but so far I've disabled:

Display Adapter
HP Webcam
Both Network Adapters: (Wireless WiFi Link, Realtek Fast Ethernet NIC)
DVD/CD-Rom drive (optiarc)
HD Audio Controller
EVERYTHING under USB

Still locking.
m
0
l
October 31, 2010 8:17:34 PM

Alright, I disabled everything in batches and when I lucked out I started re-enabling to narrow it down. Microsoft iSCSI Initiator is the only thing disabled and it appears to be running fine. It was replaced after I disabled it...with "AF6II356 IDE Controller." I'm sure enabling will bring my problem back, but I'm gonna run it like this for a while to make sure nothing else pops up.

I'm not even sure if my HD is SCSI or IDE. I'll pop open the cover later to check that out.
m
0
l

Best solution

October 31, 2010 9:57:35 PM

LOL if I got lucky and got a physically damaged, water-doused laptop to work . . . I might be tempted to leave well enough alone.

Seriously, nice find - grats!
Share
November 1, 2010 9:38:45 AM

Yeah, it's worked fine all day. I'm pretty happy about it. I'm not sure what all that iSCSI stuff is, but I checked and both my drives are IDE. Apparently it's some sort of network-storage-meets-SCSI-nonsense-that-doesn't-matter-cause-it's-frickin-fried-anyway lol.

Keyboard has been ordered and should bring the thing back to full operation. Thanks for the help.
m
0
l
November 1, 2010 9:38:54 AM

Best answer selected by JonBeam.
m
0
l
!