Sign in with
Sign up | Sign in
Your question

Windows 7 home premium (64) pci ide

Last response: in Windows 7
Share
December 31, 2012 1:23:32 AM

I just installed win 7 home premium 64bit and I need it to recognize my pci ide sn-l41011n13502 attached to my extra internal hard drive. I need the drivers. any suggestions? I have a gigabyte ga-h57m-usb3 mb revision2 running an i5-650.
a b \ Driver
a c 243 $ Windows 7
December 31, 2012 1:42:59 AM

What is the make/model of the PCI IDE adapter you are using? I assume you have something installed into your motherboard for the drive you are referring to.

If you are using the motherboard's built-in IDE port, make sure it is enabled in your BIOS. Also the drivers for your motherboard can be found here:

http://www.gigabyte.com/products/product-page.aspx?pid=...

Windows 7 should load a generic IDE driver for the IDE port if it is enabled. Also, with IDE devices, you have to have the jumpers set properly for single drive or master or cable select. What are your jumpers set to on the HDD itself?
m
0
l
a b $ Windows 7
December 31, 2012 1:47:27 AM

hello... did you download and install the chipset driver right after you installed windows?

Do ya have brand/Mf for the external drive case?
m
0
l
Related resources
December 31, 2012 2:08:24 AM

atrlmax said:
I just installed win 7 home premium 64bit and I need it to recognize my pci ide sn-l41011n13502 attached to my extra internal hard drive. I need the drivers. any suggestions? I have a gigabyte ga-h57m-usb3 mb revision2 running an i5-650.


It is a promise model tla:0a0a0d040001. I just switched from xppro and it is set up on my bios. I haven't made changes to that.
m
0
l
December 31, 2012 2:27:52 AM

atrlmax said:
I just installed win 7 home premium 64bit and I need it to recognize my pci ide sn-l41011n13502 attached to my extra internal hard drive. I need the drivers. any suggestions? I have a gigabyte ga-h57m-usb3 mb revision2 running an i5-650.





I got it. Thank you so much, that helped a lot. Have a great new year!!
m
0
l
!