Sign in with
Sign up | Sign in
Your question

Computer randomly turns off.

Last response: in Windows 7
Share
January 1, 2013 6:18:22 PM

Okay, so a while ago I finished building my new Pc. It was working fine for about 3 days but then it would randomly go black and show the message, "Please select a proper boot device and press a key". Prior to this I had accidently been turning off the power to my computer (it was in a weird position, so when i stretched i would kick the cable). Could having turn off the power caused this? I only did this twice. I also tried connecting it to different sata ports and nothing. This was my first built pc and I really need help. Thank you.
a b $ Windows 7
January 1, 2013 6:31:03 PM

theorio said:
Okay, so a while ago I finished building my new Pc. It was working fine for about 3 days but then it would randomly go black and show the message, "Please select a proper boot device and press a key". Prior to this I had accidently been turning off the power to my computer (it was in a weird position, so when i stretched i would kick the cable). Could having turn off the power caused this? I only did this twice. I also tried connecting it to different sata ports and nothing. This was my first built pc and I really need help. Thank you.


Go into the BIOS (usually will show which key to hit when the computer firsts boots up on the mobo manufacturers page) and make sure that the boot order is set to HDD or SSD (not sure which you have) as the first boot device.

Also, make sure that there are no external devices set as the first boot option when you attempt to power on the computer.
m
0
l
January 1, 2013 7:04:57 PM

Okay, my HDD is first in the boot order. The problem is that the HDD isnt even showing up. I've tried connecting to different ports.
m
0
l
Related resources
a b $ Windows 7
January 1, 2013 7:06:44 PM

I would recommend creating a Hirens Boot CD and utilize some of the options available to attempt to resolve your issue.

You may have a bad HDD.
m
0
l
January 1, 2013 9:54:14 PM

Okay, so the HDD is now showing up in the bios. However, when i try to boot it shows the windows animation thing and then it goes and black and just shows the cursor. Any ideas?
m
0
l
January 1, 2013 9:55:22 PM

Quote:
i think from the bad shutdowns you may have damaged the mbr.

I already did the fix MBR thing, should this help?
m
0
l
a b $ Windows 7
January 3, 2013 1:18:56 AM

Try booting into Safe Mode first.

It's time you take a look at everything running and starting up when your computer does.

I would recommend using Autoruns.

Not sure what all those things are? Go to HERE for help with identifying those pesky startup items.
m
0
l
January 3, 2013 5:56:33 AM

Thanks for all the suggestion guys. When I finally gave in I tried reinstalling windows. It said that it couldnt be installed on that drive because it would fail soon, so I ordered a new hard drive.
m
0
l
!