Sign in with
Sign up | Sign in
Your question

Razer Naga Hex issue

Tags:
  • Peripherals
Last response: in Computer Peripherals
Share
April 30, 2012 7:01:31 PM

Tried searching for similar issues being posted, but came up with nothing...

Just got my Naga Hex. Installed the Synapse app, made an account, plugged the thing in, let it update itself. Was working like a charm until I rebooted. Now the mouse is dead. As in, Win7 won't recognize it. I've tried it on my main machine, laptop (again Win7) and and old XP rig. It won't even acknowledge that a new USB device was plugged in, as if there was nothing on the other side of the cord. No sound, no driver installation process, no nothing...

So, I'm guessing I have a bricked mouse now, right? I already contacted Razer support, but I'm trying to make sure I'm not denying myself a couple weeks of gaming for no good reason...

More about : razer naga hex issue

April 30, 2012 10:52:32 PM

I will get this mouse a couple of hours so I cant answer your question very well... but I think when you reboot your pc your mouse is updating or something...
April 30, 2012 11:10:34 PM

Nope, it does not. It' not detected at all, neither by Windows nor by the Synapse app. The led won't even light up when I plug it in. Pressing left, middle and right button and THEN plugging it in does start the bootstarter, which on in itself shows up as a device in the control panel, so the mouse doesn't seem completely dead, but that's not getting me anywhere.
May 1, 2012 9:10:50 PM

I've got the same issues, and after asking help to razer technical support I've got this reply:
Quote:
Hey,

We are sorry about the problems you have experienced with the Synapse update to your Razer Naga Hex. We have a manual version of the firmware update that should quickly revive your mouse. Simply click on the link below and open the zip file. From there run the "DeviceUpdater.exe" file and follow the on screen instructions to flash the firmware to your unit.

http://dl.razerzone.com/drivers/NagaHex/win/RazerNagaHe...

Please note this manual version will set the color of your Naga Hex interface to Red instead of Green. You can choose to keep the red interface and it will have no effect on the performance of your mouse. If you prefer the green interface we will soon follow up with you and forward you a firmware version that contains the proper green interface.


It worked perfectly, hope it will fix your problem too!
May 2, 2012 2:02:51 AM

I had the same problem. It won't turn on when plugged in. I got the same email from razer but it didn't work. I hear the sounds when I plug it in, but says it is and "unknown device"...any suggestions?????? I REALLY don't want to send it back as it takes razer forever to do anything.
May 2, 2012 7:30:20 AM

Well, the solution provided by Razer did work. I tried updating the first post, but it seem the forum is having a fit and won't let me do it.
May 2, 2012 10:10:12 AM

ok today, I got the latest firmware update from synapse 2.0...

this update is from 1.1 to 2.0 I think and the loading is not moving at all anyone experiencing this issue?
May 2, 2012 10:25:42 AM

If you're stuck at "entering bootloader" that happened to me too and I assume caused the firmware to get corrupted. One solution is to unplug the mouse, wait for the system to register it's gone then plug it in the same port.

Another is the download the firmware update from the link below, do a manual update, then let Synapse update everything else.

Here's the full message I got from Razer.

Quote:
We are sorry about the problems you have experienced with the Synapse update to your Razer Naga Hex. We have a manual version of the firmware update that should quickly revive your mouse. Simply click on the link below and open the zip file. From there run the "DeviceUpdater.exe" file and follow the on screen instructions to flash the firmware to your unit.

http://dl.razerzone.com/drivers/NagaHex/win/RazerNagaHe...

Please note this manual version will set the color of your Naga Hex interface to Red instead of Green. You can choose to keep the red interface and it will have no effect on the performance of your mouse. If you prefer the green interface we will soon follow up with you and forward you a firmware version that contains the proper green interface.


Should the update fail, Please follow the instructions below.

Try this method and it should help. Please note, it is helpful if you have a second mouse connected during the firmware update as the mouse may be unresponsive during the updating procedure.

1) Manually launch the Firmware update program.

2) Before clicking "Next", un-plug the mouse and hold down the Left click, Right click and Scroll buttons at the same time.
Example: http://dl.dropbox.com/u/34137291/Naga%20Update.jpg

3) Now reconnect the mouse to the computer and after 5 seconds release the three buttons. Windows should detect a new USB device and the update should proceed.
*Should the firmware update fail, please exit the firmware updater and run the firmware updater again. If possible, you may want to try the firmware update on another system
May 2, 2012 11:45:29 AM

Hey HMV, I did get that same message from you. Unfortunately it still comes up as unrecognized and shows as an unknown device in the device manager. :-/ I did exactly as that email said...multiple times, and nothing.
May 2, 2012 2:07:13 PM

Guess you don't have another rig to try it on?
May 2, 2012 4:43:05 PM

Tried it on my second computer at home and brought it into work and tried it there...no dice :cry: 
May 2, 2012 6:17:22 PM

I'm having this same problem. my update failed in the middle of installing and ever since then my mouse has failed to work. thank god i have another mouse for the time being. steps i've tried are as followed :

1. Uninstalling and reinstalling synapse after reboot
2. running the manual updater including unplugging the mouse and replugging it back in after holding down left middle and right mouse button.
3. uninstalling the "unknown device" from device manager and running the maual updater again after a reboot.
4. finally i called support and told them my problem and apparently it is common. they are going to send me an email probably the same one they sent you HMV.

Cheers guys wish us luck or imma be one po'd customer! lol first and last razer product i will buy if they don't resolve this.
May 2, 2012 7:29:04 PM

Jewfro said:
I'm having this same problem. my update failed in the middle of installing and ever since then my mouse has failed to work. thank god i have another mouse for the time being. steps i've tried are as followed :

1. Uninstalling and reinstalling synapse after reboot
2. running the manual updater including unplugging the mouse and replugging it back in after holding down left middle and right mouse button.
3. uninstalling the "unknown device" from device manager and running the maual updater again after a reboot.
4. finally i called support and told them my problem and apparently it is common. they are going to send me an email probably the same one they sent you HMV.

Cheers guys wish us luck or imma be one po'd customer! lol first and last razer product i will buy if they don't resolve this.


Im having the same problem at the moment, ive tried everything, What is the number you called Razer on, i couldnt find a phone number
May 2, 2012 7:38:29 PM

888-697-2037 is the number. all they will tell you is they will submit a ticket for their tier 2 guys or w/e bs and you'll be s.o.l. again just a heads up

Edit: Just got a reply back from cs and it's the same freakin email they are sending everyone else. It does not work for me and i told them that on the phone. If they don't resolve this with the next email i'm sending this POS back and getting a different mouse from a different company. This is just rediculous.
May 2, 2012 9:14:45 PM

I called them and told him the email fix doesnt work for me, but now im waiting on an email, so idk yet if they are gonna send me something different, will update when i receive email.
May 2, 2012 9:31:22 PM

good luck, I've been back and forth with 5 other reps...nothing! Same crap. I'm usually a very calm but at least the same person can email me back or something. Very aggravating.
May 3, 2012 12:32:59 AM

had the same problem, try a restore to last shutdown last night before the update then use the manual update. Also mine e-mails said to hold the 3 mouse buttons down while it was plugged back in for 5 seconds.
May 3, 2012 8:55:48 AM

yea nothing i do fixes it. I think somehow the firmware within the mouse got corrupted or something. I'm just going to rma it back to newegg under defective.... i dont know if i'm going to get another one or just pick a different brand.
May 3, 2012 10:27:03 AM

After thinking about why anyone would require you to log into their server to configure something as simple as a multi-button mouse when all of the configuration files could be kept on your computer along with all the different profiles for the different games you play it begs the question why? There is only one reason, that is to gather the information from gamers on what games you play, how often you play each game and then to sell that information to the highest bidder.

The days of Razer's edge on the gaming world is slowly coming to an end and so, if this is how they are going to treat their customers, to this dull end to Razer's Naga Hex I am resolved to never sign into synapse again. To never have 4 hours of my life scouring the web for resolve wasted time because they can't compile a single update that doesn't cause fatal flaws in the end users equipment! GOODBYE SYNAPSE! Who needs it?
May 3, 2012 10:47:15 AM

I have just got a Naga Hex and have had issues similer to these, basically it tried to autoupdate the firmware which I thought at the time was the Synapse software but it wasn't and the update locked up on me. Had to restart Win7 and the mouse then didn't work light up or anything.

I did notice it was recognised as boot loader or something at first which I'm guessing would have been fine if I knew about the manual firmware update at the time, once I unplugged it and plugged it back in it was now unknown device.

So my question is if anyone knows is can this be recovered? I've tried the mouse on different systems but it's always unrecognised the "left right middle" button hold before plugging the mouse in does nothing, and the manual update software does not see the device so I'm guessing the mouse is bricked and I will have to send it back.

Issues are have are why would I want to update the firmware of a mouse it if it was working fine and why does the Synapse softare require me to log in. I really don't thing my mouse settings need be on a cloud TBH.

Anyway I think at this point I've tried everything I can and now I have a fancy paper weight if anyone has a solution for this I'd be gratefull but I'm already getting ready to ship this guy back to Razer.
May 3, 2012 10:58:42 AM

Be4sT said:
I have just got a Naga Hex and have had issues similer to these, basically it tried to autoupdate the firmware which I thought at the time was the Synapse software but it wasn't and the update locked up on me. Had to restart Win7 and the mouse then didn't work light up or anything.

I did notice it was recognised as boot loader or something at first which I'm guessing would have been fine if I knew about the manual firmware update at the time, once I unplugged it and plugged it back in it was now unknown device.

So my question is if anyone knows is can this be recovered? I've tried the mouse on different systems but it's always unrecognised the "left right middle" button hold before plugging the mouse in does nothing, and the manual update software does not see the device so I'm guessing the mouse is bricked and I will have to send it back.

Issues are have are why would I want to update the firmware of a mouse it if it was working fine and why does the Synapse softare require me to log in. I really don't thing my mouse settings need be on a cloud TBH.

Anyway I think at this point I've tried everything I can and now I have a fancy paper weight if anyone has a solution for this I'd be gratefull but I'm already getting ready to ship this guy back to Razer.


Yep I'm sending mine back today. No way should an update kill hardware like this. It just goes to show you how bad razer is and don't get me started on their support.... I'll probably be getting a Logitech G9x or the Diablo III steelseries mouse, as i originaly order the hex for Diablo 3 but i don't want to get a new hex just to have to put up with this bs again....
May 3, 2012 1:06:19 PM

draterrojam said:
Here is my post on overclocker.net

http://www.overclock.net/t/1251378/naga-hex-no-mouse-de...

Hope this helps you guys out. It worked for me like a charm.


Thank you for this. Worked for me. It seems the the "boot-loader" is the software on the mouse itself. and when the update got interrupted it erased the software therefore it was undetected as a mouse because the mouse didn't know it was a mouse.... Still think its silly that this can be overwritten.... but oh well i still love the feel of this mouse if only it didn't have that one software hiccup.... will probably keep the mouse after all and just pray this doesn't happen again
May 3, 2012 5:56:11 PM

Hello, after updating my Naga Hex, I noticed that left clicking once often ends up clicking twice or even there times! This is really bothering me. Has anyone noticed that
too? Is there a way to fix that?
May 3, 2012 10:59:36 PM

Holding the 3 buttons down didn't work for me either, holding down the 3 buttons for 5 seconds and plugging it in while still holding those 3 buttons for 5 seconds after plugging it in DID work. The OS recognized the mouse as a Razer Naga Hex. The synapse did not! the reply I got from razer after the OS recognized the mouse correctly is below;

Now that Windows can recognize the mouse, please try the following:

- Disconnect
- Uninstall Synapse 2.0
- Reboot
- Uninstall .Net Framework 4
- Reboot
- Run Microsoft Updates and apply all available updates for your operating system, rebooting when prompted (This may take some time)
- Install .Net Framework 4 -Standalone from the following links
(http://www.microsoft.com/download/en/details.aspx?id=17...)
- Reboot
- Right click on the Synapse 2.0 installer and choose "Run as Administrator"
- Reconnect

This should resolve the issue. Please let us know the results.

good luck ppl
May 4, 2012 5:00:46 AM

Hey can you repost the dropbox link for the bootloader again? It doesnt seem to be able to work. Thanks!
May 4, 2012 12:42:24 PM

it seems they have changed the drop box. If you need the driver I have it saved on my computer. Send me a PM on here or overclock.net and I will help you get the driver you need. Sorry about that. I was kind of their "beta" tester, as it seems to me. So I'm sure they changed the dropbox to a more "consumer friendly" approach.
May 4, 2012 2:32:47 PM

Nothing Works for me ! My Computer Dosent Recognize the mouse just says unknownd Unit ! I got the mouse yesterday and i really want it to works so badly!! Pls help! I need my computer to recognize the mouse first before i can try what Skycaptn said! And i need the bootloader also so pls Send a new link or smt to me would help so much! Btw my mouse dosent even light up :S The mouse is like turned off but still the computer can sense that smt got in in the USB port but during the Firmware Update of the mouse an littel box poped up '' During the Firmware update, the mouse will become unresponsive. To maintain control of your system, it is recommended to connect a second mouse before you start the update.'' so i guess thats why its unresponsive clearly
May 4, 2012 3:29:59 PM

Hi draterrojam, can u send me the file to my mail @ hellos11@live.com? Thanks alot!
May 4, 2012 3:38:52 PM

Hey draterrojam, Thanks alot!! It worked for me! xD +Rep!!!!
May 4, 2012 3:43:28 PM

Hey draterrojam, Thanks alot!! It worked for me! xD +Rep!!!!
May 4, 2012 3:44:31 PM

Please add me on skype Draterrojam i really need to talk to you Live like direct writing

Skype: linuus4
May 4, 2012 4:09:04 PM

Hey Plaxiz, I sent you a message on overclock.net I am at work now and don't have skype, if you would like to chat later I can arrange it. just send me a pm here or on overclock if you are still having problems after reading my response. Sorry I couldn't be of better help sooner
July 10, 2012 6:05:13 PM

Jewfro said:
Yep I'm sending mine back today. No way should an update kill hardware like this. It just goes to show you how bad razer is and don't get me started on their support.... I'll probably be getting a Logitech G9x or the Diablo III steelseries mouse, as i originaly order the hex for Diablo 3 but i don't want to get a new hex just to have to put up with this bs again....


Yes,conserning razers customer support non existant, I asked a question regarding the instructions on the hex, I am having trouble with downloading it, seems adobe is having a problem reading it, maybe they could send it to me email, but no they send me to support again, After reading these reviews Im concerned about there products as well as customer support.
!