Sign in with
Sign up | Sign in
Your question
Closed

How to make Windows 7 user's folder private?

Last response: in Windows 7
Share
April 29, 2010 6:18:29 PM

Hi all.

In Windows XP there was an option where I could make all my user folders and files in my profile private.
In Windows 7 I just cant find the setting anywhere.

I have two users on my computer. Me (as administrator) and my girlfriend (as standard user)

Whenever she is doing a search or browse the folders on the computer she gets a lot of results and all my documents and pictures is showing up. No restriction at all. She can delete, edit and so on. I can (obviously) do the same to her files and folders.
We both have password protected profiles.

When ever I do a search all her files / mail and documents shows up, because the indexing service is generally at one configuration. All users can search/browse all files in every profile on the computer.

In Windows XP that simply did not happen.

Så where is the setting to make my private folders/files private? if there is a simple way. It seems like Microsoft forgot something otherwise.


Best regards Tim from Sweden.
April 30, 2010 9:23:34 AM

Unfortunatelly that only applies in a home or corporate network enviroment. I don share any files or folders. They are all set to "Not shared"
I mean permissions between local user accounts om the same computer running Windows 7.
But thank you anyhow.

I really think Microsoft has missed this. Everyone is sharing everything all the time.

Not good.

Score
0
Related resources
a b $ Windows 7
April 30, 2010 10:20:34 AM

I believe you should be able to change the permissions on this to solve your problem.

Go to the users folder, right click, and select properties. Go to the security tab. You can then select the user and adjust their permissions. If you don't want them to be able to edit, change their permissions to not be able to write or modify. If you don't want them to see these items, change it so they can't see it, I think you can take away read and list contents. Certainly take away their ability for Full-Control.

I don't think Microsoft forgot about it - these permissions are the same NTFS permissions built into XP. I'm not sure about "private" mode, but I think you can accomplish this through file permissions.
Score
0
April 30, 2010 11:38:34 AM

Yes, I certenly can edit the permissions manually. No problem at all. But it conflicts with the systemdefaults that grant "users" to view and browse files. Whenever I restrict the other users in that group Windows 7 tells me its a permission conflict with inherited permissions or so. I do not want to laborate with the user permissions, when I dont know exacly what consequenses it will give me or the other users on my computer.

All users should be in "users" group otherwise lack of funktionality will appear for other folders/files. Thats not an easy way of doing it. in Windows XP there was a simple checkbox that read "Make my files private" and all the files and folders in my Documents and settings became private.
Score
0

Best solution

a b $ Windows 7
April 30, 2010 5:37:19 PM

According to the following from microsofts help , no standard user should be able to access your files.Only users who are administrators. is your girfriends account set up right.
Here are answers to some common questions about applying permissions to a file or folder.

Do I have to apply permissions to keep other people from accessing my files?
No. Your user account prevents anyone who is using a standard account on your computer from seeing your files. However, it doesn't prevent anyone who is using an administrator account on your computer from seeing your files. If there are other administrator accounts on your computer, instead of using permissions, you can protect your files by encrypting them with the Encrypting File System (EFS). For more information, see What is Encrypting File System (EFS)? If you create a user account for another user on your computer, make sure you create a standard account and not an administrator account.

Share
a c 209 $ Windows 7
May 1, 2010 3:35:46 AM

mibix19 is correct - if you create your accounts as "normal" accounts without any administrative privileges, then each account has no access to any other accounts' files.

If you're creating everyone's accounts with administrative access, then you're essentially defeating the purpose of the security system.
Score
0
May 1, 2010 9:38:27 AM

Best answer selected by Dockland.
Score
0
May 1, 2010 9:38:59 AM

Thank You all. It seems like her account can not see my files on C:\ when she's not in the administrator group. I'm not sure, but I think that in XP, even if all users were in

the administrator group, no one had access to the other local users profiles, even thou you could take ownership of other users files.
I tested to browse my it and it worked fine. But still, there is a difference. Ive moved all our personal folders/files to my D:\ partition and then the functionality with

private files dissapeared. I think I have to set the permissions manually. Thank You all for your answers.

Best regards Tim
Score
0
a b $ Windows 7
May 2, 2010 2:56:25 PM

Thanks for giving me Best answer
Score
0
May 2, 2010 7:00:41 PM

Thank You right back. I have modified permissions manually now and it works like charm.
Thanks again.
Score
0
August 22, 2011 2:24:31 AM

I, too, think that Microsoft missed the mark. My system was upgraded from Vista to Windows 7. The upgrade went without a hitch. But, at the end, I found out months later, I did not own my files in my profile. As the main user with administrator privileges, I didn't even notice. And, the other restricted (non-admin) profile could search and read my files from that other profile. When they navigated directly to my profile it gave them a permissions error. But, when they found it with search it read fine. The problem is that USERS is inherited and needs to be inherited across your hard drive. The other user profile, as a member of USERS has read, execute, list privileges for the entire C drive including my main profile.

So, the solution was to take ownership of all my files. Then, add the other profile user, call it Eve, to the permissions for your profile using Properties. Then, edit the permissions for Eve in your profile to DENY. This will override the inherited USERS permission for that other profile. This fixes the problem. Search will still find the files based on whatever search criteria but those files will not open when clicked. I think this is only a partial solution since the names of the files can still be seen by Search. Possibly reindexing your HD will fix that. And, unfortunately, when you add another profile, you will need to deny that new user too.

Hopefully this helps (even though this thread is closed.
Dwight
Score
0
a c 395 $ Windows 7
August 22, 2011 4:03:41 AM

This topic has been closed by Area51reopened
Score
0
!