Sign in with
Sign up | Sign in
Your question

Concerning Win7 64bit and GAMES...

Last response: in Windows 7
Share
April 30, 2010 8:04:12 AM

Hello,

Yesterday I've upgraded from XP to Win7 64 bit. Considering I have a 64 AMD processor I was hoping to see a boost in performance.

After the nightmare of reinstalling drivers and programs, at midnight I have finally launched BF: Bad Company 2... and boy was I amazed, not only did the game not run faster, it actually now runs SLOWER (noticable lag when there's lot's of stuff on screen). It NEVER happened on XP, and its not graphics lag, since the graphical setting are identical.

Can anyone tell me whats at fault here? Bad driver, 64bit system? WHAT?

Thanks.

Oh and config:
CPU Athlon 64 x2 5200+
RAM 4gb 800mhz
VIDEO 8800GT SLI

More about : win7 64bit games

April 30, 2010 8:13:21 AM

I forgot to mention that 8800GTs are DX9 compatible, but win7 has DirectX11 atm, maybe that's the prob? Should/can I install DX9 on win7? Also BC2 is both DX9 and DX11 compatible, but I've been told it runs better on DX11...
m
0
l
a b $ Windows 7
April 30, 2010 8:17:40 AM

i assume you have 64bit nvidia drivers? I doubt you'dsee a boost in performance, typically stuff the runs about the same, just with more memory to play with.



m
0
l
Related resources
April 30, 2010 8:18:43 AM

Was it a fresh install of Windows 7 or a direct upgrade from XP? If it was just an upgrade I'd be inclined to blame that. Upgrading is not a good way change your OS - a lot of stuff is left behind in the process.

If it was a clean install of Windows 7 try this BC2 tweak guide:
http://gamers-underground.com/action-fps/32463-bad-comp...
m
0
l
April 30, 2010 8:26:01 AM

yup, have nvidia 64bit drivers on my vcards
m
0
l
a b $ Windows 7
April 30, 2010 9:08:54 AM

Not a waste of money, you actuualy need about 2.5-3Gb, so 4 is next step up.

I've not seen any issues since stepping up 64bit. Does device manager show any issues? can you run dxdiag? my first thought is that there is an issue a single driver somewhere, i'm hoping that one of these two tests will show it up.

GPU-z and CPU-z are showing everything as it should be? you are not throttling your cpu i.e. cool n quiet isn't always on? Can you try with only 1 memory stick at a time? win7 is a lot more sensitive to memory issues apparently?

are you really running everything the same with reagrds to bf2 settings? are you running in a dx9 mode or in dx10? Xp couldn't have run in dx10 or whatever that game calls for, whilst win7 would if it could, and that might stress your card whilst all other settings are the same? Clutching at straws here. If you had gone from xp32 to win732 then we wouldn't need to consider this.
m
0
l
April 30, 2010 9:39:51 AM

Yes, I ran dxdiag no problem. Where do i set dx mode??? DXDIAG shows i have dx11, but I'm not really sure what the game is using, since it can run on dx9,10,11... I thought that the game uses the DXDIAG installed on your system by default (DXDIAG11)?!

Also didnt change any CPU settings, didnt change anything tbh. Just updated all the drivers for the 64 system (ran the driver update program, it only showed some problems with SATA(or something like that, i'll write which ones exactly when I'm back home) drivers, which probably arent important).

Also about the cards, I'm pretty sure cards have nothing to do with this, since they are dx9 cards, so even if they wanted to run in dx10 - they can't xD

Also didn't run CPU-z, but I will when I get home...
m
0
l
April 30, 2010 9:57:26 AM

Forgot to mention that I played Bad Company 2 on my Windows 7 (64bit), 4GB ram and GTX 260 with no problems.
m
0
l
April 30, 2010 9:59:51 AM

its not like I'm having major problems, the game runs OK on W7 64, but it ran BETTER on XP
m
0
l
April 30, 2010 10:25:09 AM

In xp it ran in dx9 and in 7 it run dx10 ? Could be it. All 8000 cards are dx10. Try to set the game in dx9 mode.

Brad
m
0
l
April 30, 2010 10:31:09 AM

Ok, now I'm lost, if my card is DX10 card why does it run better with dx9? xD
m
0
l
a b $ Windows 7
April 30, 2010 11:12:20 AM

Firstly, you won't notice any speed difference running 32-bit apps on a 64-bit OS. If the game had been 64-bit capable, things may have been different.

Back to your problem, I suspect your SLI setup may be at fault. My brother experienced exactly the same thing with a Crossfire setup when switching from XP to 7. SLI drivers are notoriously difficult to get right, and until Nvidia brings out a fix you may have to live with lower frames.

NOTE: this is just my take on what might be happening, I have no evidence other than a hunch. I have a single GPU, and so far all the games I've run in 7 perform equal to or better than in XP.
m
0
l
a b $ Windows 7
April 30, 2010 11:15:37 AM

crabdog said:
Was it a fresh install of Windows 7 or a direct upgrade from XP? If it was just an upgrade I'd be inclined to blame that. Upgrading is not a good way change your OS - a lot of stuff is left behind in the process.

If it was a clean install of Windows 7 try this BC2 tweak guide:
http://gamers-underground.com/action-fps/32463-bad-comp...



There's no way to upgrade XP directly to 7, you HAVE to do a clean install.
m
0
l
April 30, 2010 11:42:24 AM

well first of all I'll try and install all the missing drivers first, then I'll force the game to run in DX9, if that doesnt help I'll go with installing the 32bit version of W7 if THAT doesnt help then its back to XP for me then xD
m
0
l
a b $ Windows 7
April 30, 2010 11:59:51 AM

Are you running version 197.45 of the Nvidia Windows 7 x64 drivers? See below in the release notes:

Adds SLI and multi-GPU support for top new gaming titles including Assassin Creed II, Battlefield: Bad Company 2, Command and Conquer 4: Tiberium Twilight, Grand Theft Auto IV: Episodes from Liberty City, Mass Effect 2, Napoleon: Total War, and Zombie Driver.

So if your driver is older than this, you are effectively playing the game without SLI support.
m
0
l
April 30, 2010 12:57:14 PM

yup i have downloaded the latest drivers as said, anyways I've played BC2 with only one 8800GT and it was better than it is now :) 
m
0
l
a b $ Windows 7
April 30, 2010 1:00:35 PM

Tiberius1111 said:
yup i have downloaded the latest drivers as said, anyways I've played BC2 with only one 8800GT and it was better than it is now :) 



Sounds more and more like an SLI problem to me.
m
0
l
a b $ Windows 7
April 30, 2010 2:32:16 PM

mobo drivers?
m
0
l
!