Sign in with
Sign up | Sign in
Your question

Multiple UPnP devices- MS Wins?

Last response: in Networking
Share
Anonymous
October 16, 2004 12:21:56 PM

Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

So my setup is simple- a D-Link wireless router (supports
UPnP) serving up the Internet and a wire to the WAN port of
my Microsoft wireless access point (MN-700) as set up as an
access point, extending the range and filling in a few dead
spots (running on a different channel).

When my programs open up UPnP ports, they talk to the
MN-700 router and not my D-Link router. This of course
does absolutely nothing, considering it's an access point
and has no NAT abilities.

How can I disable the annoucement/discovery of UPNP for my
MN-700 in AP mode (192.168.0.2) or maybe its ?blocking? of
my actual router (192.168.0.1).

This works fine if I am connected to the other router
directly, but not through the MN-700.

Thoughts?
Thanks in advance,
-M
Anonymous
October 16, 2004 1:20:16 PM

Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

The part that I can't seem to figure out is why the MN-700,
when set up as an access point only, still offers UPnP
services and accepts port-forwarding requests (according to
the logs of my applications). These should be ignored by
the router and passed down within the network.

How can I disable UPnP on this router or ensure the proper
functionality?

I believe that the router on the other end is irrelevant of
brand. It's simply a situation of multiple UPnP devices.

Best,
-M


>-----Original Message-----
>So my setup is simple- a D-Link wireless router (supports
>UPnP) serving up the Internet and a wire to the WAN port of
>my Microsoft wireless access point (MN-700) as set up as an
>access point, extending the range and filling in a few dead
>spots (running on a different channel).
>
>When my programs open up UPnP ports, they talk to the
>MN-700 router and not my D-Link router. This of course
>does absolutely nothing, considering it's an access point
>and has no NAT abilities.
>
>How can I disable the annoucement/discovery of UPNP for my
>MN-700 in AP mode (192.168.0.2) or maybe its ?blocking? of
>my actual router (192.168.0.1).
>
>This works fine if I am connected to the other router
>directly, but not through the MN-700.
>
>Thoughts?
>Thanks in advance,
>-M
>.
>
October 17, 2004 12:48:20 AM

Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

You can't disable UPnP on any of the Microsoft routers.

Michael K. wrote:

> The part that I can't seem to figure out is why the MN-700,
> when set up as an access point only, still offers UPnP
> services and accepts port-forwarding requests (according to
> the logs of my applications). These should be ignored by
> the router and passed down within the network.
>
> How can I disable UPnP on this router or ensure the proper
> functionality?
>
> I believe that the router on the other end is irrelevant of
> brand. It's simply a situation of multiple UPnP devices.
>
> Best,
> -M
>

--
Please do not contact me directly or ask me to contact you directly for
assistance.

If your question is worth asking, it's worth posting.

If it’s not worth posting you should have done a search on
http://www.google.com/ http://www.google.com/grphp?hl=en&tab=wg&q= or
http://news.google.com/froogle?hl=en&tab=nf&ned=us&q= before wasting our
time.
Related resources
Anonymous
October 17, 2004 6:57:16 PM

Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

Isn't that a design flaw? A wireless access point has no
purpose to accept UPnP requests (or at least respond
successfully to requests for port mappings).

-M


>-----Original Message-----
>You can't disable UPnP on any of the Microsoft routers.
>
>Michael K. wrote:
>
>> The part that I can't seem to figure out is why the MN-700,
>> when set up as an access point only, still offers UPnP
>> services and accepts port-forwarding requests (according to
>> the logs of my applications). These should be ignored by
>> the router and passed down within the network.
>>
>> How can I disable UPnP on this router or ensure the proper
>> functionality?
>>
>> I believe that the router on the other end is irrelevant of
>> brand. It's simply a situation of multiple UPnP devices.
>>
>> Best,
>> -M
>>
>
>--
>Please do not contact me directly or ask me to contact you
directly for
>assistance.
>
>If your question is worth asking, it's worth posting.
>
>If it's not worth posting you should have done a search on
>http://www.google.com/
http://www.google.com/grphp?hl=en&tab=wg&q= or
>http://news.google.com/froogle?hl=en&tab=nf&ned=us&q=
before wasting our
>time.
>.
>
Anonymous
October 17, 2004 10:04:56 PM

Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

Can you turn off UPnP on your Dlink router?

If so, have you tried switching the position of the D Link and MS routers?

--
Jason Tsang - Microsoft MVP

Find out about the MS MVP Program -
http://mvp.support.microsoft.com/default.aspx

<anonymous@discussions.microsoft.com> wrote in message
news:11b701c4b494$43f5d3c0$a301280a@phx.gbl...
> Isn't that a design flaw? A wireless access point has no
> purpose to accept UPnP requests (or at least respond
> successfully to requests for port mappings).
>
> -M
>
>
>>-----Original Message-----
>>You can't disable UPnP on any of the Microsoft routers.
>>
>>Michael K. wrote:
>>
>>> The part that I can't seem to figure out is why the MN-700,
>>> when set up as an access point only, still offers UPnP
>>> services and accepts port-forwarding requests (according to
>>> the logs of my applications). These should be ignored by
>>> the router and passed down within the network.
>>>
>>> How can I disable UPnP on this router or ensure the proper
>>> functionality?
>>>
>>> I believe that the router on the other end is irrelevant of
>>> brand. It's simply a situation of multiple UPnP devices.
>>>
>>> Best,
>>> -M
>>>
>>
>>--
>>Please do not contact me directly or ask me to contact you
> directly for
>>assistance.
>>
>>If your question is worth asking, it's worth posting.
>>
>>If it's not worth posting you should have done a search on
>>http://www.google.com/
> http://www.google.com/grphp?hl=en&tab=wg&q= or
>>http://news.google.com/froogle?hl=en&tab=nf&ned=us&q=
> before wasting our
>>time.
>>.
>>
!