Sign in with
Sign up | Sign in
Your question

Installed new SATA DVD drive, now Win7 won't boot

Last response: in Windows 7
Share
January 4, 2013 3:07:34 PM

Hello,
I recently built a new computer and installed Windows 7 on a Raid 5 array. I had some trouble setting up the array at first as instructions from ASRock are a bit messy IMO, and also I did not have an optical drive (didn't realize that the MB wouldn't have headers for my old IDE drive). I did get everything working, with my array on SATA ports 1-2-3, and the Caviar Green plugged in port 5. Installed Windows, drivers, apps and games (tens of GBs of downloads...)

Yesterday I received my SATA DVD writer and thought I would just plug it in SATA port 4 (last remaining port) and be ready to go. Here comes the trouble.

Did this, and Windows won't boot. It just gets to a black screen with flashing cursor and stays there forever. Everything is recognized properly in BIOS, and I can boot off the Win7 DVD just fine.

I figured I would do that and tell it to "repair Windows" or whatever. It doesn't see my Windows installation at all: trying to load RAID drivers off a USB device or DVD (tried both), Windows still isn't recognized.

Now for the tricky part. When I browse to choose drivers, I initially see my empty Caviar, and the USB drive that holds the drivers. I load the drivers and Windows still doesn't appear. I go back to browsing for RAID drivers, and now my array shows up! I can browse the files from the Windows install, all my drives and everything show up, but the install disc still tells me that I don't have Windows installed, so obviously I can't repair it. I did use the Windows disc to look for errors, but that returned nothing.

I also tried unplugging anything unnecessary, plugging everything like it was before the DVD drive arrived, plugging drives in different SATA ports... Nothing helps.

In the BIOS the SATA controller is set to RAID. I'm afraid it's trying to see a raid composed of all 4-5 drives together? The BIOS calls whatever drive is in port 4 "RAID: 'name of drive'". What? Any drive in port 5 shows up as "SATA: 'name of drive'". If I boot into the RAID controller everything looks fine though. ASRock says to "install ODD drivers in SATA port 5": I tried plugging the drive there, but am I supposed to get drivers for it? But even then, if I go back to my initial configuration (without the DVD drive) Windows still won't boot.

Could bootsect be broken somehow? How do I repair it? I could just format, but my Windows was a clean install and it took days to install all my programs and games, so that really would be a pain. This has to be recoverable, since until plugging in the DVD drive everything worked perfectly.

I've run out of options... Please help?

ASRock 970 Extreme 3
AMD FX-6100
Patriot Viper Extreme 2x4GB DD3-1866
3xSeagate 320GB SATAII in Raid 5 (Win7)
WD Caviar Green 1.5TB SATAII (empty for now)
LG DVD Writer SATA
Antec Truepower 750W
January 4, 2013 3:15:51 PM

I found another thread that looks similar, and maybe this answer would be the solution, but I don't understand how to do that.
m
0
l
January 5, 2013 2:38:56 PM

AMD chipset divide sata port in 2 group. The first 4 sata port will be group 1 and the other 5 and 6 will be group 2.

Now, what is good with that is, you can have RAID or AHCI on group 1 and legacy ide (to use the drive without any driver) drive on group 2.

In BIOS, you should have an option to set sata device 4-5 (or 5-6 , depending if the first SATA drive is numbered 0 or 1) to work as : same as devices 0-3 (1-4), or IDE.

Now, for your array, you will use sata connector 0-3 set as RAID and connector 4-5 set as IDE(or legacy).

So, just set, the ide mode for the group 2 connector to anything but same as group1, plug the dvd to the last connector, change the boot device to your bootable array, and it should work. Because sometime, when adding a device, the boot device switch to the first single drive available, so it might be set for the empty drive.
m
0
l
Related resources
January 7, 2013 2:59:49 PM

After some poking around, that's what I understood. However, in my BIOS I only could find whether to activate RAID or not. This seems to affect ports 1-4 only, with port 5 and eSATA port being AHCI drives (the MB has only 5 ports + 1 eSATA).

What I ended up doing is installing a fresh Windows on a spare drive on port 5 and booting from it: then I could see both of my Windows installs in the boot menu. I installed and ran EasyBCD to reconfigure my bootloader: I saw that it had disappeared from my raid array, which somewhat explains why Windows wouldn't boot. I created a new bootloader for launching the Windows that's on my array, formatted the "spare" drive, and everything is now fine.

I hope that can help someone else some day!
m
0
l
February 8, 2013 2:56:07 PM

I had something similar:
IDE hard disk and IDE DVD R/W drive

Replaced IDE DVD drive with SATA Blu Ray,
machine wouldn't boot. ("boot disk failed, insert systems disk")
unplugged Blu Ray (but didn't plug in DVD) still wouldnt reboot.
Went into BIOS, made sure that HDD was first boot device. check.
still wouldn't reboot
sctratched head, read threads (luckily this thread was only the nd one I came to!!!)

took out hard disk to re-seat it, and BINGO!!
There's the little dip connector sitting in the "Master with slave present" bay.

Removed it (to invoke "master alone" mode)
Boots fine
Installed SATA Blu Ray
Boots fine

Happy bunny!
m
0
l
!