Sign in with
Sign up | Sign in
Your question

Bootmgr is missing after a successfull Windows 7 installation.

Last response: in Windows 7
Share
January 4, 2013 3:50:50 PM

Hello,

I've had a problem with my computer booting up ever since I did a clean reformat. Whenever I turn on my computer, it goes to the black screen and says the default, "Bootmgr is missing, press ctrl alt delete to restart, blah blah blah".

The only way to get it to work is I have to press F12, and select my HDD and press enter twice. It then successfully loads and such and does fine from that point on. Problem is, it's kind of annoying and I want to rid of it.

I'm currently at work, but when I get home I'll be more than happy to take some screenshots and stuff if that would help.

Could anyone help me fix this problem?

ALSO, one more thing.
Ever since I did the recent reformat, whenever I jumped in my first game, it played for about 2-3 minutes and then randomly decided to turn off. The lights on my computer stays on, but the sound, vision, and everything turns off/goes black. Could this be my PCU, as I have a 550 Watt PCU? (My GPU is the GTX670).

(I'm wondering if the Bootmgr is a problem to this as well, let me know.)

Thanks in advance!
a b $ Windows 7
January 4, 2013 4:48:29 PM

I would recommend creating a Hirens Boot CD and utilize some of the options available to attempt to resolve your issue.

As for the computer turning off, did you reload most recent graphics drivers? If not, I highly recommend it.
a b $ Windows 7
January 4, 2013 4:55:07 PM

if you had more than one HDD or SSD attached to the computer While you reinstalled windows, now you know why geeks say to only have one drive connected

disconnect any drives other than the boot drive and boot from the windows DVD - run a repair and it should fix the issue
Related resources
January 4, 2013 5:04:21 PM

Most of the time, this can be an easy fix by going into the BIOS and change the primary boot device to the one you installed Windows onto. I'm guessing that there are multiple drives in your computer. If this does not fix it, you may need to re-install Windows with only ONE hard drive connected.

As for your Power supply (not PCU), it is not enough power to maintain computer stability. Go up to 700 to 800 watts to get more available power and better idle efficiency.
January 4, 2013 5:24:43 PM

@hedwar2011 - Reload my graphic cards as in reinstalling the drivers and such? If that's what you mean then yes, I reinstalled/updated my graphics drivers with the latest updates.

@Dingo07 - I did in fact have an SSD AND a 1TB HDD hooked up at the time of the install of Windows 7. I see how that could be an issue and if the other option I'm going to try first (What Jayambroziak said) doesen't work, I'll give this one a go.

@jayambroziak - Going into the BIOS is done by pressing F12 on the computer when it's starting up correct? If so, I'm guessing it's one of the options to select my SSD to boot from, from there? How exactly will I know it's my SSD? Will it just be the default, "HDD"?

And about the Power Supply (Opps, I thought it was the PCU this whole time :p ) I just recently (Today) bought another Power Supply. I should be going from the 550 Watt to a 750 Watt, hopefully this helps but I won't know until Tuesday =/
a b $ Windows 7
January 4, 2013 5:26:23 PM

you don't have to reinstall windows to fix the boot record
January 4, 2013 5:28:07 PM

So all I have to do is repair it? How is this done?
January 4, 2013 5:42:33 PM

Going into the BIOS is done by pressing F12 on the computer when it's starting up correct? If so, I'm guessing it's one of the options to select my SSD to boot from, from there? How exactly will I know it's my SSD? Will it just be the default, "HDD"

It should say ssd on it. Either way it usually has the ssd name say intel ssd or something like that. I would differently try that first as it's pretty easy thing to fix.
January 4, 2013 5:46:14 PM

@Dingo07 - Thank you.

@kingnoobe - Unless I'm mistaken, I've tried this I think. Before everything loads I press F12 and it brings me to the boot screen. It has like 4-5 things I can choose from, USB, USB-blah, USB-blahblah.. stuff like that.

So when it goes to that menu, if I happen to select the SSD, should it ALWAYS boot from the SSD from then on? Or is there some option I have to enable?
January 4, 2013 7:33:52 PM

F12 is your boot options menu. Pressing Delete key will more than likely get you to the system BIOS. If not Delete, try F1 or F2. When in BIOS, push right arrow key to move over to boot. Down arrow to boot device priority, hit ENTER, hit the plus (+) key until the correct drive (your SSD) is in the 1st boot device slot. Hope that helps.

This may help you with your problem, in slight variations.

http://social.technet.microsoft.com/Forums/en/w7itproin...
a b $ Windows 7
January 4, 2013 8:03:52 PM

the problem is your bootloader


here is a guide to fix mbr

http://technet.microsoft.com/en-us/magazine/ee851681.as....



if that doesnt work then download and install easy bcd


on left side click on "bcd backup/repair"

then on the right click on "re-create/repair boot files"


then on "perform action"

when its finished you should be able to reboot and it should work
January 4, 2013 9:06:48 PM

the problem wouldn't be his bootloader if the BIOS is pointing to the wrong drive to load :hello: 
a b $ Windows 7
January 4, 2013 9:12:14 PM

You need to c hange the boot order in the bios as suggested by Jayambroziak.
You said that in order for it to boot correctly, you have to go in and maually select the device each time to boot to; That means that the boot order is pointing to a non-bootable device first instead of your ssd.
a b $ Windows 7
January 4, 2013 9:39:05 PM

Simply forgot to change the boot order in the bios, the working os drive needs to be set to number one in the boot list and then saved, sorted!. Any other drive in the list with out an Os installed with not have an MS bootmanager. Likely that drive is set to number 1 in the boot list before the working Os drive.
!