Sign in with
Sign up | Sign in
Your question

Razer Naga Hex Profile Mixing

Last response: in Computer Peripherals
Share
June 9, 2012 10:03:48 PM

I just got myself a Razer Naga Hex mouse. Installed drivers and Synapse 2.0 Configurator. Everything was working perfectly up to this point. I even started a game to give the mouse a test-run and every button worked as intended.
Now after the game i wanted to set up multiple profiles... Then the trouble began.

I had the following profiles set up:
- General : For usage in desktop and browser. 1 was set to Firefox, 2 was set to LoL. The button under the scroll
was set to "Manager" (= profile). Rest stayed at default)
- LoL : For usage in League of Legends (duuh xD). Not much changed in this profile. I just set the speed and acceleration higher
and again the button under the scroll was set to "Manager".
- Manager : Only used to change profiles when i wanted. 1 was set to "General". 2 was set to "LoL".

Now whilst playing another LoL game, switching profile to LoL, I couldn't use buttons 1 and 2, as they opened firefox and league of legends.
Immediately closed down LoL and started checking what was wrong. I made a new profile (completely default), opened word and tried using buttons 1-6. Normally it should type the numbers. It did for 4-6, but again for 1 and 2 started opening Firefox and LoL. Even after deleting every profile but the default one didn't fix the "Crash" of the numbers 1 and 2.
This problem was resolved after restarting the pc. Then i reconfigured the profiles to the exact same settings as mentioned above, restarted and it still failed in the same way. Thus meaning i can only have 1 profile in total. =S

If there is anyone that can help me on this subject i would be really grateful.
June 10, 2012 9:46:28 AM

I am having the exact same problem with my Naga Hex..

I had four profiles setup

General: Binds to launch programs etc, Skype, HoN, Steam and what have you

HoN: Binds for HoN

D3: Binds for Diablo 3

DCUO: Binds for DCUO..

The problem is when I "link program" in the profiles and for example go from General to DCUO, the binds remain as General, 5 opening skype, 2 opening Chrome etc..

When I first reboot my computer and select the profile I want its fine..but once I change it they start overlapping or something..this really defeats the purpose of having profiles..

The only fix is either running one profile and manually rebinding for each game your about to run..or rebooting and manually selecting the profile of the game your about to play and if you change games you have to reboot again and select that profile..its not worth it..


Edit: After further investigation it seems the only binds actually over lapping is the binds to launch programs, the profiles do change for buttons like Alt, CTRL etc that are bound to numbers but the buttons that have Launch binds remain as Launch bound..even if the selected profile has it as default


In other words its the launch binds over lapping into the Gaming profiles..removing all launch binds and rebooting fixed it for me, but it sucks I can't use the launch binds..
June 10, 2012 7:05:51 PM

Its not only the launch binds for me though... I retried to (again with the Manager) make a profile switch on 1 and 2. As soon as i switched it and pressed 1 or 2 it went to the profile noted in the general tab, not the function that i assigned it.
Then again i made a default profile and tried the number buttons in a notepad file (All of this in the same session) and the numbers 1 and 2 were only switching profiles instead of typing the numbers (4-6 worked fine). Even after i delete the manager to switch profiles the 1 and 2 button don't work.
Related resources
June 10, 2012 7:36:08 PM

I honestly don't know then, any bind outside of a launch bind isn't overlapping for me, for example DCUO is default 1-6 because the skills work in that manner in the game

HoN I have Left ALT bound to 2 to access inventory items holding alt+qweasd, I can switch profiles back and forth and these binds are fine, the same applies to CSS, I have a macro bind for CSS on 2 and 3, switching profiles is fine

Only thing overlapping for me is Launch binds :( 
June 11, 2012 12:35:21 PM

Do you switch the profiles manually or with the old "Manager" profile? If you use the profile, how are they bound?
June 23, 2012 10:45:07 PM

I am having the same problem on the Naga Molten... I think it has to do with the latest driver updates, but I'm not sure. I didn't have this problem until I downloaded the new software updates a few weeks ago... I have found that if you switch to the profile you want, and it doesn't work right, unplugging the mouse for a few seconds, and then plugging it back in will correctly switch the profiles and make it work correctly until I need to switch it again. It's easier than shutting down and restarting at any rate, but still annoying. Until there is a fix, this does work even if it's a pain to constantly be reaching behind my tower to plug and unplug. Anyway, I hope something fixes it soon. Any new solutions found at all?
!