Sign-in / Sign-up
Your question

Error City! But Why?

Tags:
  • CPUs
Last response: in CPUs
Anonymous
a b à CPUs
January 21, 2001 10:58:50 PM

My errors have to do with the CPU (a Celeron 333), I'm sure. But just bear with me to find out why. You see, in games, such as Vampire: The Masquerade or Starlancer the game will, at random intervals, crash out to the desktop without error messages. Vampire *may* sometimes install and play fine, but after the patch is installed it will crash every time.
Baldurs Gate 2 is the worst offender, because not only does it crash to the desktop without a reason, it has a plethora of other bugs which other users on the Baldurs Gate 2 message board have nver had, and which Interplay Technical Support cannot explain. Crashes in it's game files, lockups and also a CRC error in a CAB file during installation. That last error only occurs sometimes, usually at around 14% through the installation. The CD's are not damaged... I have tried a full install on a freinds machine and the CRC error has failed to materialise there. Patching it also doesn't help.
On the net, Kernel32.dll crashes occassionaly. This is rare, but when it does happen, it will then take down other files, or result in a BSOD.
I use WinME, but not because I want to but because I have to. If I try to install Windows 98 SE, during the install process there is an illegal operation error, and Windows is screwed from the outset. I have reinstalled Windows ME (fresh install) countless times as well.

WHAT I HAVE TRIED TO DO TO FIX THE PROBLEM;

In regards to Vampire, the official website says that it may crash to the desktop without an error and if it does, that you should have your desktop resoloution at 640x480 with 256 colors. I tried that, and it still fails to fix the problem. Starlancer says that with Voodoo 3 3000 cards (which I have) that running the game at 1024x768 causes the game to crash to the desktop. Well, I run the game at 800x600 and it still happens, as well as at 640x480 and still no luck. I have installed and reinstalled these games countless times and it has not helped. I have noticed that errors within these games occur mainly when it plays intro movies.
And then theres Baldurs Gate 2. Interplay Technical Support has suggested numerous ways to try to get the game to work. I have turned down Graphical Acceleration, turned off DMA support on the hard drives and CD ROM, turned read ahead optimisation off for both the hard drive and CD ROM, gotten the latest drivers for the sound card and video card and even defragmented the drive. It crashed under both Direct X 7 and 8. Nothing has fixed it. Not even numerous reinstalls. However, as with Starlancer and Vampire, it does crash to the desktop during the intro movie.
I have also run Scandisk and discovered a few things of interest. Lost clusters are common, on both F and H drives, and F Drive in particular has a problem with its FAT allocation tables. Even when these things are fixed, the problems with the games occur. I have performed a Thorough Scan of the drives for bad sectors, but have found none.
Norton WinDoctor 2000 (not installed) says that there is an Error when it tries to scan the registry, both within WinME and Win98 SE. I cannot find a way to fix this.

MY THEORIES;

In my non expert opinion, I think its either the CPU or the CD ROM. I overclocked the CPU and about a year ago I turned it back to its normal speed. It is possible that that has damaged the CPU, but evidence points to the contrary. There are no burn marks on the CPU and 'Hot CPU', a program which runs intensive tests on CPU's to search for errors, found no errors even after 6 hours of continuous testing. But the CPU is still a possibility.
The CD ROM (a Mitsubishi 50x) is another possible culprit, because the drive tray is slightly bigger than a CD. Maybe its not transferring data correctly? The evidence to contradict that theory though, is that I had similar errors before getting the CD ROM 6 months ago, in Heavy Gear 2.
I don't think its the Primary Hard Drive, which is a 7200rpm 30GB Seagate Barracuda. For one, I bought it 4 months ago, and despite the errors I mentioned before, other programs run fine. I played the first Baldurs Gate without a hitch, and Thief Gold, Planescape Torment, Birth Of The Federation, and X: Beyond The Frontier all run perfectly.
I have never overclocked the Voodoo 3, so I think its not to blame. The RAM, which is PCI100 RAM, may be a possibility. I created a RAM drive when I first got it, in an attempt to make UltraHLE run smoother, but only did it once or twice, which is why I don't think it is to blame either.
Of course, I could be wrong on any of these points. Which is why I have asked all of you. I hope you can find out why it is doing this, as it has driven me mad!

More about : error city

January 22, 2001 12:13:38 AM

*hint* Few people are actually going to read thru ALL of that to help you. You might want to shorten it. Just a suggestion =)

-MP Jesse
January 22, 2001 1:06:10 AM

sounds like you have a bad harddrive.



- Amd Helpdesk -
Related resources
January 22, 2001 3:28:50 AM

Are you doing a clean install from a freshly formatted hard drive? You have given us alot of information about the crashes but not enough about the system...How much ram? Motherboard? You do realize that the games you are playing are about maxing your tiny 333 out dont you? From what I can guess at this point it would seem that your problems may actually in fact be a case of a bad power supply or voltage regulator on your motherboard. But this is merely a guess at this point. The first area to start is at the install of windows. If this is not going correctly then do your self a favor and stop there. No need to go on and install games if you know you have problems.

A little bit of knowledge is a dangerous thing!
Anonymous
a b à CPUs
January 22, 2001 4:37:59 AM

check your power supply.
if it is full of fuzz i will get hot and not be able to carry the full rated load.
bad power can cause random memory issues.

who is more foolish...
the fool, or the fool that takes his advice?