Sign in with
Sign up | Sign in
Your question
Solved

How to make program files folder on secondary hard drive default?

Last response: in Windows 7
Share
January 5, 2013 4:17:53 PM

I have a 120GB SSD for system etc.
I have a 1TB HDD for everything else. How do I change the default program files folders (x86 and regular) so that when I am installing a program the first choice is on this second drive instead of C?

Best solution

January 5, 2013 5:37:24 PM

The 64bit version has two versions of regedit.
BACK UP YOUR REGISTRY FIRST!

1.) Enter into Start>Run: %systemroot%\syswow64\regedit
2.) Go to: HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion
3.) Change the Path in DWORDs ProgramFilesDir, ProgramFilesDir (x86), ProgramW6432Dir to the new path, probably just changing the drive letter.

Make sure you create and copy over the files for both the 32 and 64 bit folders.
Share
January 6, 2013 8:43:28 PM

Best answer selected by ryanlaxman.
m
0
l
Related resources
January 6, 2013 10:03:23 PM

bdubs85 said:
The 64bit version has two versions of regedit.
BACK UP YOUR REGISTRY FIRST!

1.) Enter into Start>Run: %systemroot%\syswow64\regedit
2.) Go to: HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion
3.) Change the Path in DWORDs ProgramFilesDir, ProgramFilesDir (x86), ProgramW6432Dir to the new path, probably just changing the drive letter.

Make sure you create and copy over the files for both the 32 and 64 bit folders.

It didn't work... and yes I restarted.
m
0
l
May 16, 2013 5:50:28 AM

Once I follow your below steps. Do I need to create "Program Files" and "Program Files (x86)" folder in my new appointed drive?

bdubs85 said:
The 64bit version has two versions of regedit.
BACK UP YOUR REGISTRY FIRST!

1.) Enter into Start>Run: %systemroot%\syswow64\regedit
2.) Go to: HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion
3.) Change the Path in DWORDs ProgramFilesDir, ProgramFilesDir (x86), ProgramW6432Dir to the new path, probably just changing the drive letter.

Make sure you create and copy over the files for both the 32 and 64 bit folders.


m
0
l
November 5, 2013 11:53:27 PM

bdubs85 said:
The 64bit version has two versions of regedit.
BACK UP YOUR REGISTRY FIRST!

1.) Enter into Start>Run: %systemroot%\syswow64\regedit
2.) Go to: HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion
3.) Change the Path in DWORDs ProgramFilesDir, ProgramFilesDir (x86), ProgramW6432Dir to the new path, probably just changing the drive letter.

Make sure you create and copy over the files for both the 32 and 64 bit folders.


when you say "Make sure you create and copy over the files for both the 32 and 64 bit folders.[/quotemsg]", what exactly do we do here? just copy and paste both Program Files folders?
m
0
l
!