Solved

Hard drive not showing up in Windows

Hi all, really hope someone out there can help me!

I have a SATA hard drive which shows up in BIOS, but not in 'Computer Management' or 'Device Manager'. Does anyone know why this could be?

Surely if it was dead, it would not be in BIOS, but Windows doesn't seem to see it anywhere..

Thanks,

Mark
Reply to mk1
20 answers Last reply Best Answer
More about hard drive showing windows
  1. Best answer
    This is from The_Prophecy Found in the Windows 7 tips....
    I hope this answers your question.


    Windows 7 hides empty drives (both fixed, and removable drives) by default, but many people don't realize this. If you could swear you had a freshly formatted drive just hooked up to the computer, but can't seem to find it, click on Organize, Folder and Search options, select the View tab, and uncheck the Hide empty drives in the Computer folder box.

    If the drive is not yet formatted, make sure you run through the steps above (so you aren't further confused in a minute), and then type diskmgmt.msc into the Start Menu search bar. Here you should see all drives connected to your computer. Format as necessary and then they will appear in the Computer folder.
    ------------------------------ Please give credit where credit is due! If you think this post was the most helpful, please remember to mark it as the best answer!
    Reply to The_Prophecy Revove from the list of quoted messages Add to the list of quoted messages
    Reply to Pata
  2. I just put a new 500 GB drive in my system and it shows up under "Disk Management" from there you just format and it's done!!!!
    Are you running win7 or xp/vista?
    Reply to johnnyq1233
  3. Sorry, should have said it is a hard drive which I have been using in an external case (actually, it came in a My Book).
    But it disappeared one day and so to try and get the data out, i took it from the case and plugged it in directly, so it is formatted and full and was working for a couple of years.. but then suddenly disappeared and now is no longer accessible.
    While most recovery tools need to see the drive, Windows seems to now know it is there. However, it is in BIOS, so perhaps there is something else which can find it, or a way to force Windows to find it.
    But as I said above, it is not in Device Manager either.
    Thanks for your replies!
    Reply to mk1
  4. As it "disappeared one day", I would guess that there is some fault with it. This would explain why Windows can't see it.

    One possibility would be to boot from a Linux live CD to see if that can see the drive.
    Reply to Ijack
  5. The thing is that would BIOS see it if it is broken? I did try to boot into an Ubuntu CD, on my laptop, but am unable to try on a desktop at the moment.. I am not really familiar with linux so wasn't sure where to look to be honest, but it wasn't automatically found when connected by USB.
    Reply to mk1
  6. mk1 said:
    it wasn't automatically found when connected by USB.

    If it wasn't damaged (either the hard drive itself or the partition) then it should show automatically on most Linux setups. Do you know anyone else with a Windows computer that you could try it on? How about another hard drive that you can try in the enclosure?

    I'm afraid there are situations where a drive will show in the BIOS but is so badly damaged that it is unusable in an OS.
    Reply to Ijack
  7. I see. I was hoping that the fact BIOS can see it might mean it isn't completely dead. But it is looking that way.. Strange because it was just sitting there, working perfectly..

    I don't have another drive at the moment to try, but perhaps will try that when I get the chance.

    Well thanks a lot for all the feedback!

    Mark
    Reply to mk1
  8. Pata said:
    This is from The_Prophecy Found in the Windows 7 tips....
    I hope this answers your question.


    Windows 7 hides empty drives (both fixed, and removable drives) by default, but many people don't realize this. If you could swear you had a freshly formatted drive just hooked up to the computer, but can't seem to find it, click on Organize, Folder and Search options, select the View tab, and uncheck the Hide empty drives in the Computer folder box.

    If the drive is not yet formatted, make sure you run through the steps above (so you aren't further confused in a minute), and then type diskmgmt.msc into the Start Menu search bar. Here you should see all drives connected to your computer. Format as necessary and then they will appear in the Computer folder.
    ------------------------------ Please give credit where credit is due! If you think this post was the most helpful, please remember to mark it as the best answer!
    Reply to The_Prophecy Revove from the list of quoted messages Add to the list of quoted messages



    THANK YOU !!
    For weeks I have been wresling with this andwith your advise it took about a 1/2 hour to solve the problem A+ Sugestion
    Reply to hotcana
  9. Pata said:
    This is from The_Prophecy Found in the Windows 7 tips....
    I hope this answers your question.


    Windows 7 hides empty drives (both fixed, and removable drives) by default, but many people don't realize this. If you could swear you had a freshly formatted drive just hooked up to the computer, but can't seem to find it, click on Organize, Folder and Search options, select the View tab, and uncheck the Hide empty drives in the Computer folder box.

    If the drive is not yet formatted, make sure you run through the steps above (so you aren't further confused in a minute), and then type diskmgmt.msc into the Start Menu search bar. Here you should see all drives connected to your computer. Format as necessary and then they will appear in the Computer folder.
    ------------------------------ Please give credit where credit is due! If you think this post was the most helpful, please remember to mark it as the best answer!
    Reply to The_Prophecy Revove from the list of quoted messages Add to the list of quoted messages


    Excellent answer. *bow*
    Reply to ikoslog
  10. i have a similar problem. sometimes the HDD shows up in the BIOS and sometimes it doesnt. i havent been able to fully load and OS onto it yet and i assume its formatted because sometimes it shows up and i try loading an OS onto it but it seems to disappear after a while. ive plugged it in and out on different SATA ports on the mobo and it varies which one allows the HDD to show up in the BIOS. do i just have dodgy SATA serial and power cables?
    Reply to BlackKnight343
  11. BlackKnight343 said:
    i have a similar problem. sometimes the HDD shows up in the BIOS and sometimes it doesnt. i havent been able to fully load and OS onto it yet and i assume its formatted because sometimes it shows up and i try loading an OS onto it but it seems to disappear after a while. ive plugged it in and out on different SATA ports on the mobo and it varies which one allows the HDD to show up in the BIOS. do i just have dodgy SATA serial and power cables?


    Here are some solutions to try:

    Right click my computer/ manage/ storage/ disk management allocate and assign drive letter.
    http://www.tomshardware.com/forum/265764-32-guide-installed-disk-system

    Another very nice guide to try step by step:

    http://www.tomshardware.com/forum/265764-32-guide-installed-disk-system

    And finally --

    If nothing else works..

    Take drive out -- put in another working computer and format with that computer. Now put drive back into your computer,.. and often that works.
    Reply to ikoslog
  12. Pata said:
    This is from The_Prophecy Found in the Windows 7 tips....
    I hope this answers your question.


    Windows 7 hides empty drives (both fixed, and removable drives) by default, but many people don't realize this. If you could swear you had a freshly formatted drive just hooked up to the computer, but can't seem to find it, click on Organize, Folder and Search options, select the View tab, and uncheck the Hide empty drives in the Computer folder box.

    If the drive is not yet formatted, make sure you run through the steps above (so you aren't further confused in a minute), and then type diskmgmt.msc into the Start Menu search bar. Here you should see all drives connected to your computer. Format as necessary and then they will appear in the Computer folder.
    ------------------------------ Please give credit where credit is due! If you think this post was the most helpful, please remember to mark it as the best answer!
    Reply to The_Prophecy Revove from the list of quoted messages Add to the list of quoted messages
    Reply to Musclehead52
  13. Thanks BlackKnight & Pata,
    I was having the identical issue and this solution solved my problem 100%!
    Thank you both!
    Reply to Musclehead52
  14. Pata said:
    This is from The_Prophecy Found in the Windows 7 tips....
    I hope this answers your question.


    Windows 7 hides empty drives (both fixed, and removable drives) by default, but many people don't realize this. If you could swear you had a freshly formatted drive just hooked up to the computer, but can't seem to find it, click on Organize, Folder and Search options, select the View tab, and uncheck the Hide empty drives in the Computer folder box.

    If the drive is not yet formatted, make sure you run through the steps above (so you aren't further confused in a minute), and then type diskmgmt.msc into the Start Menu search bar. Here you should see all drives connected to your computer. Format as necessary and then they will appear in the Computer folder.
    ------------------------------ Please give credit where credit is due! If you think this post was the most helpful, please remember to mark it as the best answer!
    Reply to The_Prophecy Revove from the list of quoted messages Add to the list of quoted messages


    Thank you ! for me this was the best answer. It worked for me.
    Reply to Newbuilt
  15. Pata said:
    This is from The_Prophecy Found in the Windows 7 tips....
    I hope this answers your question.


    Windows 7 hides empty drives (both fixed, and removable drives) by default, but many people don't realize this. If you could swear you had a freshly formatted drive just hooked up to the computer, but can't seem to find it, click on Organize, Folder and Search options, select the View tab, and uncheck the Hide empty drives in the Computer folder box.

    If the drive is not yet formatted, make sure you run through the steps above (so you aren't further confused in a minute), and then type diskmgmt.msc into the Start Menu search bar. Here you should see all drives connected to your computer. Format as necessary and then they will appear in the Computer folder.
    ------------------------------ Please give credit where credit is due! If you think this post was the most helpful, please remember to mark it as the best answer!
    Reply to The_Prophecy Revove from the list of quoted messages Add to the list of quoted messages
    Reply to Priscilla Soares-Wilson
  16. Yes, I knew there was away to unhide a HDD, but for the life of me I forgot, so thanks for reminding me :) an it worked
    Reply to Priscilla Soares-Wilson
  17. ikoslog said:
    Right click my computer/ manage/ storage/ disk management allocate and assign drive letter.

    Yes, this solved it for me.

    For some reason, Pata's solution (running diskmgmt.msc from the start menu) did not show Disk 1, my second disk. But when I ran Disk Management from Manage - Storage etc. it showed up, and I could assign it a letter and format it. Weird. Thanks!
    Reply to Klausert
  18. This helped me solve my problem as well.

    The only extra work I had to do was format the drive using command prompt.

    Here are the commands I used to format:

    Quote:
    Diskpart

    list disk

    Select Disk N (N is the number of the drive you want to format)

    Clean

    Create Partition Primary

    Assign (You get option to format now - I choose NFTS and 4096bytes as I will be putting large files on the drive)

    Exit


    Your drive will now be formatted.
    Reply to Rabmac
  19. mk1 said:
    Hi all, really hope someone out there can help me!

    I have a SATA hard drive which shows up in BIOS, but not in 'Computer Management' or 'Device Manager'. Does anyone know why this could be?

    Surely if it was dead, it would not be in BIOS, but Windows doesn't seem to see it anywhere..

    Thanks,

    Mark
    Reply to Ernest_15
  20. I also had a similar problem with my 500GB hard drive which was showing up in BIOS but not in windows(8). The simplest thing i did was to install new windows on that very hard drive which was showing up in BIOS but not in disk management. After the installation i had two windows running on my computer (thus the previous and the newly installed windows). Now when i boot my PC from the newly installed windows, it shows all my hard drives including that which was not able to show up in disk management and all i had to do was to move necessary files from the drive containing the first windows to my new 500GB storage and format that very hard drive. And it was just simple and i didn't loose any file. Try it and see for yourself.
    Reply to Ernest_15
Ask a new question Answer

Read More

Windows 7