Sign in with
Sign up | Sign in
Your question

Thinkpad W510 - 5 out of 8GB system reserved Memory

Last response: in Laptops & Notebooks
Share
December 13, 2010 10:05:02 AM

Hi, i allready searched the forum for this problem, but i cant seem to find any similar problem with a working solution for me

i have a Thinkpad W510 laptop, wich came with 2GB DDR3-1066 Memory

i upgraded this to 8GB (4x2GB DDR3-1333) from kingston (KTL-TP3B/2G) but then i got the following problem:

Bios detected 8GB of memory, memtest x86 succesfully tested everything, no errors
when i got into windows:
Installed memory: 8.00GB (3.06GB Usable)
Operation System: Windows 7 Professional 64Bit

i called Lenovo, they said:
"its not our memory so we cant help you" - "we think its the frequency that is wrong"

after that i clearly got the message that they didnt want to pay any attention to this becous i didnt buy their memory

so i went and bought 4x2GB DDR3-1066Mhz memory from lenovo, so that they didnt have any excuses any more

after contacting the helpdesk again, they said "since the memory test passed, its not hardware related and it doesnt fall under the warranty"

i'll try and upload a screenshot in a few hours when i get home,

anyone has any ideas?
bios reads correctly, ive tried changing the extended memory settings, no luck
in windows MSCONFIG there's no settings changed in the boot settings
i have changed all the memory to all possible combinations, no luck
it is a 64bit version, i also tried a reinstall on a fresh HDD with a OEM DVD (not the preloaded image from the original HDD), no luck

if you need any more info, feel free to ask, me personally i'm out of idea's

thx in advance
a b } Memory
a c 571 D Laptop
December 13, 2010 11:12:00 AM

The screenshot I'd like to see if the from the Resource Monitor Memory Tab.
Start ->All Programs -> Accessories ->System Tools - > Resource Monitor

December 13, 2010 12:06:44 PM




a b } Memory
a c 571 D Laptop
December 13, 2010 12:56:59 PM

Have you updated your BIOS any time recently?
I saw a BIOS version 1.41 dated 12Nov on the Lenovo website.

Are you running any Virtual XP mode sessions under Win7?
December 13, 2010 1:37:58 PM

WR2 said:
Have you updated your BIOS any time recently?
I saw a BIOS version 1.41 dated 12Nov on the Lenovo website.

Are you running any Virtual XP mode sessions under Win7?


Bios update did the trick !

the Lenovo Thinkvantage software said everything was up to date
but after looking into it there was a BIOS update availeble, everything reads normal now:



Thank you very much, if you are ever near Brussels (belgium) i'll buy you a drink :sol: 
July 9, 2011 3:36:37 AM

Hi
I got the same problem, I updated the BIOS to 1.38 but it is still showing the 2.99 usable ram out of 8 Gb

February 7, 2013 6:52:34 PM

Maybe the answer is late, but It's for the people who have the same problem and will search on google.

The problem came from windows 32Bits, It support only 3Gb. If you want to profit of your 8Gb (more than 3Gb) you should upgrade to Windows 64bits.

I hope it helps.
!