Sign in with
Sign up | Sign in
Your question

Laptop not recognizing eSATA ext. HD

Last response: in Laptops & Notebooks
Share
December 24, 2010 4:57:15 AM

just like the topic says, I bought an external hdd and an enclosure with esata.
I got it to work on my desktop computer by installing the jmicron driver then going into computer management and formatting it.
However, my laptop still won't recognize it at all.

I tried looking for sata drivers on ASUS website and there's nothing there, also tried installing the jmicron driver but that said "no jmicron blahblah adapter found".


Laptop is ASUS N61JQ

anyone have a similar problem or have an idea why it's not working?
a b D Laptop
December 24, 2010 5:58:13 AM

You could perhaps try re-installing the chipset, but I'm not sure if it would reset the e-sata controller or not (I usually recommend doing this for those with USB troubles, as it resets the USB controllers). Your best bet at this point would be to get in touch with Asus support to see if they have a fix for the problem or what you would need to download from their support site.
m
0
l
a b D Laptop
December 24, 2010 4:07:09 PM

Check device manager, and check to see if the hardrive is there, if it is, uninstall from device manager, then reboot your laptop, then try plugging in the HDD, also do this for the eSata port.
m
0
l
Related resources
December 25, 2010 12:45:05 AM

nothing shows up in device manager. I did send a msg to ASUS support but they havn't got back to me yet. I choose ASUS b/c of their reputation for support but so far i'm not real impressed with their website and trying to find solutions on there
m
0
l
a b D Laptop
December 25, 2010 3:14:36 AM

Due to the X-MAS holiday, they may not get back to you until Monday, but that remains to be seen. Did you give the chipset idea a go?
m
0
l
December 27, 2010 1:21:34 AM

They actually did get back to me already, which is nice, however they had me update the chipset (intel INF update driver) and the intel storage matrix driver but neither one solved the problem.

They also suggested it might be the eSATA cable but i can't see that being the problem as it works fine with my desktop
m
0
l
December 28, 2010 12:07:05 AM

My ASUS G1S has a BIOS option for AHCI/SATA, but you probably already have it set for SATA (if your BIOS even has that option, which is useful for installing WindowsXP).

If the external drive enclosure has an optional power supply then make sure it is powered up and the eSATA is plugged into the laptop before the laptop is turned on. Hotplugging is supposed to work, but try attaching it and spinning up the drive before powering on the laptop.

Have you checked if the BIOS can see the eSATA drive? Hit ESC (or whatever your BIOS uses to get the "BBS POPUP" (that is what my ASUS BIOS calls it) menu for boot device selection) and see if it lists the external drive. Mine shows "IDE:Seagate FreeAgen" as one of the choices, even though that drive is not bootable.

If you want to test the hardware, you could download a small Linux Live image and boot it from CD or USB drive. For instance, RIPLinuX works with my ASUS G1S connected with eSATA to a Seagate FreeAgent Pro external drive. The image is about 128MB for the X-Windows version. Pendrivelinux.com has an easy way to install it to a USB drive under Windows XP/Vista/7. Just replace the RIPLinuX-10.x.iso with RIPLinuX-11.3.iso (current version as I write this) in the instructions.

Install RIPLinuX to usb from windows

Or, write the RIPLinux-11.3.iso to a CD or CD/RW as an image.

Hit ESCAPE (or whatever key your BIOS uses to select the boot device) and pick the right device.

RIPLinuX 11.3 has an option on the menu "Boot Hardware Detection Tool!" which is a quick test. It showed two disks on my G1S with the FreeAgent Pro attached. My G1S has an old ICH8 and Jmicron JMB360 controllers, but the simple hardware detection tool might not be able to detect your newer controller.

The RIPLinuX 11.3 kernel is a very recent 2.6.35.6, so it would have a better chance of detecting your SATA controler. Choose the 4th RIPLinuX menu item with the "(skip keymap prompt)" to get 32-bit X with the default US language and keyboard. Right click on the desktop to get the RIPLinuX application menu. Select "Mount/Unmount" (third on the menu) and if the eSATA is working, then the eSATA drive should be on the list of mountable partitions (probably as /dev/sdb1 if it is the second hard drive). The last menu item is "Logout" with "Halt/Poweroff" as an option when you are finished.

Here is the homepage for (R)ecovery (I)s (P)ossible Linux rescue system.
m
0
l
January 29, 2011 3:10:45 PM

I found the problem.

I was reading another thread on another site from 2007 and one guy said his problem was that he wasn't able to push the cable in far enough to make a secure connection. He shaved back the plastic with a razor blade to get it in further. This worked perfectly for me as well.

all the frustration of searching forums and dealing with the ASUS website and customer service and THAT was the problem! it makes me laugh.

anyway, just glad it works.

Thanks for all the help. I never would have guessed it'd be a mechanical problem with the cable.

So anyone else having a external hard drive not being recognized ....try shaving back the plastic on your connector first!

m
0
l
February 2, 2011 12:59:29 PM

rja said:
My ASUS G1S has a BIOS option for AHCI/SATA, but you probably already have it set for SATA (if your BIOS even has that option, which is useful for installing WindowsXP).

If the external drive enclosure has an optional power supply then make sure it is powered up and the eSATA is plugged into the laptop before the laptop is turned on. Hotplugging is supposed to work, but try attaching it and spinning up the drive before powering on the laptop.

Have you checked if the BIOS can see the eSATA drive? Hit ESC (or whatever your BIOS uses to get the "BBS POPUP" (that is what my ASUS BIOS calls it) menu for boot device selection) and see if it lists the external drive. Mine shows "IDE:Seagate FreeAgen" as one of the choices, even though that drive is not bootable.

If you want to test the hardware, you could download a small Linux Live image and boot it from CD or USB drive. For instance, RIPLinuX works with my ASUS G1S connected with eSATA to a Seagate FreeAgent Pro external drive. The image is about 128MB for the X-Windows version. Pendrivelinux.com has an easy way to install it to a USB drive under Windows XP/Vista/7. Just replace the RIPLinuX-10.x.iso with RIPLinuX-11.3.iso (current version as I write this) in the instructions.

Install RIPLinuX to usb from windows

Or, write the RIPLinux-11.3.iso to a CD or CD/RW as an image.

Hit ESCAPE (or whatever key your BIOS uses to select the boot device) and pick the right device.

RIPLinuX 11.3 has an option on the menu "Boot Hardware Detection Tool!" which is a quick test. It showed two disks on my G1S with the FreeAgent Pro attached. My G1S has an old ICH8 and Jmicron JMB360 controllers, but the simple hardware detection tool might not be able to detect your newer controller.

The RIPLinuX 11.3 kernel is a very recent 2.6.35.6, so it would have a better chance of detecting your SATA controler. Choose the 4th RIPLinuX menu item with the "(skip keymap prompt)" to get 32-bit X with the default US language and keyboard. Right click on the desktop to get the RIPLinuX application menu. Select "Mount/Unmount" (third on the menu) and if the eSATA is working, then the eSATA drive should be on the list of mountable partitions (probably as /dev/sdb1 if it is the second hard drive). The last menu item is "Logout" with "Halt/Poweroff" as an option when you are finished.

Here is the homepage for (R)ecovery (I)s (P)ossible Linux rescue system.


I tried your method and my disk doesn't show up in the "Boot Hardware Detection Tool" but it does show up under the "Mount/Unmount" option within Linux.

My question is what next?.. I click to mount that drive then booted back into windows but the external HDD still doesn't show up..
m
0
l
!