Windows Doesn't Show My Microphone

It's pretty much what the title says.

I bought these new headphones Ozone Attack, and the sound works great on them, but the microphone doesn't work in any program. Doesn't work in Skype, TS3, and it doesn't even pick it up in Recording Devices. It's the kind of headset where it's not a USB; it's got a plug for the mic and another for the headphones. They're both plugged in firmly, and I've updated my audio thing which is IDT High Definition Audio CODEC. My laptop is a HP Pavilion g6-1241sa Notebook PC. I've also gone into Recording Devices and checked for any disabled mics, but the one in my headset isn't there. And even though my headset is set as the Default Communication Device, the mic doesn't get picked up under Recording Devices. Push to Talk is also not on. The headset is also shown only under Playback Devices.

So what do I do? I've tried everything I can think of.
10 answers Last reply
More about windows doesn show microphone
  1. Because you have to click right click on the speaker icon next to the time on the start bar.

    Then left click in the menu, recording devices.

    The mic should show up in there of the headset.
    You then right click on it and select one or two of the options.Enable.
    Next go to the playback menu, You should see your headset listed there, right click on it and in the menu select it as default communications device.
  2. weaselman said:
    Because you have to click right click on the speaker icon net to the time on the start bar.Then click in the menu, recording devices. The mic should show up in there of the headset.
    You then right click on it and select one or two of the options.Enable, or select as default device.

    ...That made no sense to me whatsoever. It's not under the headset, and the headset is in Playback Devices only.
  3. Ok so set it as default communication device. And in recording make sure the mic is enabled. how simple do want me to make it.
  4. weaselman said:
    Ok so set it as default communication device.

    It is set as default communication device, but it still doesn't work on Skype or TS3.
    On Skype it's picked it up, but won't let me choose the mic. On TS3 it doesn't pick it up at all.
  5. Go into play back the headset should be in the list, right click on it and set it to default communication device, next go to recording and make sure the mic is enabled in that section.
  6. Have you checked you do not have the push to talk key enabled in the programs.
  7. weaselman said:
    Go into play back the headset should be in the list, right click on it and set it to default communication device, next go to recording and make sure the mic is enabled in that section.

    *Sigh* It's set as the default communication device, but the mic still hasn't been picked up. That's the problem.
  8. weaselman said:
    Have you checked you do not have the push to talk key enabled in the programs.

    Yes.
  9. im having the same problem as u atm... did u find a fix
  10. Did you try downloading drivers?
Ask a new question

Read More

Microphone Devices Windows 7