Sign in with
Sign up | Sign in
Your question
Closed

Annoying beep when unplugging AC Power

Last response: in Laptops & Notebooks
Share
January 13, 2011 10:37:06 PM

Hi all,

Acer 7740g, Windows 7 HE.
I have this annoying problem that when my AC power is plugged or unplugged it makes a beep.
Muting the sound completely helps, but that's sometimes not an option.

I tried the following and no luck:

Editing a registry entry HKEY_CURRENT_USER\Control Panel\Sound\Beep and changed it to "No".
Uninstalling the Beep device from my device manager.
Turning off my pc speaker, unfortunately, I didn't find where I can disable it. :non: 

My sound card drivers are: Realtek 6.0.1.5969

Anyone has another idea?

Thanks.
a b D Laptop
January 16, 2011 7:03:05 PM

Maybe it is a feature letting user know when ac adapter is not powering laptop. Call Acer support and aske them.
January 17, 2011 10:20:13 PM

Thank you, Captain Obvious.
Related resources
January 19, 2011 2:53:21 PM

Any other ideas?
January 19, 2011 7:01:55 PM

Try checking your power settings ... this sounds like a function of the charger being connected, disconnected as was suggested, but their might be a setting in power management that will fix this so you don't hear the beep. Short of that I would have to suggest ear plugs I guess, because I am not sure that their will be much else you can do if there isn't a bios setting for it. (usually you can access the power settings if you right click on the battery icon when it appears, otherwise right click on the desk top).
January 19, 2011 7:18:23 PM

Checked the power management settings, there's nothing there.

I'm sure there's something I can do, since it started after I reinstalled the windows, so it's something in the settings of the Windows.
September 26, 2011 8:51:59 PM

whatever61 said:
Hi all,

Acer 7740g, Windows 7 HE.
I have this annoying problem that when my AC power is plugged or unplugged it makes a beep.
Muting the sound completely helps, but that's sometimes not an option.

I tried the following and no luck:

Editing a registry entry HKEY_CURRENT_USER\Control Panel\Sound\Beep and changed it to "No".
Uninstalling the Beep device from my device manager.
Turning off my pc speaker, unfortunately, I didn't find where I can disable it. :non: 

My sound card drivers are: Realtek 6.0.1.5969

Anyone has another idea?

Thanks.


if you right click the volume icon down in the task menu > then hit playback devices > then right click speakers (realtek high definition audio) > hit properties > hit the tab "levels" > there you should see a slider named " Pc Beeps" turn that down/mute

and you should be rid of the annoying beep sound :) 
November 23, 2011 8:24:45 PM

I am having similar issues with an acer laptop. It will start beeping when my batter hits a certain level of charge. At first it was 95-96% then I let it fully charge one night and it started doing it between 86-88%. If I suffer through constant beeping and screen flashing I can get past this range and the issue goes away. It is extremely annoying and all the Acer support people have told me is to send it to them. However, I use this laptop every day for work and cannot go 2 weeks without it (not to mention that I will have to pay for shipping even though it is under warrante). I can ditch the noise by muting my laptop but the screen still flashes (AC to battery mode and back). This is really annoying.
February 13, 2013 12:51:15 PM

The problem is the Realtek Audio Drivers. Windows doesn't have a sound for the event so it supplies the old-school default beep. Truly annoying.

Go to Device Manager>Sound, Video & Game Controllers> and uninstall the Realtek device (choose to delete the drivers as well). Then click "Scan for HW changes" and let the Windows default driver install.

Problem solved.
a c 248 D Laptop
February 13, 2013 8:55:13 PM

whatever61 said:
Thank you, Captain Obvious.



Hi :) 

LOSE the sarcasm please....

All the best Brett :) 
April 20, 2013 10:40:25 PM



[/quotemsg]

if you right click the volume icon down in the task menu > then hit playback devices > then right click speakers (realtek high definition audio) > hit properties > hit the tab "levels" > there you should see a slider named " Pc Beeps" turn that down/mute

and you should be rid of the annoying beep sound :) [/quotemsg]

You are my hero! I got a new ac adapter because my old one died. The new one constantly disconnects and reconnects to the computer, making the beeping incessant. This worked and I can now watch movies on my computer again :-)
April 21, 2013 4:38:06 AM

[/quotemsg]
You are my hero! I got a new ac adapter because my old one died. The new one constantly disconnects and reconnects to the computer, making the beeping incessant. This worked and I can now watch movies on my computer again :-)
[/quotemsg]

Nice to hear that it helped someone!:)  but since it constantly disconnects and reconnects your adapter must be defect. I had the same problem with my computer but the beeping got more and more frequently so I had to try to buy a new adapter. And now the problem is completely gone!

So I would recommend buying a new one or send the one you got now in to repair.
eBay has really cheap adapters for laptops, so I recommend getting it from eBay if you need a new one :) 
June 2, 2013 10:12:29 AM

Thank you, thank you! I've had my laptop for over a year and that beep was driving me nuts! I couldn't for the life of me figure out how to turn it off. :) 






thunstop said:
[quotemsg


=7751358,1,395828]Hi all,

Acer 7740g, Windows 7 HE.
I have this annoying problem that when my AC power is plugged or unplugged it makes a beep.
Muting the sound completely helps, but that's sometimes not an option.

I tried the following and no luck:

Editing a registry entry HKEY_CURRENT_USER\Control Panel\Sound\Beep and changed it to "No".
Uninstalling the Beep device from my device manager.
Turning off my pc speaker, unfortunately, I didn't find where I can disable it. :non: 

My sound card drivers are: Realtek 6.0.1.5969

Anyone has another idea?

Thanks.


if you right click the volume icon down in the task menu > then hit playback devices > then right click speakers (realtek high definition audio) > hit properties > hit the tab "levels" > there you should see a slider named " Pc Beeps" turn that down/mute

and you should be rid of the annoying beep sound :) [/quotemsg]

!