Not allowing deletion

so i reinstall my os and backed up all of my c drive and an additional hdd when i restored them on the new hdd i try to delete the old c folder and it says i dont have permission but im the only user on this computer and it will not allow me to delete this folder at all i tried to go in and allow myself full access but yet can not delete this folder can anyone give me some insight on this and a way to get rid of this restored c folder thank you in advance
17 answers Last reply
More about allowing deletion
  1. Did you format the drive before you did this re-install?

    I think this could be your problem. You see the old C: drive is in a way registered to your old OS install, and will not allow itself to be deleted by an unknown (the new C:) user.

    If it's not too late, and you still have the important data backed up, try doing a quick format of the drive and re-install windows on it, this way the drive will be completely empty for your install.
  2. i formatted both drives prior to installing my os on it and i had some movies and games that i backed up only difference is i restored into my s drive
  3. and i used same admin name for the installation
  4. Run command prompt as administator, (assuming that your drive with backed up files is D:\) type the following:
    Quote:
    icacls D:\* /reset /t /c /l

    This will reset the ownership/permissions on all the files on D:\ drive. You'll have to wait some time, depending on your HDD speed/amount of files after which you'll get a message informing you on how many files have been successfully updated.
  5. ok so the file are on my s drive now labeled in folder c so when i go to it it looks like this s/c so u want me to put icacls s:\* /t/c/l in the command prompt and that will allow me to deleete that c folder correct
  6. Correct.

    Edit: icacls s:\* /reset /t /c /l

    Reset flag is the most important one.
  7. sorry but how do i get to the command prompt
  8. Press start menu, type in CMD in search, right click cmd.exe and click run as administrator.
  9. says the file name, directory name or volume label syntaxs is incorrect
  10. Try
    Quote:
    S:
    icacls * /reset /t /c /l


    (don't forget spaces)
  11. man i cant get this *** to work im inputting s:\ icacls * /reset/t/c/l and says not recognized as internal or external command
  12. c:\ windows\system32> s:\ icacls * /reset/t/c/l and i keep getting the internal external issue
  13. Have you run command prompt as administrator and did you put spaces between /reset /t /c /l

    Window title should be 'Administrator: C:\Windows\system32\cmd.exe' when you open it, then as previously stated, type S: press enter and then type icacls * /reset /t /c /l
  14. yes window title is labeled as that but only get the c:\windows\system32 where im allowed to write prompts in
  15. damn took me a lil while but thank for that i got it working right now hopefully this works thats the type of *** i need to learn how to do mess wit command prompt when it comes to putting a comp together no prob when it comes to software forget about it
  16. still not allowing me to delete and it was tellin me my recycling bin was corrupted
  17. To fix corrupted recycling bin, go to Control Panel>Folder Options>View then select Show hidden files, folders and drives and untick following 3 options that start with Hide right below. After that, open S:\ and delete $Recycle.Bin folder (shift + delete) and reboot PC.
Ask a new question

Read More

Security Hard Drives Windows 7