Sign in with
Sign up | Sign in
Your question

Flash Drive No Longer Recognized

Last response: in Windows 7
Share
January 12, 2013 1:07:52 AM

I'm running WIN 7 on my home pc and transferred some files via a Flash Drive to a laptop running XP Pro to go on a trip. Upon my return I update my home pc with the data from laptop/FD; I've done this with no problem many times. Upon my return this time my home pc will not recognize the FD. I've updated the driver, checked Disk Management, etc all to no avail. The FD isn't recognized and neither is a second FD I tried. They both work on the laptop. HELP...and thanks.
a b $ Windows 7
January 12, 2013 3:04:49 AM

Do the following:
1. Go into Device Manager (however it is you get there)
2. Expand Universal Serial Bus Adapters category
3. Right click each of the USB Root Hubs (one at a time mind you)
4. After right clicking, choose uninstall. The computer will think for a minute and it may prompt you to reboot. DO NOT reboot until you've removed all of them.
5. Once you have all of them removed, reboot the computer.
6. After the reboot, Windows should rebuild all the USB Root Hub drivers so it may take a minute. It is also best that nothing is plugged into those ports for the time being.

Once the process is finished, go ahead and try your device again.
m
0
l
January 12, 2013 9:50:07 AM

More information. I tried 3 different flash drives and an iPhone. Nothing was recognized.
After installing several Microsoft and McAfee updates and about 3 reboots, I finally threw in the towel and went to bed, but first, "Let's do one more reboot." And then, Ta Da! the flash drives were recognized!
Sounds like an intermittent, perhaps? Curiously, the home pc was shut off for 3 weeks while I was away. It worked fine before I left, and upon my return the adventure started. Any thoughts on the cause?
Thanks for looking.
m
0
l
a b $ Windows 7
January 12, 2013 11:50:35 AM

It could potentially be the computer turning off the ports to conserve power being used.

Not sure if you know how to check each of the USB Root Hubs to see if that is the case. Its real simple to do:
1. Go back to where you can see all the USB Root Hubs in Device Manager
2. Right click each one separately, choose Properties.
3. When window loads, click on Power Management tab.
4. Make sure that check box labeled "Allow the computer to turn off this device to save power" is unchecked.

See if that helps.
m
0
l
!