Sign in with
Sign up | Sign in
Your question
Solved

Setting up headphones and speakers as different audio devices

Last response: in Computer Peripherals
Share
November 2, 2012 8:23:41 PM

I am trying to set up my audio so that when I use Windows casually I can disable my headphones and use my speakers and vice versa when gaming. However my headphones and speakers show up as one device labeled "Speakers" in the Windows "Playback Devices" window. Is there any way to set them up to show up separately under Windows? I am running Windows 7 and using the built-in sound card in a Gigabyte Z77X-UD5H mobo. Thanks in advance.

Best solution

November 3, 2012 4:58:47 AM

Yes, just open up "Manage Audio Devices" (or right click the sound icon in the taskbar tray and select "Playback devices"), then right click the device you want to rename and click properties. At the top the tab, you can rename it.

After you rename it, you can make switching devices rather easy with a script and a program. Look for the latest nircmd.exe download, and install it. then use this batch file script:

@echo off
C:\Windows\nircmd.exe setdefaultsounddevice "Speakers"
exit

Make one for each device.
Share
November 3, 2012 3:01:33 PM

bystander said:
Yes, just open up "Manage Audio Devices" (or right click the sound icon in the taskbar tray and select "Playback devices"), then right click the device you want to rename and click properties. At the top the tab, you can rename it.

After you rename it, you can make switching devices rather easy with a script and a program. Look for the latest nircmd.exe download, and install it. then use this batch file script:

@echo off
C:\Windows\nircmd.exe setdefaultsounddevice "Speakers"
exit

Make one for each device.



Thanks, but I think you misunderstood. I don't have two devices labeled "Speakers", I only have one. Below is a link to a screenshot of what I see. That once "Speakers" device accounts for both my headphones AND speakers.

http://imgur.com/JY7xy
m
0
l
Related resources
November 3, 2012 3:07:51 PM

Well, that means you only have 1 device installed. When you plug headphones into the computer, there should be another device there. Otherwise you may need to find the software for it.
m
0
l
November 3, 2012 4:01:31 PM

bystander said:
Well, that means you only have 1 device installed. When you plug headphones into the computer, there should be another device there. Otherwise you may need to find the software for it.



Got it to work. Thanks for the batch script
m
0
l
November 3, 2012 4:01:43 PM

Best answer selected by dragonborn1337.
m
0
l
November 18, 2012 7:19:53 AM

dragonborn1337 said:
Got it to work. Thanks for the batch script


I've been searching everywhere for a fix to this problem, can you detail exactly how you fixed it please?

My headset and speakers are showing up as the same thing as well
m
0
l
April 6, 2013 8:22:58 PM

hi can u help me out with the speaker and headphone problem even i have the same issue i have an asus rog crosshair formula v z
m
0
l
September 5, 2013 9:30:24 AM

I'm also having the speakers and headphone problem, can someone help me? Aarcaane did you get an answer? dragonborn1337 how did you get it to work?

m
0
l
September 24, 2013 7:00:08 AM

dragonborn1337 said:
bystander said:
Well, that means you only have 1 device installed. When you plug headphones into the computer, there should be another device there. Otherwise you may need to find the software for it.



Got it to work. Thanks for the batch script


can I ask if you had only one device (like me) and if so if yo had to setup a virtual device to use this script?

I have HDMI, presumably for if I ever have a HDMI device... I have two headphone jacks and amazing speakers, but would like to use headphones for video on chrome/vlc while playing mediamonkey through built-in, or even stereo connnected through other jack...

I'm sure this is the way to go, but think I only have one "device" (soundcard?)

any tips?

Many thanks
m
0
l
December 15, 2013 8:36:16 AM

dragonborn1337 said:
bystander said:
Well, that means you only have 1 device installed. When you plug headphones into the computer, there should be another device there. Otherwise you may need to find the software for it.



Got it to work. Thanks for the batch script


Yes please I am having the same problem. What did you do to fix it? I have been messing around for hours and would greatly appreciate some advice.
m
0
l
January 4, 2014 4:13:02 AM

Ariectus said:
dragonborn1337 said:
Got it to work. Thanks for the batch script


I've been searching everywhere for a fix to this problem, can you detail exactly how you fixed it please?

My headset and speakers are showing up as the same thing as well


what i did to fix mine was plug in my speakers so the realtek hd audio manager thing came up then i went into device advanced settings and u have two options one is to mute speakers when headphones are on and the other is to play sound through both devices simultaneously and it creats a 2nd icon 4 headphones in the playback devices tray hope it works for u guys
m
0
l
January 4, 2014 4:14:00 AM

reptilicus said:
dragonborn1337 said:
bystander said:
Well, that means you only have 1 device installed. When you plug headphones into the computer, there should be another device there. Otherwise you may need to find the software for it.



Got it to work. Thanks for the batch script


Yes please I am having the same problem. What did you do to fix it? I have been messing around for hours and would greatly appreciate some advice.


dont do what i did earlier i may have two diff outputs now but neither of them work do not attemp what i did!!!!!
m
0
l
March 14, 2014 11:58:31 AM

My system is using the Realtek High Definition Audio driver (discovered by: right-click on volume icon, select Playback Devices, read grey text under "Speaker"). After a lot of digging around, this solved my issue:

  1. Open "Realtek HD Audio Manager" (to find this quickly, open the Start menu and type "Realtek" in the search field).
  2. Click "Device advanced settings" in the upper right corner of Realtek HD Audio Manager.
  3. Select "Multi-stream mode".
  4. Click "OK".

  • Internal speakers and microphone now have separate audio controls.
    m
    1
    l
    June 22, 2014 6:56:23 AM

    I prefer nomadbydesign's solution because it doesn't involve any scripting. Thanks! nomadbydesign
    However in my Realtek HD Audio Manager, I need to select Options from upper right corner, under Playback Device, tick the checkbox "Make front and rear output devices playback two different audio streams simultaneously."
    m
    0
    l
    !