Sign in with
Sign up | Sign in
Your question

Help! CD-ROM not being recognized.

Last response: in CPUs
Share
Anonymous
a b à CPUs
May 2, 2001 2:29:16 AM

First let my system be known:
AMD duron 800Mhz @ 800Mhz.
Abit KT7a RAID.
Wesern Digital 20GB HDD
Quantum Fireball 3.0GB HDD
30 something x CDROM.
Windows98 se

The 2 HDDs are hooked up to the primary IDE mobo slot
and the CDROM is hooked up to the Secondary IDE slot.

I"m not totally sure whether this is the cause or not, but it seems highly probable. I believe that the Hard Drive IDE cable was partially removed during windows operation. This was folowed by blue screens, saying something about windows 32 bit drivers not worked, and being replaced. It also had the word "child" in there I think.

Anyway, It said I must restart my computer, and when I did, It paused in POST. I turned it off and I checked all connections to find that my primary HDD (Western Digital 20GB) Was loose, and fastened it back in as well as removing the Quantum Fireball.

Well, All seemed well at frist, my computer booted up normally and It seemed All good, until I tried to play And Audio CD, when I was Greeted to the message "No CDROM detected, CD player cannot continue operation and will close now" or something simalar. So I open up 'My computer' To find only my floppy and HDD listed.

I shut down my computer and Go into BIOS, to see both the CDROM and HDD listed properly, HDD as primary master, and CDROM on secondary master. So I exit BIOS saving changes (there were non but I saved anyway) and In POST My CDROM and HDD was still being recognised properly, but when I got to windows, it was another story.

Under 'Control panel,' 'System,' 'Device Manager' I found two lovely little yellow Exclaimation marks next to Primary IDE controler (dual fifo) and also one on Secondary IDE controler (dual fifo). I tried to remove them in an attempt to have windows re-detect and re-install everything. But It said I had to remove the master controller first. (which was something like 'VIA master controler something or other' which was under the hard disk controllers tab) So I remove it and it takes the other two IDE controllers with it. It then says I need to restart my computer, so I do.

Once I get back into windows It says: "building driver database" and then detects the two IDE controlers as well as the Master controler, and asks to restart again. So I do, and after the restart I get back into control panel, system, device manager, only to find the damn exclaimation marks still there as well as my CDROM not being recognized!
Arghhhhhh!!!

Please help, I've done Everything I know to do And I'm fixing to reformat and start from scratch. Any little peice of advice might help. please don't hesitate to post. Thanx.

More about : rom recognized

May 2, 2001 2:57:29 AM

Is your CDROM drive set to master or slave (or cable select?) on the 2nd IDE controller? If it's alone on the controller, set it to master.

-Raystonn

= The views stated herein are my personal views, and not necessarily the views of my employer. =
Anonymous
a b à CPUs
May 2, 2001 3:16:50 AM

My CDROM is set to master, and it is the only device on my secondary IDE channel. My HDD is also set to master, and it, also, is the only device on the Primary IDE channel.

POST see's all of this correctly, but with windows, the story's different.
Related resources
May 2, 2001 3:19:56 AM

Have you tried installing DOS drivers for it to see if it works properly in DOS. First you install the proper DOS driver in the config.sys, then you add the mscdex (I believe) line. You should then be able to access it from DOS and see if it's functioning properly. This by the way will also get it to work in win98, but it will be using the 16bit drivers instead of the 32bit.

-Raystonn

= The views stated herein are my personal views, and not necessarily the views of my employer. =
Anonymous
a b à CPUs
May 2, 2001 9:40:29 AM

it may sound like crap, but, everytime i screw something up, the only way i find satisfaction is to buy something new.
but really, you probably need to reinstall via4in1 drivers (v4.29 works nicely on my kt7a).
hope this helps!
May 2, 2001 10:43:06 AM

try putting the cdrom as a slave to your boot harddisk both on the primary ide. this will let you know if you have a dead cdrom or a dead secondary channel or just a dodgy cable on the secondary channel. you could also try putting the second harddisk in the place of the cdrom to see if you get simalar results.

there are only two types of class. first and none
!