Windows 7 fresh install doesn't detect new ssd on hp

I'm really stuck. When I go to install windows 7 the install gets to install now and when I click it the next screen shows no hard drive,

Hp pavilion elite m9652uk
8 answers Last reply
More about windows fresh install doesn detect
  1. Does it show up in the BIOS?

    Does it list it in IDE mode or AHCI mode?

    You might need to download drivers specific to that model and make a Windows Installation Driver disk, used to be F6 when the WinXP installer was loaded.

    Process has changed since I had to do it last.
  2. It shows up in bios. I believe it's achi. I put some driver on the install USB but after I install them refresh but doesn't show up
  3. Scott_D_Bowen said:
    Does it show up in the BIOS?

    Does it list it in IDE mode or AHCI mode?

    You might need to download drivers specific to that model and make a Windows Installation Driver disk, used to be F6 when the WinXP installer was loaded.

    Process has changed since I had to do it last.


    It shows up in bios. I believe it's achi. I put some driver on the install USB but after I install them refresh but doesn't show up
  4. Its time to check what type of Sata ports are on the board, I presume it at least has 2.0 ports.
    Then you need to check what the standard of the SSD drive is for example 3.0 sata transfer speed and a 2.0 tranfer speed mode.
    You may be required to install the sata driver before you get to the point of installing windows os so it can see and use the Sata controller. more than likely the cause, so have a look for a driver to do with the sata on HP`s website.

    http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=3929294&prodTypeId=12454&prodSeriesId=3880335&swLang=8&taskId=135&swEnvOID=4063
  5. I don't think the Pegatron M2N78-LA mobo has a 3rd party SATA chip-set in addition to the one paired with the NVIDIA GeForce 9100.
  6. weaselman said:
    Its time to check what type of Sata ports are on the board, I presume it at least has 2.0 ports.
    Then you need to check what the standard of the SSD drive is for example 3.0 sata transfer speed and a 2.0 tranfer speed mode.
    You may be required to install the sata driver before you get to the point of installing windows os so it can see and use the Sata controller. more than likely the cause, so have a look for a driver to do with the sata on HP`s website.

    http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=3929294&prodTypeId=12454&prodSeriesId=3880335&swLang=8&taskId=135&swEnvOID=4063


    The ssd is 3.0 Sata I believe.
  7. Scott_D_Bowen said:
    I don't think the Pegatron M2N78-LA mobo has a 3rd party SATA chip-set in addition to the one paired with the NVIDIA GeForce 9100.

    I don't really understand what's this means tbh
  8. It means it should be working.... and yet it's not.
Ask a new question

Read More

Windows 7 Hewlett Packard SSD