Sign-in / Sign-up
Your question

vga graphics in kubuntu

Tags:
  • Games
  • VGA
  • Graphics
  • Video Games
Last response: in PC Gaming
Anonymous
April 9, 2005 2:44:50 PM

Archived from groups: rec.games.roguelike.nethack (More info?)

Hi,

I just installed kubuntu (ubuntu /w KDE), and I must say I am very
impressed with the distro. The only serious problem is with nethack's
vga text grahpics. In the xterm, I can get DECgraphics to work, which
is okay, but I prefer IBM graphics. The IBM graphics, however, are
seriously screwed up. I only see the @, the < and my pet, and the rest
ofthe dungeon is blank. When I move, the old @ symbols are still
there, so I get something that looks like this:

@ <
@ uu
@ u

In the tty console, the DECgraphics use incorrect characters, and the
IBMgrahpics are the same as in the xterm. The same problem has
occurred both with the apt-get packages and with the tarball from the
site. I tried a few different fonts (including the ones in the
tarball) in the xterm, but with the same result. Any help would be
appreciated, since nethack is the best game ever and I love it.

--C

More about : vga graphics kubuntu

Anonymous
April 9, 2005 8:24:49 PM

Archived from groups: rec.games.roguelike.nethack (More info?)

coldsalmon wrote:

> In the tty console, the DECgraphics use incorrect characters, and the
> IBMgrahpics are the same as in the xterm. The same problem has
> occurred both with the apt-get packages and with the tarball from the
> site. I tried a few different fonts (including the ones in the
> tarball) in the xterm, but with the same result. Any help would be
> appreciated, since nethack is the best game ever and I love it.

You need a font that has the IBM cp437 characters. Try looking for one
with "vga" in the name -- I use one called "vga11x19", which in debian is
included in the package xfonts-dosemu.deb

On the console, in debian linux, the font called default8x16 works for me.

--
Benjamin Lewis

Evelyn the dog, having undergone further modification, pondered the
significance of short-person behavior in pedal-depressed panchromatic
resonance and other highly ambient domains... "Arf", she said.
Anonymous
April 10, 2005 9:07:57 PM

Archived from groups: rec.games.roguelike.nethack (More info?)

Thanks, but how do I control which fonts my console uses? I can choose
from about 6 fonts in the xterm, but when I install new fonts they
don't show up on the menu. I also have no idea how to change the font
that is used for tty consoles.

Thanks again,

--C
Benjamin Lewis wrote:
> coldsalmon wrote:
>
> > In the tty console, the DECgraphics use incorrect characters, and
the
> > IBMgrahpics are the same as in the xterm. The same problem has
> > occurred both with the apt-get packages and with the tarball from
the
> > site. I tried a few different fonts (including the ones in the
> > tarball) in the xterm, but with the same result. Any help would be
> > appreciated, since nethack is the best game ever and I love it.
>
> You need a font that has the IBM cp437 characters. Try looking for
one
> with "vga" in the name -- I use one called "vga11x19", which in
debian is
> included in the package xfonts-dosemu.deb
>
> On the console, in debian linux, the font called default8x16 works
for me.
>
> --
> Benjamin Lewis
>
> Evelyn the dog, having undergone further modification, pondered the
> significance of short-person behavior in pedal-depressed panchromatic
> resonance and other highly ambient domains... "Arf", she said.
Related resources
Anonymous
April 10, 2005 9:56:41 PM

Archived from groups: rec.games.roguelike.nethack (More info?)

coldsalmon wrote:

> Thanks, but how do I control which fonts my console uses? I can choose
> from about 6 fonts in the xterm, but when I install new fonts they
> don't show up on the menu. I also have no idea how to change the font
> that is used for tty consoles.

From the console, it may just be a question of selecting the proper
charset. If your distribution uses a recent version of console-tools, try
doing

charset G0 cp437

On older or other distributions you may have to use "setfont" instead; I
don't remember what the syntax would be offhand. setfont has now been
renamed "consolechars", and you can use this to change the font if toggling
the charset doesn't work.

If you want to run an xterm with a font that is not on the menu, you can
start it with something like

xterm -fn vga11x19

from the command line (assuming you have this font). You could also change
xterm's font menu by fiddling with XResources settings, but this is more
complicated to explain.

--
Benjamin Lewis

Evelyn the dog, having undergone further modification, pondered the
significance of short-person behavior in pedal-depressed panchromatic
resonance and other highly ambient domains... "Arf", she said.
April 12, 2005 6:09:49 AM

Archived from groups: rec.games.roguelike.nethack (More info?)

"coldsalmon" <dudefaceguy@hotmail.com> wrote in
news:1113068690.721244.296530@z14g2000cwz.googlegroups.com:

> In the tty console, the DECgraphics use incorrect characters, and the
> IBMgrahpics are the same as in the xterm. The same problem has
> occurred both with the apt-get packages and with the tarball from the
> site. I tried a few different fonts (including the ones in the
> tarball) in the xterm, but with the same result. Any help would be
> appreciated, since nethack is the best game ever and I love it.

Do you have a line saying:
export TERM=ansi
in your /etc/profile? (BTW I'm not sure if ansi should be capitalized or not
and it DOES matter). Try adding one if you don't. You will have to restart
linux afterwards before it has an effect. Alternatively you could add the
same line to <home>/.bashrc if you use bash as the shell.
Anonymous
April 12, 2005 5:07:27 PM

Archived from groups: rec.games.roguelike.nethack (More info?)

chuck wrote:

> "coldsalmon" <dudefaceguy@hotmail.com> wrote:
>
>> In the tty console, the DECgraphics use incorrect characters, and the
>> IBMgrahpics are the same as in the xterm. The same problem has
>> occurred both with the apt-get packages and with the tarball from the
>> site. I tried a few different fonts (including the ones in the
>> tarball) in the xterm, but with the same result. Any help would be
>> appreciated, since nethack is the best game ever and I love it.
>
> Do you have a line saying: export TERM=ansi in your /etc/profile? (BTW
> I'm not sure if ansi should be capitalized or not and it DOES
> matter). Try adding one if you don't. You will have to restart linux
> afterwards before it has an effect. Alternatively you could add the same
> line to <home>/.bashrc if you use bash as the shell.

One wonders if chuck ever follows his own advice, or indeed, if he even
uses Linux (restart the OS after a change to /etc/profile?!)

--
Benjamin Lewis

Evelyn the dog, having undergone further modification, pondered the
significance of short-person behavior in pedal-depressed panchromatic
resonance and other highly ambient domains... "Arf", she said.
Anonymous
April 13, 2005 12:40:02 AM

Archived from groups: rec.games.roguelike.nethack (More info?)

Benjamin Lewis <bclewis@cs.sfu.ca> wrote:

> chuck wrote:
>
> > Do you have a line saying: export TERM=ansi in your /etc/profile? (BTW
> > I'm not sure if ansi should be capitalized or not and it DOES
> > matter). Try adding one if you don't. You will have to restart linux
> > afterwards before it has an effect.
>
> One wonders if chuck ever follows his own advice, or indeed, if he even
> uses Linux (restart the OS after a change to /etc/profile?!)

One thing is certain: he doesn't use an account on a multi-user system.
He'd have that kind of habit beaten out of him pretty rapidly if he did.

Richard
April 14, 2005 5:20:47 AM

Archived from groups: rec.games.roguelike.nethack (More info?)

> One thing is certain: he doesn't use an account on a multi-user system.
> He'd have that kind of habit beaten out of him pretty rapidly if he did.
>
> Richard
>
I didn't see you try to help him troll!
Anonymous
April 20, 2005 5:25:17 PM

Archived from groups: rec.games.roguelike.nethack (More info?)

Tried charset, and I didn't get any errors, but I still have the same
problems. I have tried installing a variety of fonts in the xterm, but
I still get the same problem with the IBM graphics, which I don't think
is caused by the font, because it's not just a question of incorrect
symbols. The screen is not refreshing properly or showing anything
close to what it should. Here's a screenshot:

http://www.drew-edwards.com/snapshot1.jpg

It looks similar in the console.

Thanks,

--C
Anonymous
April 20, 2005 5:38:24 PM

Archived from groups: rec.games.roguelike.nethack (More info?)

coldsalmon wrote:

> Tried charset, and I didn't get any errors, but I still have the same
> problems. I have tried installing a variety of fonts in the xterm, but
> I still get the same problem with the IBM graphics, which I don't think
> is caused by the font, because it's not just a question of incorrect
> symbols. The screen is not refreshing properly or showing anything
> close to what it should. Here's a screenshot:
>
> http://www.drew-edwards.com/snapshot1.jpg
>
> It looks similar in the console.

What font are you using? I suspect it *is* the font, which doesn't contain
the IBM extended chars (cp437). There's no reason why the other characters
would appear as incorrect symbols.

With IBMGraphics, floor squares and walls use extended chars which will be
unavailable if you're using a normal font.

Are you using a TrueType font, by the way?

--
Benjamin Lewis

Evelyn the dog, having undergone further modification, pondered the
significance of short-person behavior in pedal-depressed panchromatic
resonance and other highly ambient domains... "Arf", she said.
Anonymous
April 21, 2005 4:37:41 PM

Archived from groups: rec.games.roguelike.nethack (More info?)

I'm a noob, so I really don't know anything about fonts in Linux. I've
tried following people's directions for installing and using new fonts,
but with no success. Sometimes I get the incorrect characters to
change, but they are still incorrect. In the xterm, it looks like I am
using Courier New, which I suppose would not work, but there are only
about 8 other choices, which do not change even if I install new fonts.
Plus I have no idea how to manipulate the fonts in the console. I've
googled for info, but haven't had any luck. Does anyone know where a
useful FAQ about that is?

Thanks so much,

--C
Anonymous
April 21, 2005 4:37:48 PM

Archived from groups: rec.games.roguelike.nethack (More info?)

I'm a noob, so I really don't know anything about fonts in Linux. I've
tried following people's directions for installing and using new fonts,
but with no success. Sometimes I get the incorrect characters to
change, but they are still incorrect. In the xterm, it looks like I am
using Courier New, which I suppose would not work, but there are only
about 8 other choices, which do not change even if I install new fonts.
Plus I have no idea how to manipulate the fonts in the console. I've
googled for info, but haven't had any luck. Does anyone know where a
useful FAQ about that is?

Thanks so much,

--C
Anonymous
April 21, 2005 11:28:40 PM

Archived from groups: rec.games.roguelike.nethack (More info?)

coldsalmon wrote:

> I'm a noob, so I really don't know anything about fonts in Linux. I've
> tried following people's directions for installing and using new fonts,
> but with no success. Sometimes I get the incorrect characters to
> change, but they are still incorrect. In the xterm, it looks like I am
> using Courier New, which I suppose would not work, but there are only
> about 8 other choices, which do not change even if I install new fonts.
> Plus I have no idea how to manipulate the fonts in the console. I've
> googled for info, but haven't had any luck. Does anyone know where a
> useful FAQ about that is?

1. Get an appropriate font. Try this one:

ftp://ftp.bitchx.org/pub/BitchX/misc/tmp/vga11x19.pcf

2. As root, copy it to /usr/lib/X11/fonts/misc/
(This may differ on your system; you can run "xset q" (no quotes), and see
if this directory is listed under "Font Path" to make sure)

3. mkfontdir /usr/lib/X11/fonts/misc

4. xset fp rehash

5. Start up a new xterm with "xterm -fn vga11x19"

6. Run NetHack in this xterm!

--
Benjamin Lewis

Evelyn the dog, having undergone further modification, pondered the
significance of short-person behavior in pedal-depressed panchromatic
resonance and other highly ambient domains... "Arf", she said.
Anonymous
April 22, 2005 4:24:13 AM

Archived from groups: rec.games.roguelike.nethack (More info?)

On 04/21/05 3:37 PM, coldsalmon wrote:

> I'm a noob, so I really don't know anything about fonts in Linux.
> [...]
> Does anyone know where a useful FAQ about that is?

http://www.tldp.org/HOWTO/Bash-Prompt-HOWTO/x606.html
http://www.openbsd.org/faq/truetype.html (this is for OpenBSD, so some
files might be in slightly different locations, but everything else will
be the same)
http://www.tldp.org/HOWTO/Font-HOWTO/

Hint: xterm only displays a few hardwired default fonts, you'll have to
change the command line for xterm in your window manager / desktop
system to include "-fn vga11x19". Or add a new menu entry with

xterm -fn vga11x19 -e nethack

as the command line (which will let you use the VGA font for Nethack and
a standard font for everything else). (This can also be typed at the
prompt in your regular xterm, and it'll open Nethack in a new window
with a VGA font.)

As for the console, using consolechars should help (although the choice
of fonts is much smaller, you're usually limited to 8x{8,10,12,14,16}
bitmapped fonts). (Better do a "man consolechars" since my system is old
enough to still call this program setfont, and I use the built-in font
anyway.)

> Thanks so much,

No problem. I've been setting up anti-aliased fonts on my laptop the
last couple of days, so I may as well share what I've learned...

--
Chris "Bob" Odorjan - bobnet@canada.com
BobNET - http://www.execulink.com/~bobnet/
April 22, 2005 5:50:58 AM

Archived from groups: rec.games.roguelike.nethack (More info?)

"coldsalmon" <dudefaceguy@hotmail.com> wrote in
news:1114112261.566110.239790@f14g2000cwb.googlegroups.com:

> I'm a noob, so I really don't know anything about fonts in Linux. I've
> tried following people's directions for installing and using new fonts,
> but with no success. Sometimes I get the incorrect characters to
> change, but they are still incorrect. In the xterm, it looks like I am
> using Courier New, which I suppose would not work, but there are only
> about 8 other choices, which do not change even if I install new fonts.
> Plus I have no idea how to manipulate the fonts in the console. I've
> googled for info, but haven't had any luck. Does anyone know where a
> useful FAQ about that is?
>
> Thanks so much,
>
> --C
>
>
Try man xterm
man term