AMD Bulldozer problems with XP mode in Windows 7

Hey, all. I have not been able to install XP Mode in Windows 7...and after hours of looking, I see there's an actual issue with CPUs like mine (lucky me), AMD Bulldozer-based multi-core chips. I have an FX-4170.

There is a hotfix from Microsoft, http://support.microsoft.com/kb/2519949?wa=wsignin1.0 but even after running it "successfully," XP Mode installation bombs out at the very end of the install attempt with an error message.

Help! Are there any other fixes??

JB
8 answers Last reply
More about bulldozer problems mode windows
  1. jb922 said:
    Hey, all. I have not been able to install XP Mode in Windows 7...and after hours of looking, I see there's an actual issue with CPUs like mine (lucky me), AMD Bulldozer-based multi-core chips. I have an FX-4170.

    There is a hotfix from Microsoft, http://support.microsoft.com/kb/2519949?wa=wsignin1.0 but even after running it "successfully," XP Mode installation bombs out at the very end of the install attempt with an error message.

    Help! Are there any other fixes??

    JB


    What version of Windows 7 are you running? Professional or above?

    With you having the AMD Bulldozer I recommend following the directions you posted, or you may be able to get lucky and try the method listed HERE .
  2. XP MODE ...will NOT work with Home Premium of below..
  3. I'm using Win 7 Ultimate.
  4. BTW, I was using XP mode just fine with the same OS before I recently upgraded my CPU & motherboard.
  5. jb922 said:
    Hey, all. I have not been able to install XP Mode in Windows 7...and after hours of looking, I see there's an actual issue with CPUs like mine (lucky me), AMD Bulldozer-based multi-core chips. I have an FX-4170.

    There is a hotfix from Microsoft, http://support.microsoft.com/kb/2519949?wa=wsignin1.0 but even after running it "successfully," XP Mode installation bombs out at the very end of the install attempt with an error message.

    Help! Are there any other fixes??

    JB



    jb922, I was having the same issue. I am running Windows 7 Ultimate 64bit with an AMD A8-5600K processor (also an AMD Bulldozer processor) and was getting the error message every time I tried to install XP Mode for the first time. After reading all of the legal warnings and searching for a couple of weeks looking for the solution, I decided to try the hotfix found at: http://support.microsoft.com/kb/2519949. the update was very simple and when I tried to run Windows XP Mode, the installation worked! I just opened Windows XP Professional and loaded my antivirus program without any issues. Now I just need to start installing my old 32 bit XP programs as the real test. I am hopeful just getting this far. Note: make sure you have the latest service pack for Windows 7 SP1. Good luck with yours.
  6. I was having the same problem with my FX-4100, even after installing the hotfix I was still getting the error. The solution for me was to run the "Windows XP Mode" application as an administrator then it finally worked.
  7. Steve Cox said:
    I was having the same problem with my FX-4100, even after installing the hotfix I was still getting the error. The solution for me was to run the "Windows XP Mode" application as an administrator then it finally worked.


    How do run it as as administrator?
Ask a new question

Read More

Windows 7 Bulldozer Windows XP