Sign in with
Sign up | Sign in
Your question

USB stopped working. Windows code 43 (hardware?)

Last response: in Laptops & Notebooks
Share
March 5, 2011 11:07:49 AM

I have an Acer Aspire 5745G-6538. The computer worked fine for the first 2 months after i bought it. The USB ports were all functioning properly. Then one day I tried to plug in my thumb drive and Windows tells me that there is a Hardware problem preventing windows from letting me use my USB ports. Device Manager was displaying a warning triangle with a "!".. So I started by unloading the drivers and reinstalling them. That didnt work, so I re-installed Windows. That didn't work either. SO, I installed Linux Ubuntu... Ubuntu told me the same thing, that there was a problem with my USB hardware. So I then disassembled my laptop to look for anything out of the ordinary, i.e. burns, fried PCB ect.. NOTHING... I then reassembled the laptop, re-installed Windows 7 and they still do not work. At one point, every time I tried to shut down windows I would get a BSOD saying that my USB Device had caused a fatal error that prevented windows from shutting down.. And this happened with nothing at all in the USB ports.. I am assuming that my Chip set is bad... any comments are appreciated..

Acer Aspire 5745G-6538
Specs:
Core i7 720QM
Chip Set is: HM55
DDR3 @ 4GB

a b D Laptop
March 7, 2011 5:39:03 AM

You can try updating the chipset via Acer's support site, but if you have already, I'd say that there is a hardware issue. If the laptop is within the 1 year factory warranty, get in touch with Acer and send it in for repair.

http://www.acer.com/acer/service.do;jsessionid=22054B2529173E789903FE686CA9F646.public_a_us003?LanguageISOCtxParam=hi&ctx2.c2att1=158&CountryISOCtxParam=IN&ctx1.att21k=1&CRC=3148546756
March 14, 2011 1:50:48 PM

I have exactly the same problem. I tried everything including driver updates, re-installing drivers and finally installing a clean win7 again. and also the "unplug computer, wait for minutes and start it back" method...But nothing worked for me. Could you find a solution? I believe this is some kind of hardware problem caused by Win7 (may be related to selective USB control in power management settings?)
I would appreciate if you share your progress with me. Tx.
March 22, 2011 2:19:24 AM

Anybody have any conclusion on this problem? I have same problem with my Acer 7745G. Which so far has been an awesome machine. I use the USB to charge my android phone all the time and then one day the unknown device code 43 showed up. Now I can't seem to initialize any connections through USB. I've tried removing battery after shutdown, booting to safe mode and removing drivers for fresh install. Tried the newest driver from Acer web site. Tried to blow out ports with air. Tried prayer and holy water. Any conclusions on how to fix something like this??
Related resources
!