Sign in with
Sign up | Sign in
Your question

Networking

Last response: in Windows 7
Share
January 21, 2013 7:22:51 PM

I'm trying to get 2 Windows 7 (64) computers - a laptop and a desktop - connected specifically to share printers. It's a home network running a Linksys E2000 router and both computers are connected through wireless. Even with firewalls off I can't see either computer from the other. The desktop is running ZoneAlarm as the firewall and AVG as the antivirus; the laptop is using Windows firewall. Any ideas?

Thanks!

EDIT: Internet works fine on both.

More about : networking

a b $ Windows 7
January 21, 2013 8:15:48 PM

Do both computer use the same workgroup name? Is file and printer sharing enabled on each and they are on a Win 7 home or work network?
m
0
l
a b $ Windows 7
January 21, 2013 8:46:23 PM

Homegroups ?
m
0
l
Related resources
January 21, 2013 9:08:36 PM

Yes, same workgroup name
Yes, both have file and printer sharing enabled
Home network
Homegroups off
m
0
l
a b $ Windows 7
January 21, 2013 9:13:17 PM

osizz said:
Yes, same workgroup name
Yes, both have file and printer sharing enabled
Home network
Homegroups off



Hi :) 

Try it in Homegroups, it works remarkably well for MS software lol

All the best Brett :) 
m
0
l
January 21, 2013 11:43:36 PM

Thanks. I'd gladly do a homegroup and the laptop is set up with one but the desktop can't see it on the network. Tried it the other way as well and same result. I'm assuming it's a router thing, but even with the router firewall off it didn't see anything.
m
0
l
a b $ Windows 7
January 21, 2013 11:49:56 PM

osizz said:
Thanks. I'd gladly do a homegroup and the laptop is set up with one but the desktop can't see it on the network. Tried it the other way as well and same result. I'm assuming it's a router thing, but even with the router firewall off it didn't see anything.



Hi :) 

You have to have HOMEGROUPS on BOTH....

And a small tip from someone who has done lots of networking.....

Every alteration in any network... NEEDS A REBOOT...

All the best Brett :) 
m
0
l
January 21, 2013 11:55:14 PM

Will try reboots. And I understand that I want homegroups on both but the only option I get is to create a new homegroup; not to join an existing one and put the password in to join.
m
0
l
a b $ Windows 7
January 22, 2013 12:09:27 AM

osizz said:
Will try reboots. And I understand that I want homegroups on both but the only option I get is to create a new homegroup; not to join an existing one and put the password in to join.


Hi :) 

Just get rid of the existing Homegroup and create 2 new ones...

All the best Brett :) 
m
0
l
Anonymous
a b $ Windows 7
January 22, 2013 5:29:06 AM

Brett928S2 said:
Hi :) 

And a small tip from someone who has done lots of networking.....

Every alteration in any network... NEEDS A REBOOT...

All the best Brett :) 


Change of workgroup/domain membership yes, changes to IP configuration etc can be done without requiring reboots.

To the OP - The firewall on the Cisco/Linksys operates between the LAN and the WAN(Internet) side of the router, it shouldn't be filtering any traffic on the LAN side at all.

Are you able to verify basic connectivity between the 2 machines using ping etc? No point in setting up anything new until you can verify that.

Personally I would remove Zonealarm (unless you require the ability to reactively block at the application level) and ensure both machines have their Windows Firewalls set to the Home Zone.

Also have you disabled IPv6 on your network cards, Windows Homegroup requires IPv6 to function.

After quite a bit of searching I can't find a definitive answer as to whether your E2000 is IPv6 capable, so it could well be that causing the issue (or at least the homegroup issue).


I don't see the necessity to create a homegroup on each PC, I would create the homegroup on the Desktop, make a note of the password that is generated and then go to the homegroup settings on the laptop which should detect (assuming connectivity issues have been solved) the newly created homegroup and prompt you to join.

m
0
l
!