Sign in with
Sign up | Sign in
Your question

c++ prob with t-bird

Tags:
Last response: in CPUs
Share
June 18, 2001 8:31:31 AM

now this may or may not be cpu related but i'm thinking it is. I installed borland turbo C++ on my t-bird but it doesn't work. each time i want to run programs that i wrote (very basic college assignment) i get a general protection error. but i tried it on my pentium mmx 200 and it worked like a charm. any help would be much appreciated.

:cool: :eek:  :redface: :frown: :lol:  :mad:  :eek:  :smile: :tongue: :wink:

More about : prob bird

June 18, 2001 8:33:25 AM

Search for a patch or an update.

<font color=red>We are going to have peace even if we have to fight for it. - Eisenhower</font color=red>
Anonymous
a b à CPUs
June 18, 2001 8:55:00 AM

What operating system etc .. I installed Turbo C++ (the free edition from Borland) on a Duron 700 0c'd to 900 for my son's college projects .. It works fine but is geared to DOS or Win 3.1 not Win 95/98 or 2K.

More details & we'll try to duplicate your problem.
Related resources
June 18, 2001 9:03:33 AM

both systems runon win98
the t-bird is on an a7v bios rev 1007(not overclocked)
and thanks too


:cool: :eek:  :redface: :frown: :lol:  :mad:  :eek:  :smile: :tongue: :wink: <P ID="edit"><FONT SIZE=-1><EM>Edited by bigrat on 06/18/01 05:05 PM.</EM></FONT></P>
Anonymous
a b à CPUs
June 18, 2001 10:18:04 AM

We have 98 SE on the Duron (multi boot) so we'll try installing tonight (about 7 hours time), hope you get some additional help from others too
June 18, 2001 12:31:50 PM

Hmm.. I use Visual C++ 5.0 and 6.0 and it
works fine for me.. when you say it works
on your P200, did you recompile on the P200
or just copy the binary over?

Intel Components, AMD Components... all made in Taiwan!
Anonymous
a b à CPUs
June 18, 2001 2:35:47 PM

I use gcc(g++) under NT and 2000 and have no problems (Athlon 1200). I have tested some of my programs on
Athlon, P4, P3 and P2.

(http://www.cygwin.com/)

Best thing about gcc ----> its free :) 
so u could use it to do your assignment.

(no, i do not work for redhat) :) 
regards
Skrue

<P ID="edit"><FONT SIZE=-1><EM>Edited by SkrueMcDuck on 06/18/01 04:41 PM.</EM></FONT></P>
June 18, 2001 2:38:43 PM

i saved it on a diskette when i finished it in college. i just reopened it at home

:cool: :eek:  :redface: :frown: :lol:  :mad:  :eek:  :smile: :tongue: :wink:
Anonymous
a b à CPUs
June 18, 2001 2:41:33 PM

I don't think this is a CPU problem.
A general protection error ussually means that you tried to write to memory that your program doesn't own, like the OS, or another aplication. Like you're writing past the end of an array or something.

It could easily happen that on a different computer (ie. your P200) the memory map is different such that the memory you are trying to access is does not generate a GPF. Doesn't mean that it is right, just that the program doesn't core (yet).

Try loading some other programs on the P200. I bet, if you try hard enough, you can get it to core there also.

BTW: What operating systems are you running on the TBird & P200? Is the version of Borland the same on each?

And finally...
Have you tried stepping through it with a debugger on the TBird?

<i>Cognite Tute</i>
(Think for Yourself)<P ID="edit"><FONT SIZE=-1><EM>Edited by ergeorge on 06/18/01 10:50 AM.</EM></FONT></P>
Anonymous
a b à CPUs
June 18, 2001 2:43:52 PM

>i saved it on a diskette when i finished it in college. i
>just reopened it at home

Which computer is home? The TBird or P200?



<i>Cognite Tute</i>
(Think for Yourself)
June 18, 2001 2:59:45 PM

both pcs are at home, running the same turbo c++ 4.5 and win 98.
everytime i debug(in college and at home), there are no errors but when i execute it on the t-bird it gives me a general protection error. I can't even make a simple cout statement run.
and about getting the error in some other case, it did happen to me before when i wrote some crap[it was my first lab lesson :) ]
also thank you for trying to help.

:cool: :eek:  :redface: :frown: :lol:  :mad:  :eek:  :smile: :tongue: :wink:
Anonymous
a b à CPUs
June 18, 2001 3:58:05 PM

>both pcs are at home, running the same turbo c++ 4.5 and
>win 98.

I'm not familiar with TurboC++ anymore. Is 4.5 a current version? The binary that fails on the TBird, was it compiled on the TBird, or the P200?

>everytime i debug(in college and at home), there are no
>errors but when i execute it on the t-bird it gives me a
>general protection error.

Do you mean that when you compile the program with debugging on, it works OK on either machine? Or that it works ok when running the program under a debugger? The nasty bit about these kinds of bugs is that changing the environment that the program runs in can change the behavior of the bug :-( I've had cases where adding a cout to print some debugging information caused the bug to disapear. It was still there of course, just wasn't showing up in quite the same way.

If you were running under a unix, there are several tools I could reccomend that automatically detect this sort of stuff. But I'm not familiar with the Windows equivalents (other then Purify which is great, but very expensive).

>I can't even make a simple cout statement run.

Yikes ... are you saying that you can't even get a trivial "Hello World" program to run on the TBird? If that is so, you can ignore my previous comments. There must be something terribly wrong with your development environment!!

If the code is short & simple, you might post it.


<i>Cognite Tute</i>
(Think for Yourself)
June 18, 2001 5:30:58 PM

Borland ceased to be Borland a few years ago. My guess that the Borland C++ you are trying to use is quite old. It works on a 200mmx machine. How fast is the T-Bird?

Some old Borland compilers have a hard time running on very fast machines. The speed of todays machines weren't even dreamed of when the software was written. For example, Borlands Turbo Pascal version 5.0 does not produce workable code because various timing loops in the code are executed too quickly! Version 6.0 works properly. You have to stop using the routines that cause the error, or hope to find a patch somewhere.

I wonder if this is the same sort of problem you are having with your C++ compiler. Best you can do is search the web and see if there are any patches for the compiler.

<font color=blue>This is a Forum, not a playground. Treat it with Respect.</font color=blue>
Anonymous
a b à CPUs
June 18, 2001 6:38:34 PM

>Borland ceased to be Borland a few years ago.

Yea, they called themselves <A HREF="http://news.cnet.com/news/0-1003-200-330026.html" target="_new">Inprise</A> for a while.

But apparently, they are to become <A HREF="http://community.borland.com/article/0,1410,26287,00.ht..." target="_new">Borland</A> again.

But you're point stands! I just checked out the Borland site and found the <A HREF="http://www.borland.com/borlandcpp/cppprev/turboc45/c45_..." target="_new">Turbo C++ 4.5</A> page. This was released for Windows 3.1!! I wouldn't bother trying to debug further. Get yourself an up to date compiler. The one you have is badly out of date.






<i>Cognite Tute</i>
(Think for Yourself)
Anonymous
a b à CPUs
June 19, 2001 12:23:23 AM

i run borland c++ 4.52 on my p2 266, havent installed it on my athlon yet, but, there is an obscure setting i dont remember that allows programs to use large arrays. i would run programs at school that ran fine that had say 6 1000 item arrays but at home i would get processor faults or general protection faults. trips through the debugging code would show no out of bound array references or logic errors. i would shrink the arrays to say 500 items each and the programs would run. i was told it was a setting in the setup. also check the memory model settings in the compiler. some code only runs on medium or large memory model settings. im sure it will work on your machine, probably needs some tweaking. im curious to see how my installation works when i get around to it.

athlon1300
128megpc133sdram
radeon ve 64 ddr
sb live value
Anonymous
a b à CPUs
June 19, 2001 9:25:52 AM

OK sorry about the delay .. I have installed and run Borland Turbo C++ (the free version) on a Duron running Win 98 (not SE) and it works fine in a DOS box (double clicked tc). I ran some simple loop & print tests. I then repeated the whole process on my Athlon classic 600 (Slot A) running Win2K Professional. Still runs fine. Note my version (being free) is not the very last version produced (4.1 i think).

GP faults are nasty and can sometimes go undetected because a pointer accidentally refers to memory which you may or may not own. If you need more info on downloading the version I have put a message on the forum.
June 19, 2001 11:41:34 AM

DOS box?did you reboot into DOS or just open a DOS prompt.
It would be nice to know where i can download your version. thank you very much you've been very helpful.

:cool: :eek:  :redface: :frown: :lol:  :mad:  :eek:  :smile: :tongue: :wink:
June 19, 2001 11:48:16 AM

i think its the newest in the turbo suite but not in c++.
i thought the debugger only runs on demand(pressing f9)? i might be using the wrong terms. please forgive me, i've only been learning c++ this semester. anyway, the prog is quite long due to the calling of functions so i can't post it. but about the cout thing, i'm pretty sure about the syntax and such.

:cool: :eek:  :redface: :frown: :lol:  :mad:  :eek:  :smile: :tongue: :wink:
Anonymous
a b à CPUs
June 19, 2001 12:35:17 PM

If you run tc.exe by double clicking it in win 95/98 it will open a "dos box" for you (you can tailor it for full screen etc), you DO NOT have to reboot in dos.

I got my free version from the following .. apologies I have not learned how to embed URLs yet.

http://community.borland.com/museum/
Turbo C++ version 1.01
You have to register before you can download it.

It downloads as a zip file about 1.63 Mbyte. This unzips into 4 sub directories disk1 disk2 disk3 disk4. You are supposed to copy the contents of each directory on a seperate disk for instakkation but there is an error in the install program which I overcame by copy all the directories into a single install directory on my hard drive annd installing from there. I found this development environment effective for simple "C" and "C++" programs and a hell of a lot cheaper than Visual C++ 6 (which I also use).
Hope this helps Regards Fred
June 19, 2001 1:17:47 PM

i already downloaded the one and only patch and installed but no effect.
generally this is what i see

<font color=green>General Protection Exception</font color=green>
0x50F7:0x0B8a
NONAME00(4)Ox50F7:0x0B8A <font color=green>Processor
Fault</font color=green>

basically the green ones are always the same but the rest changes by filename, new file opened etc



:cool: :eek:  :redface: :frown: :lol:  :mad:  :eek:  :smile: :tongue: :wink:
June 19, 2001 1:20:49 PM

its supposed to be able to run on win98. the college uses win 95 for some labs and this was one of them

:cool: :eek:  :redface: :frown: :lol:  :mad:  :eek:  :smile: :tongue: :wink:
Anonymous
a b à CPUs
June 19, 2001 2:12:11 PM

>but about the cout thing, i'm pretty sure about the syntax
>and such.

Can you get even a trivial program to run on the athlon?

Try this:

#include <stdlib.h>
#include <fstream.h>

int main(void)
{
cout << "Hello World\n";
return 0;
}

If that doesn't run, then I'd really have to question your install, or the compiler version, etc.

If it does run, you're back where you started: hunting for that memory bug in your code.

And again, I'm not up to speed at all on windows compilers, but I'd have some serious reservations about using a version released for Win3.1 At the very least, it won't implement the C++ standard which was released in '99.

You might look into the Gnu compilers for Windows. They're free.

<i>Cognite Tute</i>
(Think for Yourself)
June 20, 2001 1:51:11 PM

i did this:
#include <iostream.h>
main()
{
cout<<"Hello"<<endl;
return 0;
}
which is much simpler but doesn't work. anyway, i've given up and will stick to programming in college and with the p200

:cool: :eek:  :redface: :frown: :lol:  :mad:  :eek:  :smile: :tongue: :wink:
Anonymous
a b à CPUs
June 20, 2001 3:40:53 PM

>which is much simpler but doesn't work.

Well, if that doesn't work, I don't know what to tell you other then to try an up-to-date compiler. Or at least a fresh install of what you have.

You might also try different compile options, in particular, turn off any optimizations.
Good Luck



<i>Cognite Tute</i>
(Think for Yourself)
!