Sign in with
Sign up | Sign in
Your question

Wake-On-LAN over Internet

Last response: in Windows 7
Share
January 24, 2013 1:14:44 AM

Hello,
Wake-on-lan stops working after being in sleep mode or off for an extended time (hours?). Bios is set correctly at S3, router port 9 correctly forwarded, W7 security is set correctly, and the NIC properties are set to allow magic packets to wake the machine. Everything works perfectly all the time over my LAN no matter how long the PC is off. When I send WOL remotely over the Internet it works fine in sleep mode or turned off for a while then fails. I have noticed after waking from sleep that the internet connection icon in the W7 tray indicates a loss of Internet but automatically reacquires after a few seconds. I think this is the root of mine and many other's problem. Something is shutting off the Internet connection. Because the system will wake over the LAN when this happens it proves that the bios, router, ans NIC are alive and passing the packets. My router and LAN IP addresses have not changed either. I am totally out of ideas. Would anyone have any ideas why the system would stop communication with the internet?

More about : wake lan internet

January 24, 2013 10:43:16 AM

In the future, try not to post big chunks of text that people would get bored reading.

It is normal for the computer to lose internet connection while it is asleep, and then once it wakes up it will take a few seconds before it can detect and establish a connection.

Apart from that, I don't really get what your problem is.
m
0
l
a b $ Windows 7
January 24, 2013 11:17:40 AM

Wake over Local area Network is not intended to operate over the internet. It requires ports to be open and forwarded across through all the hops in the route to your machine. You will have the ability to config routers on your own LAN segment only. Most of the internet routers will not forward these packets on to the next router in your traceroute. You will need to find a proxy program to run on your local subnet that you can send a internet signal to. The program will in turn send a wake on LAN broadcast to the machine you want to wake.

it is a pretty simple program, I would think it should be pretty easy to find one

note: you can run network monitor to watch what packets your machine network interface card actually receives. You should be able to see the packet when sent on the LAN but not when sent from a remote machine on the internet.
m
0
l
Related resources
a b $ Windows 7
January 24, 2013 11:22:36 AM

The Stealthinator said:
In the future, try not to post big chunks of text that people would get bored reading.

It is normal for the computer to lose internet connection while it is asleep, and then once it wakes up it will take a few seconds before it can detect and establish a connection.

Apart from that, I don't really get what your problem is.


What is your problem? The OP explaining his situation is not "big chunks of text that people would get bored reading" as you would call it. If you feel need to keep this type of persona up, hit the road. We are here to help, not criticize.

Sounds like someone needs to freshin' up on the forum rules.

Go HERE for more help!
m
0
l
a b $ Windows 7
January 24, 2013 11:24:32 AM

johnbl said:
Wake over Local area Network is not intended to operate over the internet. It requires ports to be open and forwarded across through all the hops in the route to your machine. You will have the ability to config routers on your own LAN segment only. Most of the internet routers will not forward these packets on to the next router in your traceroute. You will need to find a proxy program to run on your local subnet that you can send a internet signal to. The program will in turn send a wake on LAN broadcast to the machine you want to wake.

it is a pretty simple program, I would think it should be pretty easy to find one


You are correct in regards to it being very localized.

@OP: I would recommend you do some pros vs. cons comparisons as to why you want to enable something like this because as johnbl mentioned you will have to have certain ports open and your firewall configured to allow those ports on a consistent basis which unfortunately can be a potential back door for someone to come in and compromise your system.

EDIT:

Also go into your network connections, right click your LAN connections and choose properties and then click on Configure. Click on the Power Management tab and make sure that all of the checkboxes except for the top one is checked. This will prevent the computer from turning off the NIC when it's not in use.
m
0
l
January 24, 2013 12:04:32 PM

hedwar2011 said:
The OP explaining his situation is not "big chunks of text that people would get bored reading" as you would call it.

Go HERE for more help!

The link you provided says:
Quote:
Use paragraphs, and avoid walls of text that are hard to read.


So yes, it is a large chunk of text. Make sure you've gone through the link first before telling me.
m
0
l
February 1, 2013 8:01:26 PM

If I change my LAN Connection to uncheck "Allow the computer to turn off this device to save power" it also greys out and disables the feature "Allow this device to wake the computer" which defeats the purpose. Even with it checked it is always awake enough to start the computer over the LAN. It just stops listening to the Internet.

(I wanted to add this comment to my first post but it would have added to such a "large chunk.")

The point about reduced security is a good point. At this point it's more of a technical challenge for me an I'm not an IT pro.
m
0
l
!