Sign in with
Sign up | Sign in
Your question

Dell Latitude C600 battery problem

Last response: in Computer Brands
Share
Anonymous
September 5, 2004 4:28:43 PM

Archived from groups: alt.sys.pc-clone.dell (More info?)

My Dell Latitude C600 is four years old using the original battery.
Recently, the battery life has been getting smaller.

But a few days ago, I am now getting NO use out of the battery. That is,
when I unplug the AC power, the computer immediately goes dead, despite
Windows XP and the BIOS telling me it is 100% charged and charging. It seems
that maybe there is some electrical contact not being made up or something
similar.

Any idea what is going on? I would like to know if I buy another battery
that it is going to work - but I have a suspicion the same thing might
happen with any battery I install!

Bud H.
Anonymous
September 5, 2004 7:10:38 PM

Archived from groups: alt.sys.pc-clone.dell (More info?)

"Bud H" <budh@REMOVETHISameritech.net> wrote:

>My Dell Latitude C600 is four years old using the original battery.
>Recently, the battery life has been getting smaller.
>
>But a few days ago, I am now getting NO use out of the battery. That is,
>when I unplug the AC power, the computer immediately goes dead, despite
>Windows XP and the BIOS telling me it is 100% charged and charging. It seems
>that maybe there is some electrical contact not being made up or something
>similar.
>
>Any idea what is going on? I would like to know if I buy another battery
>that it is going to work - but I have a suspicion the same thing might
>happen with any battery I install!

You got four years out of a two-year battery. Count your
blessings and go buy a new one. The new one will also have a
two-year life. I wouldn't count on getting four years out of it.
--
OJ III
[Email to Yahoo address may be burned before reading.
Lower and crunch the sig and you'll net me at comcast.]
!