Sign in with
Sign up | Sign in
Your question
Solved

Ahci

Last response: in Windows 7
Share
January 28, 2013 6:50:55 PM

Hello,

I’ll try and keep this short
2 weeks ago I reinstalled win 7 I did a clean install on my ssd Intel 330 120 GB and I could have sworn I enabled ahci.
Yesterday I found out it’s installed in ide mode so I did the registry trick and changed it to ahci in the bois and it booted,
But it’s still in ide mode the bois is still in ahci but windows is in ide mode.
I even tried putting it in raid mode but to no avail.
So I downloaded the ahci drivers from gigabyte and I formatted and reinstalled (I have backup on a different drive) and it was still in ide mode.
So now I restored my backup but I’m stumped
Please help me.

My specs:
I3-2120
Hd 6770\5770
Ga-h77-d3h
8 gb of g-skill ram at 1333mhz
Intel 330 ssd 120 gb
Samsung hd103sj
Samsung hd322hj

If you need more info just say so.

Thank you very much
-Adam Ericson

More about : ahci

January 28, 2013 7:20:05 PM

no the computer boots fine and works but it's still stuck on ide mode
m
0
l
Related resources
January 28, 2013 7:23:42 PM

I know this isn't what you want to hear but I don't believe there is anyway to switch between the interface modes after Windows is installed. From college, through several IT jobs, and multiple articles, I've always been told/read that you can only change it Pre-Installation and not afterwards.

TLDR: I think you have to reinstall Windows with the correct setting in the BIOS.

:-(
m
0
l
January 28, 2013 7:32:23 PM

Well i did do that 3 times already but it's still in stupid ide mode
And on the plus side ever since i restored my backup with Acronis True Image Home 2013
And i restart i get "boot mgr is missing" so i pop in my windows 7 dvd and i hit "bootrec /fix mgr" and it does not work the only way to boot is by using Hiren’s BootCD.
I know i need to reformat but how can i get the bloody drivers to work.
Help in a few more this i goanna kill myself in skyrim .... :) 
m
0
l

Best solution

January 28, 2013 7:40:46 PM

Your motherboard should have come with a CD that has the AHCI driver on it. After backing up your data and what not, begin the Windows 7 installation. When it asks you to format your drives there should be an option to "Load Driver". Select that, then eject the Windows 7 disc and insert your motherboard disc. You should be able to browse the motherboard disc for the AHCI driver. Find it, and select the driver. The driver should install. Once that's done eject it and insert the Windows 7 disc once again and proceed with the installation.

I hope that helps.
Share
January 28, 2013 7:45:07 PM

I'll report back in 16-18 hours (got school)
and i did that with my flash drive loaded with the driver from the web site but i'll try with the disk
and if it work's i will put a shrine for you and pray every night.
m
0
l
January 28, 2013 7:54:12 PM

You shouldn't need any third party drivers for this. Go into you BIOS settings and set it to AHCI. Make sure that you F10 before exiting the BIOS. Then just install windows 7. Windows will install with whatever the BIOS is set at. If not there is a hardware malfunction in your sata controller on the motherboard.
m
0
l
a c 229 $ Windows 7
January 29, 2013 11:44:14 AM

Kindredsouls said:
I know this isn't what you want to hear but I don't believe there is anyway to switch between the interface modes after Windows is installed. From college, through several IT jobs, and multiple articles, I've always been told/read that you can only change it Pre-Installation and not afterwards.

TLDR: I think you have to reinstall Windows with the correct setting in the BIOS.

:-(


Yes, there is a way and it's supported by Microsoft. See the link ex_bubblehead posted.
m
0
l
January 29, 2013 4:00:12 PM

Thank you all
In the and after reformatting 3 times today
installin Intel RST made the trick
my scrore in as ssd went from 303 to 450

so thats good.
m
0
l
a b $ Windows 7
January 29, 2013 7:23:50 PM

adamdbz said:
Thank you all
In the and after reformatting 3 times today
installin Intel RST made the trick
my scrore in as ssd went from 303 to 450

so thats good.




cool beans. Please select your best answer.
m
0
l
January 30, 2013 4:18:23 AM

Best answer selected by adamdbz.
m
0
l
!