Sign in with
Sign up | Sign in
Your question
Solved

PC Clock keeps going back one hour exactly every boot on Win 7

Last response: in Windows 7
Share
May 14, 2010 10:11:42 AM

Hi -

Have Windows 7 Ultimate x64 and the clock keeps going back exactly one hour practically every time I reboot. This has been happening ever since i thing we went into GMT+1 hr (British Summer Time); I have tried all the different internet sync services offered, have tried having none, have tried turning off the daylight -saving time auto-adjust, but it just keeps returning to exactly one hour behind the actual time. I figure if it was a bios battery problem then it wouldn't be exactly one hour behind like that... I've had bios flat batteries before (not on this PC) and I was getting crazy dates and times like 2094 and any time of the day/night. Any ideas? The internet sync pulls in in line every two days or so I think, but it's out by that hour the rest of the time.

Sys spec:

Win 7 Ultimate x64 dual boot with OS X Leopard 10.5.7 (using BootThink v1)
Sony Vaio VGN-NR280E
ICH8/Mobile Intel 965 Express Family chipset
Intel GMA X3100 Video (QE/CI enabled)
Intel Core 2 Duo 1.66MHz T5450 CPUs
4GB PC2-5300 667 DDRII RAM
200GB Fujitsu Fast SATA HDD

Thanks

Best solution

May 14, 2010 10:43:04 AM

Check the time in your BIOS maybe? If not check to see if you have any widgets enabled whereby it syncs the clock time.
Share
Related resources
Can't find your answer ? Ask !
May 14, 2010 3:48:21 PM

Check to be sure you have all your updates. What can happen as well, in the US, within the last couple of years they changed the days that daylight savings time takes effect. Could be that your software needs a patch to tell it that if the same is true for you. Al;so, in your clock, check your time zone setting. I've seen it happen that a system was older, needed that update I mentioned, and it was set to update time with the web, so what I think actually happened was that I had to check the time zone and turn off the updating so that it would stop what you are describing. One of those weird issues.

But to check the settings for syncing the internet time, click the clock in the start menu, click change date and time settings. Click on Internet Time, click change settings. In there there should be a box to uncheck to disable it syncing with the web. But check the time zone first. If it keeps time on leopard, the cmos battery should be fine, it would have to be a software issue.

And incidentally, at least on the 20 inch iMacs I've worked on, if the cmos battery dies, they would not boot. Just give you a series of beeps. Replaced the cmos battery, powered right up. Strange to me too......But that was actually what apple told me to check and it worked...go figure.
m
0
l
May 14, 2010 6:44:56 PM

OK, sorted that little problem out... my BIOS clock was still one hour behind. Sure baffles me why it changed with the clocks twice a year for the last 2 or so years though... maybe because I'm now using a Bootloader (BootThink)?

Thanks for your time, yo
m
0
l
!