Closed Solved

Alienware battery not charging

I've looked all over for solutions to this problem and can't find any that work for me. I have a Dell Alienware M15X with a 9cell battery that won't charge. Specifically the battery is dead and the system says "battery not detected", although it used to just say "battery plugged in, not charging." Now I've tried EVERYTHING I can find short of buying a new battery. Here's what I've done so far -

Turn off and unplug the system and batteries, hold the power button down.
Take the battery out, turn off, turn back on, log in and put the battery back in.
Toggle the FN and F2 key to turn the battery on.
Uninstalled the battery drivers and reinstalled.
Various other combinations of these, I've been frustrated...

None of these has worked. The charger works fine so I can still use the laptop and I know its technically called a desktop replacement but this is ridiculous.
14 answers Last reply Best Answer
More about alienware battery charging
  1. how old is the battery. Those things do have an expiration date, mind you. So, if it anywhere above 3 years old, face it, it just died, you will need to purchase a new one.
  2. The battery is less than six months old.
  3. you need to check the leads from the battery to motherboard, both sides (battery and motherboard). one might have gotten damaged and now the battery isn't recognized
  4. Best answer
    Probably a new battery is needed. If you left your battery out for a while, and used your laptop as a desktop, I think it might of died out. That is what happened to mine. I never unplugged my laptop for 2 months, and when I finally decided to take it out again, the battery did not charge. New battery is probably needed.
  5. Sorry I'm not very familiar with batteries and connectors and such. As far as I can tell the motherboard and battery look the same as when I bought them. In fact dell replaced the motherboard a couple months ago. As for the battery dying out I shouldn't of, I used my system for school mostly so I dragged it along with me every other day.
  6. Get a multimeter and select DC volts and test the voltage across the battery - charged up it is around 11.1 volts ... it is is much lower (and I imagine it is) then your battery is shot.

    Note since the charger is still supplying power to the laptop it is unlikely to be the issue.

    Test it and post back your answer ...

    :)
  7. So Alienware finally let my warranty go through and sent me a new battery. The new one works fine so I was curious what the problem was. I called their services and inquired about the issue. Apparently one of the nine cells in my battery went dead, so there you have it, one faulty cell took down my battery and made it useless.
  8. Best answer selected by ragenalien.
  9. Same happening to me my laptop is 13ish days old (got it for christmas) I am only 11 but worked with my dad as a computer engineer my whole life and im fudged for ideas help pleaaase ? it cant need a new one can it ?
  10. My Alienware 18 also have same problem...I have new battery.. what should I do to install the new battry?should I charged the battry first or just plugin the battery and switch on the laptop?
  11. ragenalien said:
    The battery is less than six months old.


    My son is experiencing the same problem. He was told by Alienware that it is likely an update that disabled the charging system.
    They can undue the software but only on an update that requires at least a 10% charge of the battery. So they are saying the battery will have to be replaced to have at least the 10% CHARGE. Even with this they say there is a 50/50 chance that this won't fix it and could cause permanent damage to the motherboard. WHAT A GREAT SOLUTION.! He forgot to ask if this is a alienware, ms update or something viral.
    Anyone else know what this "UPDATE" is. restoring to a earlier time did not fix it.
  12. I need help too, i'm have a similar situation. So if I order a new battery, does it requires a technician to replace it? Or I can do it myself?
  13. I have an Alienware m18 that presented the identical issue this morning. I tried removal and reinstall of the battery to no avail.
    I ran Alienware diagnostics from the boot menu that showed my battery as having 100% capacity, 52% charge.
    I then rebooted using F2 into bios and noted on the first page that my Alienware power supply was showing as "unknown". I unplugged the AC side of it and replugged it in. That immediately changed to "240W". I saved changes and rebooted. My battery is now charging (61% and charging as I write this).
  14. the solution to my battery problem on my x18 was to unplug everything, turn the computer upside down to look for where to remove the battery which infact is a technitions job on this particular device, so I'm not trying to remove the battery.

    the laptop had been plugged in for quite awhile and had even slept whilst being plugged in.

    so after removing all the cables and turning the laptop upside down, and having had the computer completely shut down...I turned it back up, still with the power off and plugged the power cable back in and waited to see if the bios leds would light up...which they did. I then powered the computer back on and now the battery is charging.

    so i think for some people the solution is simply to shut down, disconnect all the plugs. wait a few moments. replug the power and make sure the bios charger light comes on, and then reboot. Also, because it's alienware it wouldn't suprise me if the reason it wasn't charging is because the advanced motherboard expects you to drain the battery at intervals.

    hope it helps.
Ask a new question

Read More

Battery Alienware Laptops