Sign-in / Sign-up
Your question

At witt's end. All playback devices "not plugged in".

Tags:
  • Windows 7
Last response: in Windows 7
February 5, 2013 9:52:39 AM

Okay, I'm about to go off the deep end with this thing.

Been working on this "rig" (PoS Compaq SR5350F) for hours upon hours now.

Machine came in with Vista x64. Customer wanted to upgrade to Windows 7 among other things. Upgraded their RAM, installed an HD6670 and sold 'em an OEM Windows 7 Home Prem x64. Formatted, etc, all was good.

Today, customer gets ahold of me and says sound's not working. Figure they probably just muted it or something. No big. They bring the rig in.

First thing I notice is that once it's on the bench, red X thru the speaker icon on the task bar saying "No speakers or headphones are plugged in." Computer's calling me a liar because I know I plugged in the speakers.

Double-check. Yup. Speakers are plugged in.

Pop open the Sounds in the Control Panel and notice that all of the playback devices are greyed out and "not plugged in"..what the *&^@?

6670 has HDMI playback
Onboard is Realtek HD audio, which was default.

Now both playback devices were greyed out and "not plugged in".

So I eventually give up and format 'em (Glad Vista and 7 make this so painless) and got a fresh OS put back on it..

Same thing.

HDMI playback greyed out with "Not plugged in"
Realtek HD audio greyed out with "Not plugged in"

Both devices are properly installed in the device manager with the latest drivers from ATI/Realtek

Upon removal of the 6670 and, of course, the HDMI playback device, Realtek HD is still greyed out with "Not plugged in"

Upon disabling of the Realtek HD and reinstallation of the HD6670, HDMI playback is still greyed out and "Not plugged in"

So I think "damnit all.." and get a stand-alone USB headset.

Plug it in.

Install it.

"Not plugged in"

Open up a PCI soundblaster.

"Not plugged in"

Okay, this computer's fracking with me now. It's 4:00 in the morning and I'm pissed.

Anyone have any insight on this?

More about : witt end playback devices plugged

February 5, 2013 3:50:02 PM

Did you reset the BIOS or something when you upgraded it? Go into BIOS and check for "enable onboard sound" or something.
m
0
l
February 5, 2013 8:54:35 PM

BIOS has 3 options for the onboard audio.

"Auto"
"Enabled"
"Disabled"

It makes no difference to any audio device what the onaboard audio's BIOS setting is. Even with the onboard Realtek HD disabled, it still won't allow the HDMI audio, a PCI Soundblaster or a USB headset to operate.
m
0
l
Related resources
a b $ Windows 7
February 5, 2013 9:00:45 PM

Do you have any hair left mate lol, sounds like a very irritating problem.

is the chipset driver installed? i know its an obvious driver to install first but just in case it was forgotten.
m
0
l
February 5, 2013 10:26:46 PM

Unfortunately, there is no chipset driver offered by Compaq/HP or from ASUS as the mobo's OEMer, and Intel only offers the chipset driver with the display driver and that's all installed and functioning properly.

The more I think about this the less sense it makes, and that's what's driving me crazy here.
m
0
l
a b $ Windows 7
February 6, 2013 12:30:36 AM

I know chipset drivers are generally required for some functions on the motherboard to work properly and being an older system onboard sound might be one of those not properly supported under Win7 and could be something missing.

Compaq is Hp now so driver support should come from them if they have any.

Found a driver support page from hp for Compaq Presario SR5300 series.

http://h20000.www2.hp.com/bizsupport/TechSupport/Driver...

Vista drivers should work with Win7, didnt find 'chipset driver' but maybe try your luck with their sound driver, it might include something else Win7 doesn't.

This is a link prior to the driver page i gave above, its a long list of older Compaqs.
http://h20000.www2.hp.com/bizsupport/TechSupport/Produc...
m
0
l
a b $ Windows 7
February 6, 2013 1:52:01 AM

This may sound rather crazy but go into Services and check to make sure that "Windows Audio" is started and set to Automatic.

There's more info HERE in regards to it.

You could also try the M$ Fix-It found HERE .
m
0
l
February 7, 2013 4:52:42 AM

The audio driver Compaq/HP offers (The Vista x64 driver) is a Realtek driver, and it's among the many Realtek drivers I've tried without success.

MS Fix-It does the same thing the Windows 7 automated fix tries to do, and fails the same way.

Windows Audio service is started and running.

I'm thinking the only thing that's going to fix this computer is a moderate amount of explosives out in the parking lot...
m
0
l
a b $ Windows 7
February 7, 2013 9:53:34 AM

Not sure how you're going with it, just been digging around a bit for some info and some suggestions.

Some details i've come across regarding PoS Compaq SR5350F

Manufacturer name: ASUS IPILP-LC
HP/Compaq name: Lancaster8-GL6

http://www.asus.com/Motherboard/P5GCMXGBL/#support_Down...
^^
This is as close as i can get to a chipset driver from Asus for the 945gc family without knowing specifics, it might work.

Its flaming hard to know the exact motherboard model Asus was using and giving it a name like IPILP-LC and 945GC generically makes searching almost impossible... Anyhow, being the same chipset family (945gc) and similar memory specs (DDR2 667), the chipset driver may give support for the same features including audio chip as the original chipset driver.

Was the computer preloaded with an operating system from Compaq? thats the only reason im thinking it may have something to do with the chipset driver as it may have been lost when the hdd was formatted.

Also, have a look for a model number printed on the motherboard. If there is one, it may help you find more specific chipset drivers from Asus.
m
0
l
February 8, 2013 12:20:22 PM

The machine had Vista x64 loaded on it from Compaq. It worked for a few months without issue with 7 x64 and the HD6670. That's the weirdest part here.

I'm going to reinstall Vista on it, see if that works and then, if it does, do an upgrade-install of Windows 7, see if I get anywhere with that.

This has just been the most astronomically retarded problem I've ever faced..
m
0
l