Sign in with
Sign up | Sign in
Your question

Win 7 PC won't wake from longer sleep

Tags:
Last response: in Windows 7
Share
February 8, 2013 11:36:40 AM

All,

I recently built my first PC - AMD FX8350 on an Asus M5A88M motherboard. Running Windows 7, set up mostly as default. Newest drivers on everything.

The sleep functionality (using the default Balanced mode) had been working fine as far as I could tell. I'd walk away from the computer for a while, or leave it on overnight, and come back to find it asleep. A few taps on the keyboard or a push of the flashing power button would wake it up.

Recently, I've been having trouble waking the computer from longer sleeps (overnight). Nothing seems to wake it - the mouse, the keyboard, or the power button - I get no fans or anything, the system seems locked up tight. I actually have to switch off the power supply and then turn it back on. Only after that can I hit the power button and it resumes. For short sleeps (a couple of hours), everything works as it should.

I only have it set to sleep after 30 minutes (hybrid sleep actually). I have hibernate set to never. Monitor turns off after 10 minutes. Hard drives off after 20 minutes. These are the default settings for Balanced. As far as I can tell, there should be no difference to Windows if the PC has been sleeping for 1 hour or 12 hours, there are no different settings that kick in after a longer period of time.

Recently I converted from a PS/2 to a USB keyboard - that's been the only change. When I run powercfg, it shows the mouse, keyboard, and Realtek device (presumably the power button) as the ones that would wake the computer.

I've seen a lot of reports from others of similar problems, but none that describe my symptoms exactly. I've tried all the troubleshooting I've read and can't find anything that would help me.

Any thoughts? Any chance it's hardware instead?

Thanks.

More about : win wake longer sleep

February 8, 2013 11:42:13 AM

Let me know it seems since I moved to ssd this is a problem I encounter as well, but only if it sleeps more than 12 hours
m
0
l
a b $ Windows 7
February 8, 2013 1:54:50 PM

mooch91 said:
All,

I recently built my first PC - AMD FX8350 on an Asus M5A88M motherboard. Running Windows 7, set up mostly as default. Newest drivers on everything.

The sleep functionality (using the default Balanced mode) had been working fine as far as I could tell. I'd walk away from the computer for a while, or leave it on overnight, and come back to find it asleep. A few taps on the keyboard or a push of the flashing power button would wake it up.

Recently, I've been having trouble waking the computer from longer sleeps (overnight). Nothing seems to wake it - the mouse, the keyboard, or the power button - I get no fans or anything, the system seems locked up tight. I actually have to switch off the power supply and then turn it back on. Only after that can I hit the power button and it resumes. For short sleeps (a couple of hours), everything works as it should.

I only have it set to sleep after 30 minutes (hybrid sleep actually). I have hibernate set to never. Monitor turns off after 10 minutes. Hard drives off after 20 minutes. These are the default settings for Balanced. As far as I can tell, there should be no difference to Windows if the PC has been sleeping for 1 hour or 12 hours, there are no different settings that kick in after a longer period of time.

Recently I converted from a PS/2 to a USB keyboard - that's been the only change. When I run powercfg, it shows the mouse, keyboard, and Realtek device (presumably the power button) as the ones that would wake the computer.

I've seen a lot of reports from others of similar problems, but none that describe my symptoms exactly. I've tried all the troubleshooting I've read and can't find anything that would help me.

Any thoughts? Any chance it's hardware instead?

Thanks.

I know the problem. It's a defect in the software hardware compatibility.
It happens all the time, on many systems. And it's been going on for years, in all versions of the operating system.
No matter XP, win 2000, Vista, Win 7 etc...etc...the same problem in all of the products. And the manufacturer has never done a thing about fixing the bugs...
despite the repeated complaints, that have persisted for years and years. (there are also compatibility bugs in automatic updates, and these problems have never been fixed either)
DON'T expect sleep hibernate, standby to work properly. On many systems, it WON'T! Stop pulling your hair out...
Windows contains a number of (very irritating) "Automatic Features" that are supposed to "Save Power"
A. When these features are enabled, it causes a bunch of problems.
B. Windows shuts down your system to sleep, hibernate, standby, etc..etc...
C. After shutting down system to "save power" the system malfunctions when you try to wake it up again...and locks up, freezes, etc...
It locks the mouse, it locks the keyboard, it shuts off the display, and locks out the hard drive, it shuts off USB devices, etc...etc...
D. This will cause you to pull your hair out, and go to the funny farm...(those nice young men in their pretty white coats)
E. Make it stop, please make it stop.
F. Shut off all these (very irritating) "features" and USE your computer (for a change):

Click Start, Click Control Panel, Click ( in power options) Choose a Power Plan
Check the Box that says "high performance"
Click "change plan settings"
Turn off display: set to NEVER
Put the computer to sleep: set to NEVER
Click: Change advanced plan settings
Select "high performance" from the drop down menu
Scroll down the list: Click on the + signs to expand the choices for each item on the list.
Require a password on wake up: set to NO
Hard disk: turn off the hard disk: set to NEVER
Wireless adapter settings:
Sleep: set to NEVER
Allow Hybrid sleep: set to NEVER
Hibernate after: set to NEVER
Allow wake timers: set to disable
USB settings:
USB selective suspend setting: set to NEVER
Power Buttons and lid:
Power button action: Setting: set to shut down
Sleep Button Action: set to: do nothing
PCI Express:
Link State Power Management, Setting: OFF
Processor Power Management:
System Cooling Policy: setting: Active
Display
Turn off display after: setting: NEVER
Multimedia Settings:
When Sharing Media: Setting: Prevent idling to sleep
When Playing Video: Setting: Optimize Video
Click APPLY
Click OK

Go into the power profiles,
set standby, hibernate and sleep to OFF
leave the monitor standby ON, that's OK (maybe not, try OFF)
Set the Hard Drive standby to NEVER
Set system Performance to MAXIMUM, not "quiet mode."

Open the bios set up and make sure "cool and quiet" is OFF. (AMD)
If there is a power saver or a "quiet mode" in the bios, shut it off...
There may be a performance setting in the bios setup you have...make sure it's cranked up to max.
in the bios, see that the allocation for video, if available, is maxed.

Now open the hardware manager profiles...
click start
click computer
click system properties
click device manager
double click on mice and other pointing devices
right click on HID compliant mouse
left click on properties
click on the power management tab
UN-check the box that says: "allow the computer to turn off this device to save power." (there is now NO check mark in this box)
click OK

Now repeat this procedure for all mice, monitors, keyboards, and ALL USB ports on the device manager list.

You must open ALL the devices one at a time, as above, and turn off the power saver, for each device.


m
0
l
Related resources
a b $ Windows 7
February 8, 2013 2:17:05 PM

I have seen a BIOS that had a EU power setting that actually fully turns off power to your USB devices after a sleep. This prevents USB devices from being able to wake up a computer. Check your BIOS and make sure it is not selected.
The option was added because of a European Union regulation to get computer to save power. (some motherboards did not take much care in how they did things)

otherwise you might want to check for BIOS updates. It is very common to have fixes to sleep states bugs in the BIOS
m
0
l
February 18, 2013 9:33:51 AM

Thanks all.

I took a look for an "EU power setting" - nothing on my BIOS that I can find. I also forced it to "S3" instead of "Auto" or "S1", with no change.

Basically, the computer is waking fine if it's been asleep for 15 minutes or an hour or two. When I leave it overnight, it won't wake up with any of the keyboard, mouse or power button.

And I'd really rather not turn it off altogether...

I may plug my PS/2 keyboard back in to see if it's any different. And I'll temporarily disconnect my new printer. These are the only two system changes made around the time this started.
m
0
l
February 28, 2013 2:06:26 AM

I tinkered with a lot of stuff and got it working. Unfortunately, I don't know which change did it, but here's what I did:
- Shut off the ability of the network controller to wake the computer.
- Shut off allowing the compouter to power down all of the USB hubs in device manager.
- Shut off USB selective suspend setting.

I had noticed that the system was not sleeping right either. When I looked in Event Viewer, I saw it would try to sleep and then awaken within 1 minute each time. It was on that time that it did eventually sleep that it wouldn't wake back up without powering down.

Knock on wood, it's sleeping at the requested time now and wakes up with a key stroke, mouse click, or power button on the front of the PC.

So I think I actually have the best answer. ;) 
m
0
l
May 17, 2013 3:14:02 AM

mooch91 said:
I tinkered with a lot of stuff and got it working. Unfortunately, I don't know which change did it, but here's what I did:
- Shut off the ability of the network controller to wake the computer.
- Shut off allowing the compouter to power down all of the USB hubs in device manager.
- Shut off USB selective suspend setting.

I had noticed that the system was not sleeping right either. When I looked in Event Viewer, I saw it would try to sleep and then awaken within 1 minute each time. It was on that time that it did eventually sleep that it wouldn't wake back up without powering down.

Knock on wood, it's sleeping at the requested time now and wakes up with a key stroke, mouse click, or power button on the front of the PC.

So I think I actually have the best answer. ;) 


m
0
l
May 17, 2013 3:15:15 AM

I am having the same problem. How do I do these things?
- Shut off the ability of the network controller to wake the computer.
- Shut off allowing the computer to power down all of the USB hubs in device manager.
- Shut off USB selective suspend setting.
m
0
l
June 15, 2013 7:35:18 AM

Mooch91 seems to have the answer, but I don't know how to do those things. Can anybody give me blow by blow instructions, Please. :-)
m
0
l
June 23, 2013 9:32:27 PM

Grumpygrayowl said:
Mooch91 seems to have the answer, but I don't know how to do those things. Can anybody give me blow by blow instructions, Please. :-)

In Control Panel, go to Device Manager
Find Network Adapters & right-click your network controller
You will find the setting in Properties, Power Management

m
0
l
June 23, 2013 9:34:03 PM

Grumpygrayowl said:
Mooch91 seems to have the answer, but I don't know how to do those things. Can anybody give me blow by blow instructions, Please. :-)

The USB Suspend setting is also in Control Panel
Go to Power Options, find your plan & change plan settings
m
0
l
July 13, 2013 10:50:23 AM

As an amendment to Soundguru man's awesome advice - some of you might not be able to get your computer to turn on in order to make these changes. THIS is really simple. With your computer powered on (doesn't matter that the monitors won't turn on) unplug the power cord from your PSU (desktop) or pull the battery and the power cord on a laptop. This will cut the power from your system, but it will also cause all of the power in your PSU to cycle out. This is important. Leave everything unplugged for about 1 minute (unplugged from the computer NOT the wall) and then plug it back in and turn on your system. This will get it booting again so you CAN make the changes that Soundguru man suggests.

Also once you get your computer back up and running, make sure you save your work, close down every program, and do a fresh shut down and then turn on so you don't get stuck in a loop.

Finally, as some other people have mentioned in other forums, the issue is mostly with memory leaks of other applications more than windows itself. If you make sure you close down all programs like browsers, etc. It will give you a greater chance of a successful resume.
m
0
l
August 1, 2013 11:01:26 PM

mooch91 said:
All,

I recently built my first PC - AMD FX8350 on an Asus M5A88M motherboard. Running Windows 7, set up mostly as default. Newest drivers on everything.

The sleep functionality (using the default Balanced mode) had been working fine as far as I could tell. I'd walk away from the computer for a while, or leave it on overnight, and come back to find it asleep. A few taps on the keyboard or a push of the flashing power button would wake it up.

Recently, I've been having trouble waking the computer from longer sleeps (overnight). Nothing seems to wake it - the mouse, the keyboard, or the power button - I get no fans or anything, the system seems locked up tight. I actually have to switch off the power supply and then turn it back on. Only after that can I hit the power button and it resumes. For short sleeps (a couple of hours), everything works as it should.

I only have it set to sleep after 30 minutes (hybrid sleep actually). I have hibernate set to never. Monitor turns off after 10 minutes. Hard drives off after 20 minutes. These are the default settings for Balanced. As far as I can tell, there should be no difference to Windows if the PC has been sleeping for 1 hour or 12 hours, there are no different settings that kick in after a longer period of time.

Recently I converted from a PS/2 to a USB keyboard - that's been the only change. When I run powercfg, it shows the mouse, keyboard, and Realtek device (presumably the power button) as the ones that would wake the computer.

I've seen a lot of reports from others of similar problems, but none that describe my symptoms exactly. I've tried all the troubleshooting I've read and can't find anything that would help me.

Any thoughts? Any chance it's hardware instead?

Thanks.


I had the same issue, turns out there is a hotfix that seems to do the job!

http://support.microsoft.com/kb/977307

Cheers
m
0
l
August 20, 2013 8:02:25 PM

UPDATE: After about a week the Microsoft Hotfix stopped working and all the usual shutdown, sleep, boot issues returned. After a lot of messing around I tried removing my graphics card (Asus GTX660 Ti) With the card removed the problems went away, put the card back in the problems returned. Soooooo to cut a long story short, I put the Graphics Card Back in and set my Windows sound scheme to 'NO SOUNDS', the pc now shuts down, sleeps, awakens no problems. My theory is the PC shuts down and or goes into sleep mode before the Graphics card gets a chance to 'power off' leaving it in a Limbo state. It's been over a week now and the PC is still fine.
m
0
l
January 1, 2014 2:38:27 PM

JackScarlet said:
UPDATE: After about a week the Microsoft Hotfix stopped working and all the usual shutdown, sleep, boot issues returned. After a lot of messing around I tried removing my graphics card (Asus GTX660 Ti) With the card removed the problems went away, put the card back in the problems returned. Soooooo to cut a long story short, I put the Graphics Card Back in and set my Windows sound scheme to 'NO SOUNDS', the pc now shuts down, sleeps, awakens no problems. My theory is the PC shuts down and or goes into sleep mode before the Graphics card gets a chance to 'power off' leaving it in a Limbo state. It's been over a week now and the PC is still fine.


So what you suggest that we should do in order to fix it in simple way?

m
0
l
January 26, 2014 7:18:05 PM

I have the same exact setup and have this same issue, except my video card is a GTX 560 Ti. I am trying the suggested fixes and will report back what I find.
m
0
l
March 21, 2014 5:29:09 AM

bezidebela said:
I have the same exact setup and have this same issue, except my video card is a GTX 560 Ti. I am trying the suggested fixes and will report back what I find.


I have the same problem. If I put the computer to sleep and then wake it up the same day it works great. Whether by keyboard, mouse, or network magic packet from the Roku. But if I wait until the next day or evening NOTHING wakes it up. Has anyone found a solution yet? I don't want it to run 24/7 when we don't use it 24/7. It's basically a media server and right now we don't use it that much.

I don't think I want to shut off the ability of the network controller to wake the computer because I need to be able to use WOL but I have "Shut off allowing the computer to power down all of the USB hubs in device manager" and "Shut off USB selective suspend setting." I also disabled "Allow hybrid sleep". I had to manually tell it to sleep but that is because I didn't know that "hybrid sleep" was the same as plain old sleep. So I am going to test it tonight and see if it wakes up. It will have been asleep since last night.
m
0
l
May 31, 2014 2:20:44 PM

soundguruman said:
mooch91 said:
All,

I recently built my first PC - AMD FX8350 on an Asus M5A88M motherboard. Running Windows 7, set up mostly as default. Newest drivers on everything.

The sleep functionality (using the default Balanced mode) had been working fine as far as I could tell. I'd walk away from the computer for a while, or leave it on overnight, and come back to find it asleep. A few taps on the keyboard or a push of the flashing power button would wake it up.

Recently, I've been having trouble waking the computer from longer sleeps (overnight). Nothing seems to wake it - the mouse, the keyboard, or the power button - I get no fans or anything, the system seems locked up tight. I actually have to switch off the power supply and then turn it back on. Only after that can I hit the power button and it resumes. For short sleeps (a couple of hours), everything works as it should.

I only have it set to sleep after 30 minutes (hybrid sleep actually). I have hibernate set to never. Monitor turns off after 10 minutes. Hard drives off after 20 minutes. These are the default settings for Balanced. As far as I can tell, there should be no difference to Windows if the PC has been sleeping for 1 hour or 12 hours, there are no different settings that kick in after a longer period of time.

Recently I converted from a PS/2 to a USB keyboard - that's been the only change. When I run powercfg, it shows the mouse, keyboard, and Realtek device (presumably the power button) as the ones that would wake the computer.

I've seen a lot of reports from others of similar problems, but none that describe my symptoms exactly. I've tried all the troubleshooting I've read and can't find anything that would help me.

Any thoughts? Any chance it's hardware instead?

Thanks.

I know the problem. It's a defect in the software hardware compatibility.
It happens all the time, on many systems. And it's been going on for years, in all versions of the operating system.
No matter XP, win 2000, Vista, Win 7 etc...etc...the same problem in all of the products. And the manufacturer has never done a thing about fixing the bugs...
despite the repeated complaints, that have persisted for years and years. (there are also compatibility bugs in automatic updates, and these problems have never been fixed either)
DON'T expect sleep hibernate, standby to work properly. On many systems, it WON'T! Stop pulling your hair out...
Windows contains a number of (very irritating) "Automatic Features" that are supposed to "Save Power"
A. When these features are enabled, it causes a bunch of problems.
B. Windows shuts down your system to sleep, hibernate, standby, etc..etc...
C. After shutting down system to "save power" the system malfunctions when you try to wake it up again...and locks up, freezes, etc...
It locks the mouse, it locks the keyboard, it shuts off the display, and locks out the hard drive, it shuts off USB devices, etc...etc...
D. This will cause you to pull your hair out, and go to the funny farm...(those nice young men in their pretty white coats)
E. Make it stop, please make it stop.
F. Shut off all these (very irritating) "features" and USE your computer (for a change):

Click Start, Click Control Panel, Click ( in power options) Choose a Power Plan
Check the Box that says "high performance"
Click "change plan settings"
Turn off display: set to NEVER
Put the computer to sleep: set to NEVER
Click: Change advanced plan settings
Select "high performance" from the drop down menu
Scroll down the list: Click on the + signs to expand the choices for each item on the list.
Require a password on wake up: set to NO
Hard disk: turn off the hard disk: set to NEVER
Wireless adapter settings:
Sleep: set to NEVER
Allow Hybrid sleep: set to NEVER
Hibernate after: set to NEVER
Allow wake timers: set to disable
USB settings:
USB selective suspend setting: set to NEVER
Power Buttons and lid:
Power button action: Setting: set to shut down
Sleep Button Action: set to: do nothing
PCI Express:
Link State Power Management, Setting: OFF
Processor Power Management:
System Cooling Policy: setting: Active
Display
Turn off display after: setting: NEVER
Multimedia Settings:
When Sharing Media: Setting: Prevent idling to sleep
When Playing Video: Setting: Optimize Video
Click APPLY
Click OK

Go into the power profiles,
set standby, hibernate and sleep to OFF
leave the monitor standby ON, that's OK (maybe not, try OFF)
Set the Hard Drive standby to NEVER
Set system Performance to MAXIMUM, not "quiet mode."

Open the bios set up and make sure "cool and quiet" is OFF. (AMD)
If there is a power saver or a "quiet mode" in the bios, shut it off...
There may be a performance setting in the bios setup you have...make sure it's cranked up to max.
in the bios, see that the allocation for video, if available, is maxed.

Now open the hardware manager profiles...
click start
click computer
click system properties
click device manager
double click on mice and other pointing devices
right click on HID compliant mouse
left click on properties
click on the power management tab
UN-check the box that says: "allow the computer to turn off this device to save power." (there is now NO check mark in this box)
click OK

Now repeat this procedure for all mice, monitors, keyboards, and ALL USB ports on the device manager list.

You must open ALL the devices one at a time, as above, and turn off the power saver, for each device.




GREAT RESPONSE!

m
0
l
June 25, 2014 12:30:59 PM

I was having the problem of manually putting the windows 7 box into sleep mode and it would not wake up. I built the computer. Turns out I had the one 4 gb RAM module in the wrong slot. I subsequently added a second identical ram module I also put in the incorrect slot. When I added the second module, I had more problems including the video blacking out. I re-read the motherboard manual and corrected the RAM placement, now everything is working fine.
m
0
l
July 3, 2014 3:53:54 PM

With AMD FX6300 and FX6350 and perhaps 8 series. Go to bios. If the CPU north bridge is at default multiplier setting (11X), try to increase the the voltage on the next increment at the max 2 incremental setting where you started. Press sleep button and wake. If it doesn't work, do the same procedure with CPU core voltage. I have experienced this problem before and found out doing this actually solves the problem when I was trying to get the undervolt threshold for the FX6300. Now if I set the northbridge to 10x I haven't figured it out yet. The 10X setting increases the IPC but faced with this issure of video not getting back when I invoke wake.
m
0
l
!