Sign in with
Sign up | Sign in
Your question
Solved

Razer BlackWidow and Synapse Problem 2.0

Last response: in Windows 7
Share
February 13, 2013 12:47:53 AM

I had Purchased the Razer Black-widow not too long ago and i installed synapse with the current version of firmware. When i open up Synapse all i get is please connect a razer synapse 2.0 enabled device. The Keyboard still works as i am typing it right now but when i went to device manager all it said under keyboard was 2 HID Keyboard Device. I went to the control panel and went to devices and printers and there was the black widow i right clicked and it said mouse and keyboard settings.

Please Help :(  im really wanting to use the 5 macro keys



btw its a Black widow ultimate not the 2013 edition
a b $ Windows 7
February 13, 2013 12:50:10 AM

Have you installed keyboard driver along with Synapse software?
m
0
l
February 13, 2013 1:17:02 AM

Soda-88 said:
Have you installed keyboard driver along with Synapse software?

Yes
m
0
l
Related resources
Can't find your answer ? Ask !

Best solution

April 5, 2013 6:31:57 AM

this is typical of razer software, I have a naga as well as a nostro and 2 buddies have blackwidows, one being the 2013 one, and the software for all of our devices is a complete fail. Kinda like the support area and driver area on razers website. They make great peripherals, but when it comes to software, or coding their website, they are well known to fail.

im sorry that i cant provide you any information or help other then reiterating that razer cannot support their devices to save a life. Sorry
Share
April 10, 2013 9:46:27 AM

I recently had the same problem... all i did was re-download synapse. Once i did that i installed it but instead of fully re installing it I clicked the repair option... now it works fine for me!!!
m
0
l
May 6, 2013 8:44:51 PM

KarizmuH said:
I recently had the same problem... all i did was re-download synapse. Once i did that i installed it but instead of fully re installing it I clicked the repair option... now it works fine for me!!!


What repair button? It doesn't show anything like this
m
0
l
October 26, 2013 3:52:32 AM

KarizmuH said:
I recently had the same problem... all i did was re-download synapse. Once i did that i installed it but instead of fully re installing it I clicked the repair option... now it works fine for me!!!


hello and thank you i have dun that seam thing and now it is running :bounce: 
m
0
l
December 25, 2013 7:21:50 AM

Kherzhul said:

What repair button? It doesn't show anything like this


Agreed, there is no repair option.
I have also tried re-installing several times and it doesn't work, I still get "Please connect a razer synapse 2.0 enabled device".
Every single time.
The Razer install software SUCKS, and the Support section of their web site SUCKS.
m
0
l
February 10, 2014 2:27:07 AM

Same problem for me ~
I'm so sad now about this :( 
m
0
l
February 14, 2014 4:07:35 AM

I get this same thing on my mac, unplug the USB and plug it back in. Not a complete fix but it gets the job done temporarily...
m
0
l
April 4, 2014 11:22:14 AM

I get this sometimes and the solution I found was to open up task manager (CTRL+SHIFT+ESC) and find the Razer Synapse process then kill it. Then restart Synapse and it should work. A bit of a hassle, but easier than unplugging and plugging cables or reinstalls each time.
m
0
l
June 30, 2014 5:45:28 AM

Wyldereaper said:
I had Purchased the Razer Black-widow not too long ago and i installed synapse with the current version of firmware. When i open up Synapse all i get is please connect a razer synapse 2.0 enabled device. The Keyboard still works as i am typing it right now but when i went to device manager all it said under keyboard was 2 HID Keyboard Device. I went to the control panel and went to devices and printers and there was the black widow i right clicked and it said mouse and keyboard settings.

Please Help :(  im really wanting to use the 5 macro keys



btw its a Black widow ultimate not the 2013 edition


m
0
l
June 30, 2014 5:47:28 AM

Wyldereaper said:
I had Purchased the Razer Black-widow not too long ago and i installed synapse with the current version of firmware. When i open up Synapse all i get is please connect a razer synapse 2.0 enabled device. The Keyboard still works as i am typing it right now but when i went to device manager all it said under keyboard was 2 HID Keyboard Device. I went to the control panel and went to devices and printers and there was the black widow i right clicked and it said mouse and keyboard settings.

Please Help :(  im really wanting to use the 5 macro keys



btw its a Black widow ultimate not the 2013 edition


m
0
l
June 30, 2014 5:55:25 AM

Okay i see your problem Wyldereaper , we currently tested with Razer Deathstalker and we try to run the synapes 2.0 program and Updated synapse 2.0 and its work fine , you should check out the latest update for the synapse 2.0 and let the update finished their job , remember went the update was running do not turn off or restart the PC or you will get the message" Please connect to a Razer 2.0 enable device " if that's doesn't work please send us your razer data to our razer help center

Team Razer
m
0
l
!