Sign in with
Sign up | Sign in
Your question

BSOD and Issues After Installing USB Hub-Suggestions?

Last response: in Windows 7
Share
February 15, 2013 2:51:59 AM

I bought a mouse, keyboard, and usb hub. I think the latter is causing issues.


INSTALLATION:
I decided my hurting hands could use a new mouse and keyboard. I shelved my bargain bin Logitech gear and bought a CM Storm QuickFire Pro SGK-4010-GKCR1-US and a Corsair M90. I use a plasma tv for a monitor and use a lapdesk, so I purchased 2 usb extension cables and an Anker 4 port usb 3.0 hub (AK-68UNHUB-FW4A) for better accessibility.

Last night I installed the mouse (per Corsair's instructions), restarted, then the keyboard, and restarted again. I plugged in the usb hub into a powered motherboard 3.0 port and restarted yet again with the devices attached. Windows then re-installed all of the drivers but could not find one for the hub after 2 minutes, so I cancelled it (I believe its driver less, not sure). The devices would not work, so I restarted again. My PC would not shut down, so I did a hard shut down and disconnected the hub. The PC took longer than usual to restart. I then waited until I got to the desktop, attached the hub, then the other peripherals. Everything then worked fine.


THE ISSUE: BSOD AND NOT SHUTTING DOWN
The next day (today) the PC starts up ok but when I reach the desktop, the PC makes noises like a device is being disconnected/reconnected over and over again. After 30 seconds, I disconnected the device and went back to my Logitech gear for work. All of the cabling was secure, so there is no apparent reason for this except apparently this hub is known for defects in poor soldering.

Suddenly the PC gets a BSOD :fou:  and I'm pissed. I take really good care of my PC, so I was very surprised. Bluescreenview comes up with: KMODE_EXCEPTION_NOT_HANDLED 0x0000001e 00000000`00000000
00000000`00000000 00000000`00000000 00000000`00000000 caused by
driver: ntoskrnl.exe, caused by address ntoskrnl.exe+75c10, crash address: Nntoskrnl.exe+75c10.

I restart the PC; no more issues. After work, not thinking, I click shut down on my PC and come back after 1/2 hour and it is still trying to shut down. I had to do a hard shutdown yet again.


WHAT I DID:
I checked for problem devices in system info and in the device manager, and nothing came up. Other than

that, I just my usual maintance:Virus Scans (Super Anti Spyware, Spybot, Malwarebytes, Avast, TDSSKiller), Maintenance (chkdsk, scf/scannow, windows memory test, defrag, wise registry cleaner, ccleaner) and backups.

The only thing I can think to do for diagnosis is uninstall/reinstall the hub drivers, if there are any.


QUESTIONS:
Anybody know what the issue could be? Do you think it cooked my motherboard or chipset or maybe damaged the OS or?? Any thoughts on how to diagnose/correct these issues would be greatly appreciated.
February 17, 2013 12:30:22 AM

I hate to double post, but I think I solved the issue, and it might help someone else.

It seems that the issues stem from having legacy usb support enabled in the BIOS. I thought this option was inconsequential and would given me a broader range of USB support, but apparently it can cause issues with some devices. After disabling it, I haven't had any issues.
!