After win7 update, win is asking to format my existing raid

After updating to win 7 ultimate 64bit from win xp 32bit, windows 7 is asking me to format my existing raid partitions (with data on it) before i can use them...(win is installed on different drive)

They do show up and working fine for about 5 - 10 minutes after reboot (fully functional i.e. write read ecs.), but then win 7 disconnects them, and " need to format before u can use them" message...

My controller is Silicon Image SiI 3114 SoftRaid 5 Controller on asus a8n-sli premium mobo, there is quite a bit of data on them, dont wanna loose it...

how do i solve this issue?

thank you in advance,

SIMisEK
5 answers Last reply
More about after win7 update format existing raid
  1. Hi :)

    IS it a legal Ultimate ?

    All the best Brett :)
  2. what type of RAID? if its RAID1, you could plug in a single drive in SATA mode instead of RAID and backup/copy your data to the OS and follow along... if you dont find any resolution that is
  3. I don't see win7-64 drivers for the controller on the Asus site. What drivers did you install?
  4. To Brett928S2:
    The win 7 is legit and its fresh install, i have another sata drive connected and no messages about formating...Its not plugged to my raid array


    To noidea_77:
    Originally i tried to use Beta drivers that are on asus web site, but they didnt work, couldnt see my array at all, after running windows update, i choosed optional update with drivers for my silicon image controller and they worked


    To jgutz2006: Using Raid 0, two drives working as one, with 4 partitions created on array, Originaly created on windows XP pro, same hardware
  5. So obviously the drivers work only partially. The controller recognizes the drivers, but the raid driver doesn't recognize the raid set information in the boot record. But there are driver for 7-64 on the sil page:http://www.siliconimage.com/support/
Ask a new question

Read More

Configuration NAS / RAID Format Windows 7