Sign in with
Sign up | Sign in
Your question

Asrock 870 Extreme3 Ethernet driver

Last response: in Windows 7
Share
February 16, 2013 12:44:59 PM

So I have an Asrock 870 Extreme3 motherboard. It has an ethernet port in it, however whenever I stick my disk in for the drivers my computer completely freezes. I tried downloading the LAN driver from here: http://www.asrock.com/mb/AMD/870%20Extreme3/?cat=Downlo... but it tells me: "The Realtek Network Controller was not found. If Deep Sleep mod is enabled Please Plug the Cable."
I'm not sure if this was the right driver? Even though it seemed to be the only one that makes sense.
a b \ Driver
a b $ Windows 7
February 16, 2013 1:01:20 PM

If you are running Windows 7 64 bit, then at that link the driver Lan driver ver:7017 would be correct. I would try another download off a different server in case it is messed up on one of the servers. Also insure that the current LAN driver is uninstalled (if there is one showing up in the device manager).

Also check in the bios to see that the on board LAN is enabled first.
m
0
l
February 16, 2013 3:53:45 PM

Alright, thanks. I'll check the bios soon to see that. And yeah, no other LAN drivers were showing up in device manager.
m
0
l
Related resources
February 26, 2013 10:15:12 AM

Alright I eventually figured it out. Turns out this controller has some weird problem that after some time it goes into some type of deep sleep mode. The only way to get it to work is to turn your computer off and unplug it for a few minutes... It worked.
m
0
l
a b \ Driver
a b $ Windows 7
February 26, 2013 12:46:29 PM

Power management in Windows still isn't right after all the updates and the motherboard makers only got it worse.

You can turn off the power controls in a number of places, including the bios, the Windows power options control panel, and the properties (power management tab) in the device manager. I usually go with the device manager first, as my power control panel options only allow the monitors to power down after some time, everything else stays on.
m
0
l
!