Sign-in / Sign-up
Your question

'Loading Operating System' Hang in Windows 7 (first boot only)?

Tags:
  • Configuration
  • Windows 7
Last response: in Windows 7
May 24, 2010 8:53:06 AM

Hi There,

I've recently built a new PC and whilst it works I've got a problem I've never come across. When I first switch the PC on the system hangs at 'loading operating system'. Weirdly enough if I then power off and switch back on the Windows 7 OS loads fine.

The install itself went fine, I've checked the disk for errors and bought a brand new disk which had the same problem.

The system is as follows:

Gigabyte GA-P55-UD3 Motherboard
Intel Core I5-750 Processor
GSkill Ripjaws Memory (1333 MHZ) 4 GB
Windows 7
2* Western Digital 500 GB Sata II disks

I have read about AHCI, currently in my BIOS I've set it up to run as IDE, I could try AHCI but I'd need to do the post OS Install AHCI registry editing and install the drivers.

But what gets me is that the system works on the second startup which suggests to me that at some point it can detect the hard disk and boot the OS- could it be that it's using the wrong technology/ connection to read the disk first time round? (as in AUTO/ Large in the Bios).

Any help would be greatly appreciated!

More about : loading operating system hang windows boot

a c 335 $ Windows 7
May 24, 2010 4:59:17 PM

It sounds like you may be experiencing a driver issue. Once the system loads properly, are all of your devices operating correctly? Does system manager show them all ok? Does not sound like a HDD problem. Look at your video and audio drivers, as well as any special devices you may have. If nececassary, go to the vendor or chipset maker (Nvidia or ATI for video) to download and install the latest drivers to see if that clears up your issue. Good luck!
m
0
l
a c 335 $ Windows 7
May 24, 2010 5:01:28 PM

Also, check you BIOS to verify that the system is booting from the correct HDD first. Unless you are using removables drives, stick with IDE (vice AHCI) for best compatibility. Good luck!!!
m
0
l
Related resources
May 28, 2010 11:32:49 AM

Hi Col,

Thanks for your 2 bits of advice but generally I'm a pretty good problem solver. I've done the following:

1) Tried 2 different drives after verifying that both were not faulty. I installed Windows 7 both times successfully but then like I say powered down left them for a few hours/ overnight and then got stuck at the 'loading operating system' screen with flashing cursor.

2) I removed all additional drives and made sure the drive was showing up correctly in the Bios (which it was again both drives). Still had the same thing- not getting past loading operating system.

3) I've checked the motherboard manual, reset CMOS by removing battery to clear any previous issues.

4) I tried running startup repair but again nothing got fixed there....

Like I say every time I power it off and then power it back on again Windows 7 loads perfectly. Whilst this doesn't seem like a big issue I'd really like to figure it out. I'm not particularly bothered about obtaining the AHCI functionality because I don't hot swap...

I'm still wondering if its the geometry so I may try to format in LBA or Large and not using CHS which I think is what I'm on at the moment

Really weird though!
m
0
l
June 1, 2010 10:27:56 AM

Sorry guys, just bumping this thread, has anybody got any ideas?

m
0
l
a c 335 $ Windows 7
June 2, 2010 1:05:26 AM

Been out of the loop for a few days. Sorry for not getting back to you. I agree that you are a solid troubleshooter and have taken the same steps I would have.

I seriously doubt a drive geometry issue is the culprit. Most (all I am aware of) modern MBs detect HDDs flawlessly.

When you installed Win7, did you create a new filesystem or use the one from the previous install? Trying to rule out some oddness with the filesystem.

Do you have MS provided Win7 media, or a downloaded version (like my daughter received via a MS academic version offer)? Could be something corrupted with your DVD. Do you have access to another DVD of the same version you are using?

Are you Linux savvy? If so, I would install Ubuntu or OpenSuse on one of your drives to see if it displays the same issue.

Hope something here helps. HOOAH!!!

m
0
l
June 4, 2010 3:54:06 PM

Hi Col,

Thanks for coming back to me. I did try formatting with different geometries and Windows 7 wouldn't install when it was set to LBA or LARGE only with CHS. In any case that didn't work in any event.

When I installed I went for a completely fresh install off a brand new OEM DVD which I bought on Amazon. But I concede it could be a corruption- but that said I've installed off it a few times now and never encountered any errors or lockups and I'm always very careful to put my discs back in the box.

Looking at this thread: http://www.tomshardware.com/forum/2064-63-windows-insta...

I am going to try shutting down all non-essential devices, so I will unplug my front USB drives from the header, disconnect my modem and switch off the onboard LAN, turn off all non-used devices e.g floppy disk and see if that helps....

I used to stick Ubuntu on my system but I've found I wanted to get rid of it because it plays around with the master boot record.

Thanks for the suggestions, I'll keep this updated.

Cheers,

Pie
m
0
l
June 17, 2010 10:44:30 PM

I had the same issue I changed the bios and restarted my computer it hung up at the same spot. Went back and restored my bios to original and same problem. I unplugged my flash drive and 500gb ex hd restarted came up with no problem.

Don't mean to talk to much but I did this because I had to reinstall windows a couple of time during my build and it would hang up the same way. The only thing I had plugged in at the time was a wireless adapter. I unplugged this adapter and windows installed. I think the problem is in devices that have there driver on a flash drive along with the software application. Windows cannot recognize the device because the software to download and install the device driver is not available yet.
m
0
l